none
Azure Web Sites: NetworkInterface.GetIsNetworkAvailable() always returns false

All replies

  • Hi,

    Since the issue is related to Iaas, I have moved this thread to Web Sites forums for getting a better support.

    Thanks for your understanding.


    QinDian Tang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, March 12, 2013 6:19 AM
  • I suspect we are not allowing you to use this particular API. What exactly are you trying to do?


    Jim Cheshire | Microsoft

    Tuesday, March 12, 2013 1:45 PM
  • Hello,

    We have an error reporting module that checks for network connection. If it doesn't have one then it won't submit /log error reports. This works on Silverlight/winforms/wpf/mvc/webapi (everywhere but azure). It would be nice if this call threw an exception if it's not allowed/implemented.


    -Blake Niemyjski (Software Development Engineer)

    Tuesday, March 12, 2013 1:50 PM
  • I'm not positive that we're blocking that. I base that comment on the fact that it seems unlikely that we would allow you to enumerate network adapters on the VM. I'll see if I can dig up some info on why this is happening.


    Jim Cheshire | Microsoft

    Wednesday, March 13, 2013 1:18 PM
  • Blake,

    We're looking into this. What is your site name in WAWS?


    Jim Cheshire | Microsoft

    Wednesday, March 13, 2013 5:28 PM
  • Hello,

    I need to recreate it but it was useast. Do you want me to reupload the sample?


    -Blake Niemyjski (Software Development Engineer)

    Friday, March 15, 2013 10:07 PM
  • Hi, Blake. No, that's okay. I've filed a bug for us to look into how we're sandboxing that API. I'm pretty sure we're blocking it in WAWS, but something wrong because of what you're seeing.


    Jim Cheshire | Microsoft

    Friday, March 15, 2013 10:13 PM
  • Thanks for looking into this. If you need a sample or any information I'd be more than happy to help.

    -Blake Niemyjski (Software Development Engineer)

    Saturday, March 16, 2013 12:19 AM
  • Hello,

    Were you able to find out if this is being blocked?

    Friday, March 29, 2013 1:05 AM
  • Yes, it's blocked. The thing we're investigating is how we're doing it and why it always returns false. However, for your purposes, you won't be able to use this API in WAWS.


    Jim Cheshire | Microsoft

    Friday, March 29, 2013 4:59 PM
  • Hello,

    Thanks for the update. I hope in the future that this is allowed as it's a simple check that third party libraries might use.


    -Blake Niemyjski (Software Development Engineer)


    Wednesday, April 10, 2013 6:42 PM