none
Nov Azure tools fails to install

    Question

  • Hi,

    Getting this error on installing the Nov. Azure Tools SDK anybody got any ideas?

     

     

    [0490:068C][2011-12-19T14:09:50]: Burn v3.6.2228.0, path: C:\Users\Adrian\Downloads\WindowsAzureTools.VS100.exe, cmdline: ''
    
    [0490:068C][2011-12-19T14:09:50]: Initializing string variable 'ProductShortName' to value 'Windows Azure Tools - November 2011'
    
    [0490:068C][2011-12-19T14:09:50]: Setting string variable 'WixBundleName' to value 'Windows Azure Tools for Microsoft Visual Studio 2010 - November 2011'
    
    [0490:068C][2011-12-19T14:09:50]: Setting string variable 'WixBundleLog' to value 'C:\Users\Adrian\AppData\Local\Temp\Windows Azure Tools for Microsoft Visual Studio 2010_-_November 2011_20111219140950.log'
    
    [0490:068C][2011-12-19T14:09:50]: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\Adrian\Downloads\WindowsAzureTools.VS100.exe'
    
    [0490:068C][2011-12-19T14:09:50]: Detect 2 packages
    
    [0490:068C][2011-12-19T14:09:50]: Registry key not found. Key = 'SOFTWARE\Microsoft\DevDiv\VS\Servicing\10.0\procore'
    
    [0490:068C][2011-12-19T14:09:50]: Setting numeric variable 'DEVENV_PROPLUS' to value 0
    
    [0490:068C][2011-12-19T14:09:50]: Condition 'NOT DEVENV_PROPLUS' evaluates to true.
    
    [0490:068C][2011-12-19T14:09:50]: Registry key not found. Key = 'SOFTWARE\Microsoft\DevDiv\VS\Servicing\10.0\vstdcore'
    
    [0490:068C][2011-12-19T14:09:50]: Setting numeric variable 'DEVENV_PROPLUS' to value 0
    
    [0490:068C][2011-12-19T14:09:50]: Condition 'NOT DEVENV_PROPLUS' evaluates to true.
    
    [0490:068C][2011-12-19T14:09:50]: Setting numeric variable 'DEVENV_PROPLUS' to value 1
    
    [0490:068C][2011-12-19T14:09:50]: Registry value not found. Key = 'SOFTWARE\Microsoft\VWDExpress\10.0', Value = 'InstallDir'
    
    [0490:068C][2011-12-19T14:09:50]: File not found. Path = '\VWDExpress.exe'
    
    [0490:068C][2011-12-19T14:09:50]: Setting numeric variable 'VWDEXPRESS_IDE_FILE' to value 0
    
    [0490:068C][2011-12-19T14:09:50]: Setting numeric variable 'VSDEVENV' to value 1
    
    [0490:068C][2011-12-19T14:09:50]: Detected package: CctSetup.Shared, state: Absent, cached: No
    
    [0490:068C][2011-12-19T14:09:50]: Detected package: CctSetup, state: Absent, cached: Yes
    
    [0490:068C][2011-12-19T14:09:50]: Detect complete, result: 0x0
    
    [0490:068C][2011-12-19T14:09:52]: Plan 2 packages, action: Install
    
    [0490:068C][2011-12-19T14:09:52]: Condition '(VSDEVENV AND DEVENV_PROPLUS) OR VWDEXPRESS_IDE_FILE' evaluates to true.
    
    [0490:068C][2011-12-19T14:09:52]: Setting string variable 'WixBundleLog_CctSetup.Shared' to value 'C:\Users\Adrian\AppData\Local\Temp\Windows Azure Tools for Microsoft Visual Studio 2010_-_November 2011_20111219140950_0_CctSetup.Shared.log'
    
    [0490:068C][2011-12-19T14:09:52]: Setting string variable 'WixBundleRollbackLog_CctSetup.Shared' to value 'C:\Users\Adrian\AppData\Local\Temp\Windows Azure Tools for Microsoft Visual Studio 2010_-_November 2011_20111219140950_0_CctSetup.Shared_rollback.log'
    
    [0490:068C][2011-12-19T14:09:52]: Planned package: CctSetup.Shared, state: Absent, default requested: Present, ux requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
    
    [0490:068C][2011-12-19T14:09:52]: Setting string variable 'WixBundleLog_CctSetup' to value 'C:\Users\Adrian\AppData\Local\Temp\Windows Azure Tools for Microsoft Visual Studio 2010_-_November 2011_20111219140950_1_CctSetup.log'
    
    [0490:068C][2011-12-19T14:09:52]: Setting string variable 'WixBundleRollbackLog_CctSetup' to value 'C:\Users\Adrian\AppData\Local\Temp\Windows Azure Tools for Microsoft Visual Studio 2010_-_November 2011_20111219140950_1_CctSetup_rollback.log'
    
    [0490:068C][2011-12-19T14:09:52]: Planned package: CctSetup, state: Absent, default requested: Present, ux requested: Present, execute: Install, rollback: Uninstall, cache: No, uncache: No, dependency: Register
    
    [0490:068C][2011-12-19T14:09:52]: Plan complete, result: 0x0
    
    [0490:068C][2011-12-19T14:09:52]: Apply begin
    
    [0D5C:091C][2011-12-19T14:09:53]: Caching bundle from: 'C:\Users\Adrian\AppData\Local\Temp\{3975541a-8609-49c4-94d7-10af6af23833}\.be\WindowsAzureTools.VS100.exe' to: 'C:\ProgramData\Package Cache\{3975541a-8609-49c4-94d7-10af6af23833}\WindowsAzureTools.VS100.exe'
    
    [0D5C:091C][2011-12-19T14:09:53]: Registering bundle dependency key: {3975541a-8609-49c4-94d7-10af6af23833}, version 1.6.41103.1601
    
    [0D5C:0C10][2011-12-19T14:09:54]: Moving payload from working path 'C:\Users\Adrian\AppData\Local\Temp\{3975541a-8609-49c4-94d7-10af6af23833}\CctSetup.Shared' to path 'C:\ProgramData\Package Cache\{10EC9A93-A581-4063-A051-0F66D47EBC92}v1.6.41103.1601\WindowsAzureTools.VSCore.VS100.en-us.msi'
    
    [0D5C:091C][2011-12-19T14:09:54]: Applying package: CctSetup.Shared, action: Install, path: C:\ProgramData\Package Cache\{10EC9A93-A581-4063-A051-0F66D47EBC92}v1.6.41103.1601\WindowsAzureTools.VSCore.VS100.en-us.msi, arguments: ' IGNOREDEPENDENCIES="{3975541a-8609-49c4-94d7-10af6af23833}"'
    
    [0D5C:091C][2011-12-19T14:09:54]: Error 0x80070643: Failed to install MSI package.
    
    [0D5C:091C][2011-12-19T14:09:54]: Error 0x80070643: Failed to execute MSI package.
    
    [0490:068C][2011-12-19T14:09:54]: Error 0x80070643: Failed to configure per-machine MSI package.
    
    [0490:068C][2011-12-19T14:09:54]: Error 0x80070643: Failed to execute MSI package.
    
    [0D5C:091C][2011-12-19T14:09:54]: Removing cached package: {10EC9A93-A581-4063-A051-0F66D47EBC92}v1.6.41103.1601, from path: C:\ProgramData\Package Cache\{10EC9A93-A581-4063-A051-0F66D47EBC92}v1.6.41103.1601\
    
    [0490:068C][2011-12-19T14:09:54]: Error 0x80070643: Failed to execute apply.
    
    [0D5C:091C][2011-12-19T14:09:54]: Removing bundle dependency key: {3975541a-8609-49c4-94d7-10af6af23833}
    
    [0D5C:091C][2011-12-19T14:09:54]: Removing cached bundle: {3975541a-8609-49c4-94d7-10af6af23833}, from path: C:\ProgramData\Package Cache\{3975541a-8609-49c4-94d7-10af6af23833}\
    
    [0490:068C][2011-12-19T14:09:54]: Apply complete, result: 0x80070643 restart: No
    
    
    

    Thanks
    Ade.

    Monday, December 19, 2011 2:13 PM

Answers

  • Hi,

    I have since solved the problem. It appears that I didn't have Visual Web Developer installed, It would be much better for the install program to display what the problem was in an easier form, Basically MVC 3 was failing to install but with no reasonable explanation of why.

    On doing a web search there are a few people with the same error recently.

    Thanks

     

    Ade.

    • Marked as answer by Adrian Hirst Tuesday, December 20, 2011 1:35 PM
    Tuesday, December 20, 2011 1:35 PM

All replies

  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Tuesday, December 20, 2011 12:20 PM
    Moderator
  • Hi,

    I have since solved the problem. It appears that I didn't have Visual Web Developer installed, It would be much better for the install program to display what the problem was in an easier form, Basically MVC 3 was failing to install but with no reasonable explanation of why.

    On doing a web search there are a few people with the same error recently.

    Thanks

     

    Ade.

    • Marked as answer by Adrian Hirst Tuesday, December 20, 2011 1:35 PM
    Tuesday, December 20, 2011 1:35 PM
  • [Sorry for my English]


    I had this situation too. Simplest solution is to turn on (probably, it has been turned off) Web Developer component in VS. After that Cloud  project template appeared and Azure SDK and Tools has been installed correctly.


    Slava V.
    Tuesday, March 27, 2012 4:25 PM