none
While trying to retrieve the URL: http://127.0.0.1:81/ Access Denied

    Question

  • When i run my windows azure project i get following error. can anybody help>>>>

    ERROR
     
    The requested URL could not be retrieved
     
    --------------------------------------------------------------------------------
    
    While trying to retrieve the URL: http://127.0.0.1:81/ 
    
    The following error was encountered: 
    • Access Denied. 
    Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.
     
    
    Your cache administrator is webmaster. 
    
    
    --------------------------------------------------------------------------------
    
    Generated Wed, 09 Mar 2011 14:54:43 GMT by proxyserver.opdu-dev.net (squid/2.7.STABLE3) 
    


    Jagjot Singh
    Wednesday, March 09, 2011 2:56 PM

Answers

  • You can't go directly to local host when running the web app as an azure web role because if you do it won't run in the context of the Windows Azure compute emulator. When you seet the startup project to the app, it ran it like you would any traditional web app (either in IIS if you've configured your environment that way or in the debug IIS process using an oddball port). When you set the cloud service as your startup project, its going to package up your cloud service and deploy it into Windows Azure compute emulator to mimic the environment it would be living in when you deploy it to Windows Azure.

    I don't believe the problem is with the application as much as something about your environment. I still think it looks like some type of proxy that's blocking the traffic.

    Something to check is that after you press-F5, open up the computer emulator UI and make sure you see your instance there and running. Right click on the little blue flag that should be in your tooltray and select the compute emulator IO option from the context menu.

     

    • Marked as answer by Jagjot Singh Thursday, March 10, 2011 3:44 PM
    Wednesday, March 09, 2011 4:30 PM
  • If you go into your Windows Internet Explorer Options, try checking "bypass proxy server for local addresses" on the Connections|Lan Settings tab. This will give you direct access to the emulator rather than using any network proxy.

    Andy


    http://blog.bareweb.eu
    • Marked as answer by Jagjot Singh Thursday, March 10, 2011 3:43 PM
    Thursday, March 10, 2011 2:04 PM

All replies

  • Looks like you have a proxy server that's blocking access to anything on port 81. But that's really just a guess.

    Can you tell us anything else about what you're trying to do? Is this with a Windows Azure web role? Does that role make use of the ACS?

    Wednesday, March 09, 2011 3:00 PM
  • I am using VS 2010 Ultimate 64 bit, I installed Azure recently and i create asp.net web project. when i run it i go this error. 

    then i tried by changing startup project to web Application in actual project and it worked. (displayed url was localhost:port etc)

    but when i run project using  windows azure project i get this error. 

    I downloaded helloWorld sample project from web and tried to run and same error. 

    whey its i going to 127.0.0.1 IP Address instead of localhost? do i need to change some permissions. if yes then how? and where?

    Thanks guys


    Jagjot Singh
    Wednesday, March 09, 2011 4:05 PM
  • You can't go directly to local host when running the web app as an azure web role because if you do it won't run in the context of the Windows Azure compute emulator. When you seet the startup project to the app, it ran it like you would any traditional web app (either in IIS if you've configured your environment that way or in the debug IIS process using an oddball port). When you set the cloud service as your startup project, its going to package up your cloud service and deploy it into Windows Azure compute emulator to mimic the environment it would be living in when you deploy it to Windows Azure.

    I don't believe the problem is with the application as much as something about your environment. I still think it looks like some type of proxy that's blocking the traffic.

    Something to check is that after you press-F5, open up the computer emulator UI and make sure you see your instance there and running. Right click on the little blue flag that should be in your tooltray and select the compute emulator IO option from the context menu.

     

    • Marked as answer by Jagjot Singh Thursday, March 10, 2011 3:44 PM
    Wednesday, March 09, 2011 4:30 PM
  • I tried and i can see Service Deployments >> Deployment(18) > Service Details

    >>HelloWorld>HelloWorld_WebRole>0 (there is green circle befor zero)

    But still i cannot open my project. getting same error? how can i checked blocked ports?


    Jagjot Singh
    Thursday, March 10, 2011 9:07 AM
  • If you go into your Windows Internet Explorer Options, try checking "bypass proxy server for local addresses" on the Connections|Lan Settings tab. This will give you direct access to the emulator rather than using any network proxy.

    Andy


    http://blog.bareweb.eu
    • Marked as answer by Jagjot Singh Thursday, March 10, 2011 3:43 PM
    Thursday, March 10, 2011 2:04 PM