none
Problems Getting Virtual Services Installed - Everything's Running and It Says It Isn't.

    Question

  • I am install and run Virtual Server 2005 R2 SP1.  Originally, I had Vista Home, Upgraded to Ultimate and so I have upgraded IE to 7.0.  I installed the IIS 7.0 Manager.

    When installing VS 2005 R2 SP1, I get the message that www and the Manager must be running - but they are!!! 

    Is it possible that some components from 6.0 are still there?  I have turned on almost every program option under IIS and ensured that I have at least included all of options from:
    http://blogs.technet.com/mattmcspirit/archive/2006/10/18/running-virtual-server-on-vista.aspx

    I also have tried disabling and enabling IIS in program options.  I noticed in my startup that it appeared to be calling a version 5 so I tried disabling the www service and manually starting it and then starting the install.  Same message.  It is:

    Installing the Virtual Server Administration Website requires IIS Worldwide Web Service to be installed and the IIS Admin Service running - which they are.  I have also got Localhost running to ensure it is there.

    Is there a command line version to install VS 2005 so I know more about what's going on?

    Any thoughts?
    John Stack
    Saturday, October 11, 2008 9:29 PM

Answers

  •  

    Hi John,

    So, just to confirm, if you go to 'Turn Windows Features on and Off', and expand on Internet Information Services - it should look like the list here http://blogs.technet.com/mattmcspirit/archive/2006/10/18/running-virtual-server-on-vista.aspx but you also need to enable ALL II6 Settings (Just tick the IIS6 Management Compatibility box) then finish.  This should allow you to install correctly.  In all honesty John, I'd firstly remove all IIS components, restart Vista, then, manually add the components back in, using the link above as a guide (including the IIS6 Management Compatibility bits) and then restart Vista again.  Once back on, start the setup for the Admin Console.

    Once installed, when you run the admin console, you may encounter issues around authentication.  To solve this, you'll need to first log onto the Virtual Server Admin Page with IE being 'Run as Administrator' (right click IE, run as..).  Then, user accounts have to be granted administrative privileges for Virtual Server.  To do this select Server Properties from the Virtual Server section of the navigation pane on the Virtual Server web site (you will need to run IE “as administrator” in order to do this). Then select Virtual Server security, Add entry, and create a new entry for your user account with full control. You need to do this because the UAC feature of Windows Vista stops Virtual Server from being able to detect that you’re a member of the administrators group, unless you’re running IE as administrator every time.

    The second step involves adding the URL for the Virtual Server website to the trusted sites via the tools menu in Internet Explorer. You should now be able to open up the Virtual Server administrative website using the icon in the start menu, without needing to run the process “as administrator.

    Matt

    Sunday, October 12, 2008 7:31 AM

All replies

  •  

    Hi John,

    So, just to confirm, if you go to 'Turn Windows Features on and Off', and expand on Internet Information Services - it should look like the list here http://blogs.technet.com/mattmcspirit/archive/2006/10/18/running-virtual-server-on-vista.aspx but you also need to enable ALL II6 Settings (Just tick the IIS6 Management Compatibility box) then finish.  This should allow you to install correctly.  In all honesty John, I'd firstly remove all IIS components, restart Vista, then, manually add the components back in, using the link above as a guide (including the IIS6 Management Compatibility bits) and then restart Vista again.  Once back on, start the setup for the Admin Console.

    Once installed, when you run the admin console, you may encounter issues around authentication.  To solve this, you'll need to first log onto the Virtual Server Admin Page with IE being 'Run as Administrator' (right click IE, run as..).  Then, user accounts have to be granted administrative privileges for Virtual Server.  To do this select Server Properties from the Virtual Server section of the navigation pane on the Virtual Server web site (you will need to run IE “as administrator” in order to do this). Then select Virtual Server security, Add entry, and create a new entry for your user account with full control. You need to do this because the UAC feature of Windows Vista stops Virtual Server from being able to detect that you’re a member of the administrators group, unless you’re running IE as administrator every time.

    The second step involves adding the URL for the Virtual Server website to the trusted sites via the tools menu in Internet Explorer. You should now be able to open up the Virtual Server administrative website using the icon in the start menu, without needing to run the process “as administrator.

    Matt

    Sunday, October 12, 2008 7:31 AM
  • I have de-installed and reinstalled.  I have de-installed and enabled Administrator, logged in, and reinstalled.  I have basically selected to install everything.

    I have enough disk space and memory.

    I have followed your instructions to the letter!
     
    I still get the prompt that says that IIS Web Admin is not running and WWW is not installed.

    Is there a log file somewhere that I can take a look at?  Is there a command prompt with some kind of verbose setting?

    Looking at services, they're running.  I haven't done much except run local host on the server but it comes up with the Splash Screen.

    Is there a list of all services which are supposed to be running somewhere?


    Any thoughts? 



    John Stack
    Sunday, October 12, 2008 10:55 PM
  • BTW, I've got this running already on another machine running XP......  I just wanted to get it on my laptop for demo purposes.

    John Stack
    Sunday, October 12, 2008 10:57 PM