none
Failed Performance Launch and Performance Suspended in App Certification

    Domanda

  • We've put forward a bit of effort to get things to load asynchronously, and we've gotten it to start rendering and servicing input in less than two seconds (when we launch it from the start menu). Still it fails to pass "Performance Launch"

    • Infrastructure Error: Failure occurred while processing application App. Please consider re-running the test and avoid interacting with the application while tests are running.
    • Exception: Infrastructure Error: Failure occurred during testing, Error code -2147023504 occurred while running C:\Program Files\Windows Kits\8.0\App Certification Kit\..\Windows Performance Toolkit\xperf.exe. Please consider re-running the test and avoid interacting with the application while tests are running.

    What's further problematic is that we have NOTHING in our suspend handler:

    void App::OnSuspending(
    	_In_ Platform::Object^ sender, 
    	_In_ SuspendingEventArgs^ args
    	)
    {
    	// Save application state.
    	// If your application needs time to complete a lengthy operation, it can request a deferral.
    	// The SuspendingOperation has a deadline time. Make sure all your operations are complete by that time!
    	// If the app doesn't return from this handler within five seconds, it will be terminated.
    	SuspendingOperation^ op = args->SuspendingOperation;
    	SuspendingDeferral^ deferral = op->GetDeferral();
    
    	deferral->Complete();
    }

    Still, it fails the "Performance Suspend" test with:

    • Infrastructure Error: Failure occurred while processing application App. Please consider re-running the test and avoid interacting with the application while tests are running.
    • Exception: Infrastructure Error: Timeout occurred during testing while running C:\Program Files\Windows Kits\8.0\App Certification Kit\..\Windows Performance Toolkit\xperf.exe. Please consider re-running the test and avoid interacting with the application while tests are running.

    Lastly, "Eliminate Application Failures" with:

    • Failed to stop the app jumbline2_1.0.0.3_x86__7hbznc7cpnna2.

    Why would we be getting these messages?


    Software Engineer, Brainium Studios LLC

    sabato 12 maggio 2012 00:04

Tutte le risposte

  • Hi Brent,

    There are some known issues with performance testing in the WACK. You might want to look at existing posts on this in the Tools forum, and I'll move this over there for further discussion.

    --Rob

    sabato 12 maggio 2012 01:12
    Proprietario