locked
BUG: Sync with Google Calendar isn't working anymore (8004010F)

    Question

  • After updating to beta 2 the synchronization with my Google Calendar (only calendar option is activated, no mail, no contacts) isn't working anymore.

    In my scenario I just want to display the Google Calendar items. I don't manage or update them from the phone.
    My own entries are managed with a real exchange account.

    http://www.darkuniverse.ch/content/div/WP7Mango_Sync_GoogleCalendar.JPG
    Friday, July 01, 2011 11:48 PM

All replies

  • After updating to beta 2 the synchronization with my Google Calendar (only calendar option is activated, no mail, no contacts) isn't working anymore.

    In my scenario I just want to display the Google Calendar items. I don't manage or update them from the phone.
    My own entries are managed with a real exchange account.

    http://www.darkuniverse.ch/content/div/WP7Mango_Sync_GoogleCalendar.JPG

    I can second this... Anybody got any ideas? 
    Monday, July 04, 2011 10:27 AM
  • I am experiencing the same error with an ActiveSync account I added manually...
    Wednesday, July 06, 2011 8:40 PM
  • I have the same problem.  I have a Gmail account which is working fine for mail, contacts, and calendar.  But a separate Google Calendar account I have (which is only for Calendar and not tied to any of Google's other services such as Gmail) is throwing the error listed in the original post.  It worked before I updated to Mango.
    Tuesday, July 26, 2011 5:17 PM
  • This bug is still present in build 7712. That probably doesn't bode well for it having been fixed in RTM...
    Wednesday, July 27, 2011 6:27 PM
  • This bug is still present in build 7712. That probably doesn't bode well for it having been fixed in RTM...

    Remember it's still a BETA 2 build. Not RTM build. Only the APIs are locked down and final as in the RTM build, but consumer stuff might still get changed :)
    Wednesday, July 27, 2011 7:16 PM
  • Any solutions to this yet? I have alot of new/updated contacts that needs to be synced..
    Tuesday, September 27, 2011 1:16 PM
  • nope .. I tried a lot of things .. no solution

    I also deleted the Google Kalendar, removed the WP7-Google-Entry, created everything new and have still the problem ... hope in final Mango it's gone.
    Tuesday, September 27, 2011 2:12 PM
  • Just installed the current updates ... and it still does'nt worked.

    But now, here's the solution: I had a old Google Account with Calendar, but no Gmail. Now I created a Gmail for the old accout. By this step Google gives you a new Username.

    Now in WP7, just synch with this new Gmail Username and you existing password ... and everything incl. Calendar-Sync works.
    Tuesday, September 27, 2011 8:58 PM
  • My Google account (with a Yahoo email address) worked fine before I updated to Mango this week.  Now the phone (HTC Trophy via Verizon) won't sync to Google.  Short of creating/changing to a Gmail username (per above) and/or a Factory Reset, I've tried all I can think of (for a non-developer) and per suggested online - forcing a sync, unchecking all/some of “content to sync”, deleting and re-adding Google acct to phone, resetting to Spanish and then back to English again. . .  Still getting Error code: 8004010F.  You mean this worked before but actually got broke going to Mango?
    Friday, September 30, 2011 4:43 PM
  • Same same!

    HTC HD7
    Telstra network Australia

    Updated to Mango a few hours ago and my Goggle account (only sync calendar and log in with Yahoo email address) returns the 8004010F error now.

    Also Facebook won't accept password. Says has expired.

    Grrrr. I only did the Mango update because of tethering and then I find out HTC aren't supporting it yet anyway!!

    Any ideas?

    Anyone with a Google account that logs in with a gmail address NOT had this problem? Maybe it's only related to non-gmail log ins?
    Tuesday, October 04, 2011 1:07 PM
  • To fix the Google (calendar) sync problem on my Windows 7.5 (Mango) phone, I had to create a Gmail email address for my Google account.  I originally had only my existing Yahoo email set up my Google account.  My Google calendar would no longer sync with a Yahoo address assigned as the only email assigned to the Google account.

     

    I first balked at trying this fix because I had misunderstood other posts to mean that I would need to create another Google account with a new Gmail email address.  I did not want to create a second Google account and have to copy/transfer my multiple calendars from my original account to a new one.  But you don’t need a new Google account, just a (new) Gmail address assigned to your existing Google account.  So log into your existing Google account on your PC, then go to Account Settings and pick Gmail under “Try Something new”.  Proceed through the screens to create a new Gmail address, but select “use with existing account” when prompted.  You will end up with a new Gmail address as the primary email assigned to your existing Google account, and your old email (Yahoo in my case) as the secondary email.  Note that you can still login to your Google account with your secondary email address.

     

    Now go back to your phone, choose “add an account” under “email+accounts” in Settings.  Use your new Gmail address (instead of your original non-Gmail address), and rejoice as your phone starts to sync with Google.

     

    Note that I do not intend to use my Gmail address, nor the Hotmail address that Windows Live created for me.  I consider these just orphaned artifacts to enable Windows, Google, and Yahoo to play nice on my phone.

    Sunday, October 09, 2011 3:46 AM