none
Win Phone 8 - You don't have permission to modify internal Hyper-v internal network adaptor required to run the emulator

    Question

  • hi,

    Environment: Win8 64-bit with VS2012 and the Win 8 Phone SDK, running in VMware Workstation 9.1.

    When I try to run a Win8 Phone app in any of the emulators I get the above message.  Ccomplete message:

    "Win Phone 8 - You don't have permission to modify internal Hyper-v internal network adaptor required to run the emulator" Click Retry or Close.

    If click Retry, the emulator launches then throws this error

    Windows Phone Emulator: "The Windows Phone Emulator was not able to create the virtual machine: Generic failure." OK

    Click OK, the emulator closes, and this is logged to VS2012 Output window:

    Error 1 0x80131622
      0 0 

    Hyper-V was installed by the Win 8 Phone SDK - not sure why. 

    Any way has anyone seen this error and know a workaround?  Are there known issues with running Win8 phone emulators in Win8 64-bit?

    Thanks in advance,

    Paul

    Friday, November 16, 2012 2:44 AM

Answers

  • I made it. Please note that my system is in spanish so maybe some of the "names" I mention may change a little.

    1.- Stop your virtual machine (shut Windows 8 down, DO NOT suspend it).

    2.- At the VMWare Virtual Machine list, right click Windows 8 machine then click "Show in Finder".

    3.- Right click the file then click "Show package contents", then find and open with a text editor a file with the extension .vmx

    4.- Go till the end of the file and add this two lines (first check whether they were previously added):

    hypervisor.cpuid.v0 = "FALSE"
    vhv.enable = "TRUE"

    5.- At the VMWare Virtual Machine list, right click Windows 8, click "Preferences" then "Advanced". Choose "Intel VT-X with EPT" as "Preferred virtualization engine".

    Done! Start the virtual machine then execute the emulator. You will get the same error as before but if you click "retry", you'll receive a new message asking if you want to configure the emulator to use the internet. Click yes then the Emulator will pop up.

    Let me know if you have any problem.

    Happy coding!

    • Edited by Mobincube Monday, November 19, 2012 12:14 PM Added a screenshot
    • Marked as answer by PaulHomeMsdn Wednesday, November 28, 2012 2:14 PM
    Monday, November 19, 2012 12:05 PM
  • Hi,

    After reading that error message several times and reviewing the Hyper-v UI (very new to me), it occurred that the error was not with the Win8 Phone SDK, but existed, in part at least, due to my unfamiliarity with Hyper-v and VMWare.

    Frfom the error message:...."the processor topology..."  In Hyper-v, checked the number of processors assigned by Hyper-v to the Emulator and compared that to the number of processors vMware workstation had assigned to the Win8 VM.  By default it appears that Hyper-v assigns 2 processors to the emulator.  I'd created the Vm with one (1 processor). 

    Steps:

    • Hyper-v manager, Settings, Processor, Number of virtual processors.
    • VMWare workstation: rt-click the VM, select settings, Processors.

    Solution: changed the number of processors assigned by Hyper-v from 2 to 1. Started the emulator using Hyper-v manager.  Success!  Fired up VS2012 (sp1) and re-ran the basic Pivot app in debug mode, Success!  Emulator started up (slow but it runs!).  You can also go the other way, increase the number of processors used by VMWare workstation.  Either way, with this error the number of processors used by VMware and hyper-v have to agree.

    Thanks again to Mobincube for getting me 90% of the way!

    Here's a valuable checklist for anyone running Win8 Pro or higher 64-bit with VS2012, on VMWare Workstation 9.1:

    http://igrali.com/2012/10/31/windows-phone-8-emulator-wasnt-able-to-create-the-virtual-machine/

    1. Re-verified that my processor supports SLAT using coreinfo.exe:

    http://www.petri.co.il/check-cpu-slat-support.htm

    Coreinfo v3.2 - Dump information on system CPU and memory topology
    Copyright (C) 2008-2012 Mark Russinovich
    Sysinternals - www.sysinternals.com

    Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
    Intel64 Family 6 Model 42 Stepping 7, GenuineIntel
    HYPERVISOR      -       Hypervisor is present
    VMX             *       Supports Intel hardware-assisted virtualization
    EPT             *       Supports Intel extended page tables (SLAT)

    The *'ed values indicate that the CPU supports both Intels virtualization and AMD's SLAT.

    2. Verified that Hyper-V is enabled? http://www.howtogeek.com/76532/how-to-install-or-enable-hyper-v-virtualization-in-windows-8/ (it is)

    3. Are you running Windows 8 64-bit (x64) client version? Needs to be 64bit.

    Running Win8 64-bit

    4. Version of Win 8 (should be Win 8 pro or higher)

    I'm running Win 8 Enterprise.

    • Marked as answer by PaulHomeMsdn Wednesday, November 28, 2012 2:15 PM
    Wednesday, November 28, 2012 2:14 PM

All replies

  • the windows phone 8 emulator uses hyperv.  I do not believe any windows phone emulator will run in a virtual pc
    Saturday, November 17, 2012 12:37 AM
  • Thanks for the reply. So to dev phone apps we need a physical machine?  any plans to make these work on vm's?

    thanks again for taking an interest in this question.

    paul

    Saturday, November 17, 2012 12:25 PM
  • I saw a Windows Phone Emulator running on a VMWare virtual machine under Windows 8. When I figure it out I will post all the information here.
    Monday, November 19, 2012 11:17 AM
  • I made it. Please note that my system is in spanish so maybe some of the "names" I mention may change a little.

    1.- Stop your virtual machine (shut Windows 8 down, DO NOT suspend it).

    2.- At the VMWare Virtual Machine list, right click Windows 8 machine then click "Show in Finder".

    3.- Right click the file then click "Show package contents", then find and open with a text editor a file with the extension .vmx

    4.- Go till the end of the file and add this two lines (first check whether they were previously added):

    hypervisor.cpuid.v0 = "FALSE"
    vhv.enable = "TRUE"

    5.- At the VMWare Virtual Machine list, right click Windows 8, click "Preferences" then "Advanced". Choose "Intel VT-X with EPT" as "Preferred virtualization engine".

    Done! Start the virtual machine then execute the emulator. You will get the same error as before but if you click "retry", you'll receive a new message asking if you want to configure the emulator to use the internet. Click yes then the Emulator will pop up.

    Let me know if you have any problem.

    Happy coding!

    • Edited by Mobincube Monday, November 19, 2012 12:14 PM Added a screenshot
    • Marked as answer by PaulHomeMsdn Wednesday, November 28, 2012 2:14 PM
    Monday, November 19, 2012 12:05 PM
  • hi,

    Thanks for taking an interest in this question.  I'll try your solution and report back (am traveling this week).

    paul

    Tuesday, November 20, 2012 2:51 AM
  • I have the same problem running Windows 8 via Mac Parallells 8. Is there any solutiuon for this Environment as well?

    Mattias

    Thursday, November 22, 2012 8:24 AM
  • I've follow your instructions, but still doesn't work. I am using osx mountain with fusion 5.02.

    after setting change, and run emulator the message is changed with: 

    Can't start windows phone emulator

    The windows phone emulator requires Hyper-V. Your PC is missing the follow pre requisites to run Hyper-V.

    - Second level address translation

    Sunday, November 25, 2012 8:13 AM
  • hi,

    I tried the solution recommended.  It successfully got me past the initial error, but not all the way.

    the emulator is now throwing this error:

    Any thoughts?

    Thanks for getting me a bit closer.

    Paul

    Sunday, November 25, 2012 9:21 PM
  • Hi,

    After reading that error message several times and reviewing the Hyper-v UI (very new to me), it occurred that the error was not with the Win8 Phone SDK, but existed, in part at least, due to my unfamiliarity with Hyper-v and VMWare.

    Frfom the error message:...."the processor topology..."  In Hyper-v, checked the number of processors assigned by Hyper-v to the Emulator and compared that to the number of processors vMware workstation had assigned to the Win8 VM.  By default it appears that Hyper-v assigns 2 processors to the emulator.  I'd created the Vm with one (1 processor). 

    Steps:

    • Hyper-v manager, Settings, Processor, Number of virtual processors.
    • VMWare workstation: rt-click the VM, select settings, Processors.

    Solution: changed the number of processors assigned by Hyper-v from 2 to 1. Started the emulator using Hyper-v manager.  Success!  Fired up VS2012 (sp1) and re-ran the basic Pivot app in debug mode, Success!  Emulator started up (slow but it runs!).  You can also go the other way, increase the number of processors used by VMWare workstation.  Either way, with this error the number of processors used by VMware and hyper-v have to agree.

    Thanks again to Mobincube for getting me 90% of the way!

    Here's a valuable checklist for anyone running Win8 Pro or higher 64-bit with VS2012, on VMWare Workstation 9.1:

    http://igrali.com/2012/10/31/windows-phone-8-emulator-wasnt-able-to-create-the-virtual-machine/

    1. Re-verified that my processor supports SLAT using coreinfo.exe:

    http://www.petri.co.il/check-cpu-slat-support.htm

    Coreinfo v3.2 - Dump information on system CPU and memory topology
    Copyright (C) 2008-2012 Mark Russinovich
    Sysinternals - www.sysinternals.com

    Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
    Intel64 Family 6 Model 42 Stepping 7, GenuineIntel
    HYPERVISOR      -       Hypervisor is present
    VMX             *       Supports Intel hardware-assisted virtualization
    EPT             *       Supports Intel extended page tables (SLAT)

    The *'ed values indicate that the CPU supports both Intels virtualization and AMD's SLAT.

    2. Verified that Hyper-V is enabled? http://www.howtogeek.com/76532/how-to-install-or-enable-hyper-v-virtualization-in-windows-8/ (it is)

    3. Are you running Windows 8 64-bit (x64) client version? Needs to be 64bit.

    Running Win8 64-bit

    4. Version of Win 8 (should be Win 8 pro or higher)

    I'm running Win 8 Enterprise.

    • Marked as answer by PaulHomeMsdn Wednesday, November 28, 2012 2:15 PM
    Wednesday, November 28, 2012 2:14 PM
  • I have the same issue for Parallels running Windows 8. Just started developing today. Did you get this resolved? If so, how?

    Thanks

    dbdb


    • Edited by db.db Friday, December 07, 2012 7:26 PM
    Friday, December 07, 2012 5:54 PM
  • I have the same problem running Windows 8 via Mac Parallells 8. Is there any solutiuon for this Environment as well?

    Mattias

    I have resolved the issue for people using Parallels 8 with Windows 8. You need to enable Nested Virtualization to allow a virtual machine to run inside a virtual machine.

    Shut down Windows 8 on Parallels then follow these steps:

    Parallels Desktop | Virtual Desktop | Configure... | Optimization | Enable Nested Virtualization.

    Friday, December 07, 2012 10:01 PM
  • @Mobincube

    That was the solution indeed...

    The problem is however, it is capable of starting the emulator succesfully, but when trying to deploy the application, it is saying that %1 isn't a valid Win32-Application.

    ----

    Issue seems to have solved itself after a restart.

    • Edited by larssy1 Thursday, February 14, 2013 11:11 AM
    Thursday, February 14, 2013 10:42 AM
  • Thank you!! 
    Thursday, February 28, 2013 5:28 AM
  • I had same problem and resolved in below steps.

    1. Uninstall Hyper-V
    2. Shutdown
    3. Modify .vmx by adding below 2 lines
    "hypervisor.cpuid.v0 = "FALSE" 
    mce.enable = "TRUE""
    4. Start windows 8 in VMWare
    5. Install Hyper-V Management
    6. Restart as prompted
    7. Install Hyper-V Platform
    8. Restart as prompted
    9. Done.

    Friday, August 23, 2013 11:32 PM
  • I have the same problem running Windows 8 via Mac Parallells 8. Is there any solutiuon for this Environment as well?

    Mattias

    I have resolved the issue for people using Parallels 8 with Windows 8. You need to enable Nested Virtualization to allow a virtual machine to run inside a virtual machine.

    Shut down Windows 8 on Parallels then follow these steps:

    Parallels Desktop | Virtual Desktop | Configure... | Optimization | Enable Nested Virtualization.

    I had this same issue with Parallels, I followed the steps above then I ran VS2013 as an administrator to make it work
    Thursday, May 22, 2014 9:15 PM