none
Something Happened and this app couldn't be installed. Please try again. Error code: 0x80070005.

    Question

  • I installed windows 8 today and did the following. Because of this metro apps won't install or run anymore. Anyone with suggestions on how to fix this is invited to comment.         


    I moved my user data folder to a non-system partition in windows 8 using the following commands:

    1. Enabled the administrator account and set a password for it.

    In the command line (CMD with administrator rights) I use the following commands to enable the administrator account:

    net user administrator /active:yes

    To disable the administrator account again use the following command:

    net user administrator /active:no

    I didn't do this of course as I wanted to enable the administrator account in the first place. 

    Then I changed the password of administrator using the following command:

    net user administrator *

    2. Logoff and login with administrator account

    3. Relocated my user data to the other non-system partition, for example from C:\users\Jordan  to D:\users\Jordan, then REMOVE the old profile folder

    robocopy /MIR /XJ   C:\Users\Jordan  D:\Users\Jordan

    4. Use mklink to create a symbolic link from C:\users\Jordan to D:\users\Jordan

    mklink /J C:\Users\Jordan  D:\users\Jordan

    If this command fails with the following error:

    “Cannot create a file when that file already exists”

    You will have to stop the following service using the administrator account:

    Windows Media Player Network Sharing Service 

    Now you will be able to delete the old C:\Users\Jordan folder. 

    5. Re-login use your own account, you will find nothing changed, but in fact your physical user data is now on drive D and no longer on the system partition. 

    6. Done. The next time you re-install your OS, just use the same user name, remove  C:\users\Jordan then run the command of step 3 again then your user data is back.

    Everything worked like a charm for me but I have the following problem with the new metro apps in windows 8. Whenever I try to install or use them using this linked user data account I get the following message:

    Something Happened and this app couldn't be installed. Please try again. Error code: 0x80070005. 

    Anyone knows why this is happening on the copied user account to a non-system partition and linked using: 

    mklink /J C:\Users\Jordan  D:\users\Jordan

    Much appreciated if someone knows how to fix this. An "normal" user accounts on the system partition everything is okay and works.

    Best Regards,

    Jordan

    Sunday, August 19, 2012 12:54 PM

Answers

  • I found the solution, you have to change permissions up from Packages folder. If you do it from /Winstore [xxxxxx] don't work.

    http://www.goededoelenwereld.nl/index.php?id=117&no_cache=1&tx_ttnews[tt_news]=2585&cHash=916b41a1e05afbe8579fc5347b36e163

    Hope it helps.

    • Proposed as answer by AndyPT Thursday, July 25, 2013 1:40 PM
    • Marked as answer by Roberts_EModerator Friday, July 26, 2013 10:44 PM
    Wednesday, April 24, 2013 12:30 AM

All replies

  • I also offloaded my User folder to a secondary drive and now I cannot install apps.

    My process was different than yours because I did it before the install by using Shift + F10 before creating the user profiles to open the command prompt. Basically the same method I used in Windows 7. Everything works fine except for the Windows 8 app installation issue.

    Hope you get help with this because I too need this resolved.


    Monday, August 20, 2012 3:24 PM
  • I did the same thing and have the same problem.  Anyone have a solution yet?
    Tuesday, September 11, 2012 9:10 AM
  • I have exactly same problem, moved my profile to another drive and since then this user cannot install apps. Other users works ok, so I guess its something in profile directory structure 
    Monday, September 17, 2012 6:29 AM
  • There must be something that can be done!  I tried copying over the local and roaming app data to the other drive (Offline, so it grabbed every little file) and that still didn't work.

    Could there be some registry setting that needs adjusting?

    I really need my appdata to be on a separate drive because I format often and I like to keep all my data separate.

    Monday, September 17, 2012 8:47 PM
  • Can't believe there isn't a workaround for this problem yet.

    Glad to see I'm not the only one waiting for a fix.

    Thursday, September 27, 2012 2:46 AM
  • Can't believe there isn't a workaround for this problem yet.

    Glad to see I'm not the only one waiting for a fix.

    Microsoft, we need your help.  We aren't the only ones.  I've posted this on behalf of some friends too.  We all need this resolved so we can join in on the Windows Apps Store too.
    Thursday, September 27, 2012 6:47 AM
  • I had a same problem, after some research here what you need to do .

    I use my example i changed my directory from C:\Users\[name] to E:\Users\[name]

    The problem is when you run win 8 store , Microsoft runs it with your logged in account with [low-rights] privileges  and therefore the store doesnot have the right permissions to add the new packages to appstore's new directory to fix this 

    locate  E:\Users\[name]\AppData\Local\Packages  locate WinStore_[xxxx some number xxx]  right click the folder => properties => security => click on (MachineName\Users) and give full control 

    this should fix your issue. 

    -Amir 


    • Proposed as answer by Amirghz Friday, October 05, 2012 12:53 AM
    • Edited by Amirghz Friday, October 05, 2012 12:54 AM
    • Unproposed as answer by Roberts_EModerator Tuesday, June 25, 2013 8:31 PM
    • Proposed as answer by ggeisler Tuesday, November 19, 2013 5:04 PM
    Friday, October 05, 2012 12:53 AM
  • That didn't work for me or any of my friends.  The permissions were already set that way.
    Friday, October 05, 2012 1:59 AM
  • That didn't work for me or any of my friends.  The permissions were already set that way.
    did you apply the permission to all sub directories? you need then to exit app store and start it again 
    Friday, October 05, 2012 3:44 PM
  • did you apply the permission to all sub directories? you need then to exit app store and start it again 

    Yes, I did.  I tried Shutting Down and Booting.  My friends have confirmed the same.
    Saturday, October 06, 2012 2:13 AM
  • Didn't work for me either. My first thought was a permission issue when I encountered this problem and tried this on my own.
    Wednesday, October 10, 2012 4:00 AM
  • The exact thing happened to me. I was using Windows 8 on my mac's boot camp partition. The apps worked fine and I was able to download any number of apps I wanted.

    Then I tried to create a new virtual machine for using the Boot Camp Windows 8 partition using Parallels Desktop. And everything looked fine when I installed the Parallels Tools in Windows 8 except I can't download any app from the store and most of the metro apps like Mail and Messaging won't open.


    Sunday, October 14, 2012 4:13 AM
  • A little insight from Microsoft would be helpful in resolving this issue.

    You guys have been awfully quiet about this issue.

    Monday, October 15, 2012 2:31 PM
  • Exact same issue here.

    created a junction for my user profile to alleviate the writes on my ssd and now i can't install apps.

    i'll continue trying to work out the issue, unfortunately i'm still trying to learn all of windows 8's changes, which is taking time

    Good luck guys

    Saturday, October 27, 2012 9:09 AM
  • THIS PROCESS DOES NOT WORK

    Ok guys after doing some stuffing around I managed to get this fixed.

    I went into PC Settings and did a Refresh on windows after that I recreated the Junction and now it works perfectly.

    Steps:

    1. Win-C to open right menu thing
    2. Settings
    3. Change PC settings right at the bottom
    4. Click the general tab
    5. Click Get started under Refresh your PC without changing files
    6. Let it all run
    7. Recreate Junction (mklink /J /D user E:\Users\user)
    8. Log in to your user account and test it out


    You may need to reinstall some things as I had some of my drivers stop working after the refresh

    • Proposed as answer by Scott_Hancock Saturday, October 27, 2012 9:51 AM
    • Unproposed as answer by Scott_Hancock Sunday, October 28, 2012 1:53 AM
    • Edited by Scott_Hancock Sunday, October 28, 2012 1:55 AM
    Saturday, October 27, 2012 9:51 AM
  • Oh, that didn't work.  It says user data files have to be on the same drive as all the OS files in order to refresh the PC.  If you have the OS on a SSD and user data files on a HDD, it is still puking on the apps.
    Saturday, October 27, 2012 4:24 PM
  • I can confirm that this doesn't work as well.

    Saturday, October 27, 2012 6:27 PM
  • Sorry guys you're right it doesn't work. When i tested it i didn't realize that i made a mistake creating the junction and in turn it made me a new account in c:\users\ which is why it looked like it worked. Sorry I should have tested it more, i'll keep on it
    Sunday, October 28, 2012 1:55 AM
  • I'm currently running on the assumption that it is some kind of permission issue. Unless windows is actively looking for a junction (which it still possible) it wont know the difference between a junction (in c:\users\user) pointing to d:\users\user and a folder in c:\users\user. This windows might look for it, but it would seem extremely dumb for Microsoft to stuff up the ability to efficiently use an ssd. 
    Sunday, October 28, 2012 2:03 AM
  • If anyone wants to do a quick fix you could always just junction some of the folders inside the profile but leave the core parts of the profile non-junction'd. A little messy for my liking but it should work without issue. If it is looking for a junction it shouldn't look for one in every sub-directory

    So just junction my documents, downloads, music, etc

    I just tested it and it does work, it is a little messy though, but it works

    Sunday, October 28, 2012 2:15 AM
  • After 4 days of Windows store being broken (could not connect to the internet... even though my machine and all other apps could).. The store started working today...

    Now it works but cannot install any apps because I get the 

    Something Happened and this app couldn't be installed. Please try again. Error code: 0x80070005

    What is the fix? I have not moved any folders like other people I have a plain installation of Windows 8roken

    Friday, November 16, 2012 2:36 PM
  • Here it is December 19 and I still have this problem.  I have had it since I did a clean install around thanksgiving.

    Nothing, absolutely nothing has worked.

    Right now, on this user I have a bunch of blank buttons that say the apps are installed when they aren't.  When it tries to install anything I get 0x80078000 error.

    Oh, one problem I had was a bad router but that didn't fix this problem.

    Wednesday, December 19, 2012 9:30 AM
  • Oh, a refresh didn't change anything, either.
    Wednesday, December 19, 2012 9:31 AM
  • After many reboots and frustration with these exact symptoms, this post ended up doing the trick. After another reboot having the TimeBroker service temporarily disabled, everything went back to normal.  So far, it looks like the Weatherbug app was most likely the culprit.
    Friday, December 21, 2012 5:24 AM
  • I too have this issue.....much searching both here and TechNet with no great resolution.

    My issue is "slightly" different as I have relocated C:\Users to D:\Users from audit mode clean install BUT additionally, I have then ALSO relocated D:\Users\User1 to D:\User1 (thus having both D:\Users AND D:\User1 at the root of D: which I have always done since the advent of XP BTW!) applying Symbolic Link mklink /j D:\Users\User1 D:\User1 and also modifying the ProfileImagePath for that user profile key to D:\User1 in registry.

    The "Good News" ......all the Metro Apps for the relocated Users contained in D:\Users (D:\Users\User2 etc.) all appear to function correctly.

    The "Bad News" (at least for me!) ....the relocated User Profile at D:\User1 gets the same Windows Store error reported in the thread title and many of the Apps just do not work at all (e.g. Sport) refusing to launch at all.

    I do not know whether this will help anybody but the following post discusses a permissions issue which appears to resolve the Metro Apps issues for users reporting similar problems to those here. Please be aware that this user ALSO relocated his ProgramData folder to another drive/partition so the registry step referring to modifying the path for ProgramData would NOT apply if like me you relocated only the Users folder.

    See the following: Relocate User Profiles - See anthonyfleck's post of 30th December 2012 on Page 9 - www eightforums.com/tutorials/4275-user-profiles-relocate-another-partition-disk-9.html - for detailed steps on how he resolved the issue.....

    Hope it helps,

    PC Pilot

    Saturday, January 05, 2013 5:16 PM
  • So I followed this guide:

    http://www.eightforums.com/tutorials/4275-user-profiles-relocate-another-partition-disk.html

    And ended up with the same problem as a lot of you here. I could not install any windows store apps.

    My solution was this. Since I only had one user account, and the computer is quite freshly installed, I made that account a local account (it was connected to my live account Before). I created a new account that was connected to my live account, verified that it actully was created at my other disk since the guide states that all new accounts should be created there, and tested to install some apps. Works like a charm.

    I then removed my old account that could not install any store apps.

    Don't know if it will solve your problems, but it solved mine.

    Best regards
    Markus

    Saturday, January 26, 2013 3:41 PM
  • I found the solution, you have to change permissions up from Packages folder. If you do it from /Winstore [xxxxxx] don't work.

    http://www.goededoelenwereld.nl/index.php?id=117&no_cache=1&tx_ttnews[tt_news]=2585&cHash=916b41a1e05afbe8579fc5347b36e163

    Hope it helps.

    • Proposed as answer by AndyPT Thursday, July 25, 2013 1:40 PM
    • Marked as answer by Roberts_EModerator Friday, July 26, 2013 10:44 PM
    Wednesday, April 24, 2013 12:30 AM
  • YES, THIS WORKED. Thank you.

    Also, read about another issue workaround below.

    I started having problems after I moved my home/profile dir from C:\Users\<username> to somewhere else.

    The anwer is to change permissions for the directory "<profile_dir>\AppData\Packages" to:
    * "Everyone" - Full Control (solves the problem above)
    * "ALL APLICATION PACKAGES" - Full Control (solves the app stopping immediatly after start - error "App X did not launch within its allotted time.") - Please note that "Everyone" was not enough, not sure why.

    2 problems solved.

    Friday, July 26, 2013 7:32 PM
  • This one worked for me!!
    Tuesday, November 19, 2013 5:04 PM