none
Cannot open C++ Metro application in Blend for VS 2011 Beta

    Question

  • Hi,

    I have consumer preview build and I downloaded the tools needed for metro development. I cannot open any samples C++/C# solution files in Blend that came with the VS 2011 Beta.

    The error I get is "The project Application.vcxproj could not be opened. The imported project "C:\Microsoft.cpp.default.props" was not found. Confirm that the path in <import> declaration is correct , and the file exists on the disk .

    Any idea ?


    • Edited by Shawn Dan Thursday, March 08, 2012 3:32 AM
    Thursday, March 08, 2012 3:27 AM

Answers

  • Hi Eric,

    This is a known issue for Blend when SxS installed with Dev10.

    The workaround is to set the environment variable  VisualStudioVersion = 11.0.

    You can set this either by manually entering that as a system variable in your Control Panel (System Settings -> Advanced Settings -> Environment Variables).  Because that would be a global system setting it *might* have implications for Blend 4/VS 2010, I am not sure. 

    The other choice would be to set that environment variable inside of a command shell and then launch the Blend application from that command shell.

    -Navit Saxena

    • Proposed as answer by navits - MSFT Sunday, March 11, 2012 10:23 PM
    • Marked as answer by Shawn Dan Monday, March 12, 2012 6:16 AM
    Sunday, March 11, 2012 10:23 PM

All replies

  • I am also having this problem!
    Thursday, March 08, 2012 3:37 AM
  • Hi,

    Can you please share the link where you are downloading these samples from? We will take a look at this on priority. Also, would be good to know how this machine was setup, is this a clean install of Win8 Consumer Preview and Visual Studio 11 Beta?

    You can send these details directly to me at navits at microsoft dot com and I will take a look.

    -Navit Saxena

    Thursday, March 08, 2012 5:43 AM
  • Hi,

    I tried opening some of the Windows SDK samples [C++] and they opened in Blend without any issues. We would like to understand how your machine was setup, also can you check if Microsoft.Cpp.Defaults.props file is present under %Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110.

    -Navit Saxena

    Thursday, March 08, 2012 7:09 AM
  • Hello Navits,

    I'm sorry, it's not actually the samples that I'm having difficulties opening, but rather my own project file. It opens fine in VS11, but I get the exact same error as originally posted when I double click on the .snl file or the .csproj file. I responded via the forums because my issue didn't exactly match what the op had.

    If it helps, I did a clean install and the Microsoft.Cpp.Defaults.props file is present in the proper directory. Also, I am developing in C#/XAML. Hope it helps. Please let me know if I can be of further assistance.

    Thursday, March 08, 2012 2:52 PM
  • As this is specific to a project, we will need a small repro project. Can you please send a repro project to me at navits at microsoft dot com and I will take a look.

    -Navit Saxena

    Thursday, March 08, 2012 6:58 PM
  • Where can I find Microsoft.cpp.default.props file ? I don't see it under C:\ . Is it hidden ?

    Friday, March 09, 2012 3:30 AM
  • It should be under %Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110.

    -Navit Saxena

    Friday, March 09, 2012 3:53 AM
  • I have a similar problem! 

    I installed Win8CP, I installed VS2008 Pro + SP1, I installed VC2011 Pro... When I create a new Metro project with VS2011 all works in VS2011. If I try to open the project in Blend for VS2011 Beta it tell an error like :

    "The project "MyApp1.csprj" cannot be opened. The imported project "C:\Program File\(x86)\MSBuild\Microsoft\WindowsXaml\v10.0.Microsoft.UI.Xaml.CSharp.targets" was not found. Confim that the path in the <Import> declaration is correct, and that the file exists on disk. D:\My Documents\Visual Studio 11\Projects\MyApp1\MyApp1\MayApp1.csproj"

    Is it missing something to I have to install?? Or what?

    Somebody have an Idea? This is occuring with a fresh VS2011 Pro Beta installation...???


    Eric, software designer 4·jet software

    Sunday, March 11, 2012 7:08 AM
  • Hi Eric,

    This is a known issue for Blend when SxS installed with Dev10.

    The workaround is to set the environment variable  VisualStudioVersion = 11.0.

    You can set this either by manually entering that as a system variable in your Control Panel (System Settings -> Advanced Settings -> Environment Variables).  Because that would be a global system setting it *might* have implications for Blend 4/VS 2010, I am not sure. 

    The other choice would be to set that environment variable inside of a command shell and then launch the Blend application from that command shell.

    -Navit Saxena

    • Proposed as answer by navits - MSFT Sunday, March 11, 2012 10:23 PM
    • Marked as answer by Shawn Dan Monday, March 12, 2012 6:16 AM
    Sunday, March 11, 2012 10:23 PM
  • This solved the issue. Thanks Navit.

    Monday, March 12, 2012 6:15 AM