none
WP8 Emulator Deployment Fails But Emulator Still Runs

    Question

  • Whenever I try to deploy to any of the WP8 emulators, the emulator starts to load then I get this error:

    "The Windows Phone Emulator wasn't able to connect to the Windows Phone operating system:

    The emulator couldn't determine the host IP address, which is used to communicate with the guest virtual machine.

    Some functionality may be disabled."

    Then when I close the error, the emulator loads up, the WP8 OS runs on it, but the app isn't deployed, and nothing happens in Visual Studio until I close the emulator, then I get a deployment error saying "Invalid Pointer." The emulator worked the very first time I ran it, but it was extremely slow, so I decided to restart. When my PC booted back up, that's when I started getting this issue. The WP7 emulator still works.

    Also, since installing the SDK for WP8, both my WP7 and WP8 emulators are unbelievably slow. The WP7 emulator gets around 3 frames per second, it used to be 150 frames per second before I installed the new SDK. I'm running a quad-core Core i5 at 2.8Ghz, 6GB of RAM, and 2 nVidia GTX 460s.

    Thursday, November 01, 2012 1:01 AM

Answers

  • Hi,

    1. An internal developer had a similar condition that he remedied by (1) adding the (optional Windows feature) Hyper-V, adding himself to the Hypervisor Administrator groups. That did not fix it.  Next he uninstalled all the VPN software he had (such as the Cisco VPN client).  Next he went into Hyper-V Manager and deleted all Virtual Switches (which fixed his issue).

    2. Regarding the reduced performance of the WP7 emulator, the WP7 Emulator runs the phone OS in a virtual machine which is more like Virtual PC than Hyper-V.  Hyper-V adds another layer of virtualization (and no HW virtualization) slowing down the Emulator. The WP8 Emulator is based on Hyper-V and hence this needs to be turned on to enable WP8 app development.

    If you are focused only on WP7 app development, you can turn off Hyper-V to have better WP7 Emulator performance but you need to turn this back on to launch the WP8 Emulator.

    FYI the WP8 Emulator Troubleshooter can be found here.

    Hope this helps,
    Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    • Marked as answer by Ryken100 Thursday, November 01, 2012 8:50 PM
    Thursday, November 01, 2012 5:38 PM
  • The problem seemed to be fairly simple to solve, I just had to go to Network Sharing and choose change network adapters and enable vEthernet for Window Phone Emulator and that was it.  Emulator worked like a champ.
    Sunday, December 30, 2012 12:44 AM

All replies

  • Hi,

    1. An internal developer had a similar condition that he remedied by (1) adding the (optional Windows feature) Hyper-V, adding himself to the Hypervisor Administrator groups. That did not fix it.  Next he uninstalled all the VPN software he had (such as the Cisco VPN client).  Next he went into Hyper-V Manager and deleted all Virtual Switches (which fixed his issue).

    2. Regarding the reduced performance of the WP7 emulator, the WP7 Emulator runs the phone OS in a virtual machine which is more like Virtual PC than Hyper-V.  Hyper-V adds another layer of virtualization (and no HW virtualization) slowing down the Emulator. The WP8 Emulator is based on Hyper-V and hence this needs to be turned on to enable WP8 app development.

    If you are focused only on WP7 app development, you can turn off Hyper-V to have better WP7 Emulator performance but you need to turn this back on to launch the WP8 Emulator.

    FYI the WP8 Emulator Troubleshooter can be found here.

    Hope this helps,
    Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    • Marked as answer by Ryken100 Thursday, November 01, 2012 8:50 PM
    Thursday, November 01, 2012 5:38 PM
  • Thanks! Removing the Virtual Switches fixed it!

    Ryken Productions

    Thursday, November 01, 2012 8:51 PM
  • Hi Mark Chamberlain ,

    I came into the same problem that my wp8 and wp7 emulator run slowly on my laptop( i5/Ati 5730m/8G ram ,running win8 pro x64).

    I removed the virtual switches for the wp8 emulator. But when I start the emulator from VS2012, A messagebox showed up saying I need to run as Administrator to change the Internet configuration for the emulator. The emulator will close if I click the "No". So I have to click "Yes", and then all the virtual switches which I had just deleted all comes back, the wp8 emulator runs still very slowly.

    I have tried to run the emulator from the Hyper-V manager, still slowy...

    Sunday, November 18, 2012 1:40 PM
  • Hi,

    Do you see a lot of disk drive activity (disk drive LED?) when the emulator is running?  The storage device on a laptop is typically slower. And other factors can make the drive even slower such as a fragmented file system and low free disk space. It might be necessary to upgrade the drive, perhaps with a solid state drive (which will give your laptop a nice performance improvement).

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    • Proposed as answer by macadelic Sunday, December 30, 2012 12:42 AM
    • Unproposed as answer by macadelic Sunday, December 30, 2012 12:42 AM
    Monday, November 19, 2012 4:45 PM
  • The problem seemed to be fairly simple to solve, I just had to go to Network Sharing and choose change network adapters and enable vEthernet for Window Phone Emulator and that was it.  Emulator worked like a champ.
    Sunday, December 30, 2012 12:44 AM
  • @ macadelic - yes, this is the fix
    Thursday, March 14, 2013 5:38 AM
  • I will try this today and hopefully this works.

    I had the same thing last night and i was so frustrated!


    Mostafa Arafa Elzoghbi

    Monday, March 25, 2013 3:21 PM
  • The proposed solution to enable "vEthernet for Window Phone Emulator" didn't work for me since it is already enabled.

    I'm facing the same issue, developing windows 8 in a brand new laptop, AMD E1500 and supports SLAT.

    I'm not able to run the emulator, it seems so slow to run since i  takes forever after seeing the windows OS VS is starting... and then i get an error message:

    App Deployment failed. please try again.

    The steps stops at the following step from the output window:

    2>Connecting to Emulator WVGA 512MB...

    Any helps is appreciated.


    Mostafa Arafa Elzoghbi

    Tuesday, March 26, 2013 12:47 AM
  • This sounds like a problem with third party software such as antivirus, system monitoring, hyper-v monitoring etc., interfering with the emulator. You might need to completely back out the tools, uninstall the third party software, and reinstall the tools.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Tuesday, March 26, 2013 3:44 PM
  • I think the problem is related to the DHCP since the created VM doesn't have an IP and i'm not connected to the router with a wire, i'm using wireless to connect to the internet.

    I have a thought it is related to the configuration of the adapters and how it is being assigned IP so the laptop can deploy the assemblies to the VM.

    I tried to connect to the VM by it self and it works, so the VM is not corrupted but the network configuration might have an issue.

    Do you have any check list to check on the adapter and 2 other vEthernet that is being created by Hyper-V before i uninstall all the tools and software ?

    Thanks.


    Mostafa Elzoghbi

    Tuesday, March 26, 2013 3:53 PM
  • i found the solution:

    http://moustafa-arafa.blogspot.com/2013/03/fix-it-application-deployment-failed.html


    Mostafa Elzoghbi

    Thursday, March 28, 2013 1:48 AM
  • Thank you Mostafa.

    Alas, the real-time antivirus software strikes again...

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Thursday, March 28, 2013 1:46 PM
  • I'm facing the following problem: I can start the emulator from hyper v manager, the WP8 image itself does start. But I can not debug any applications from VS2012, it simply wont connect to the emulator.

    So I figured out that I have to turn on network sharing on the virtual emulator switch, then VS2012 is able to start the emulator, deploy the package and debug it. But turning on sharing on the emulator adapter switch brings down my wifi connection resulting in the fact that I have no internet connection any more, which is really annoying.

    What can I do to enable both, wifi internet connection and the emulator running from vs2012?

    Friday, June 28, 2013 9:03 AM
  • I am having a very similar problem.

    Everything was working and I upgraded to Window 8.1

    Then I was asked to apply a patch to VS 2012.

    Now I get an error message in a pop up dialog.

    There were Deployment errors. Continue?

    If I continue it will fail to launch the application and I get the following error message as a pop up.

    App Deployment Failed Please try again.

    The emulator works fine otherwise including access to the internet through both search and explorer.

    I got the emulator to work temporarily once by repairing VS 2012 but next time I went to debug it failed again in the same way, and now I can't get it to work again by doing this.

    Here is the Output associated with the error.

    1>------ Deploy started: Project: PivotApp1, Configuration: Debug Any CPU ------

    1>Deploying C:\Users\maalund\Documents\Visual Studio 2012\Projects\PivotApp1\PivotApp1\Bin\Debug\PivotApp1_Debug_AnyCPU.xap...

    1>Connecting to Emulator WVGA 512MB...

    1>Deployment of application to device failed.

    1>App deployment failed. Please try again.

    ========== Deploy: 0 succeeded, 1 failed, 0 skipped =========

    I have tried most if not all the sugestions I have found on this forum including playing with the Virtual Switch setting and checking the network settings.

    Any suggestions would be appreciated.

    Thanks


    • Edited by maalund Wednesday, July 03, 2013 3:50 AM Updated with text on pictures
    Wednesday, July 03, 2013 3:45 AM
  • I found a work around.

    If I run VS as Administrator then it works fine and loads quickly.


    maalund

    Wednesday, July 03, 2013 3:04 PM
  • this is what my problem is. thanks a lot.. i always believe to think simply first :)
    Sunday, March 16, 2014 5:15 PM
  • Yes, its working. Thanks for the tip. :)
    Saturday, May 31, 2014 12:12 PM