none
WDDM 1.1 driver for Intel 945 Express Chipset Family

    Question

  • Hello, I am using Dell Inspiron 640m laptop along with Windows 7 Ultimate. I have successfully installed WPDT. The problem I am facing is that when I launch a template Windows Phone Application, the emulator show up and disappears giving the error "The object invoked disconnected from the client". Sometimes, the error is "The interface is unknown".

    After some research, I have reached a conclusion (Please correct me if I am wrong) that driver for my Intel 945 Express Chipset is not WDDM 1.1 compliant. I have done enough research but could not find the updated driver anywhere. Can anyone please guide me to resolve this issue? I am pasting the DirectX Diagnostics information below for your reference. Thanks in advance.

    ------------------ System Information ------------------ Time of this report: 3/18/2011, 20:43:30
    Machine name: WAQASDANISH-PC
    Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7600) (7600.win7_rtm.090713-1255)
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Inc.
    System Model: MXC061
    BIOS: Phoenix ROM BIOS PLUS Version 1.10 A10
    Processor: Intel(R) Core(TM)2 CPU T5200 @ 1.60GHz (2 CPUs), ~1.6GHz
    Memory: 1024MB RAM
    Available OS Memory: 1014MB RAM
    Page File: 1055MB used, 982MB available
    Windows Dir: G:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7600.16385 32bit Unicode


    ------------ DxDiag Notes ------------ Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Input Tab: No problems found.


    --------------- Display Devices --------------- Card name: Mobile Intel(R) 945 Express Chipset Family
    Manufacturer: Intel Corporation
    Chip type: Intel(R) GMA 950
    DAC type: Internal
    Device Key: Enum\PCI\VEN_8086&DEV_27A2&SUBSYS_01D81028&REV_03
    Display Memory: 251 MB
    Dedicated Memory: 0 MB
    Shared Memory: 251 MB
    Current Mode: 1280 x 800 (32 bit) (60Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: unknown
    Monitor Id: QDS0047
    Native Mode: 1280 x 800(p) (59.910Hz)
    Output Type: Internal
    Driver Name: igdumd32.dll
    Driver File Version: 8.14.0010.1930 (English)
    Driver Version: 8.15.10.1930
    DDI Version: 9Ex
    Driver Model: WDDM 1.0
    Driver Attributes: Final Retail
    Driver Date/Size: 9/23/2009 19:18:08, 3829760 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp:
    Device Identifier: {D7B78E66-64E2-11CF-1274-D221A2C2C535}
    Vendor ID: 0x8086
    Device ID: 0x27A2
    SubSys ID: 0x01D81028
    Revision ID: 0x0003
    Driver Strong Name: oem1.inf:Intel.Mfg:i945GM0:8.15.10.1930:pci\ven_8086&dev_27a2
    Rank Of Driver: 00F42001
    Video Accel: ModeMPEG2_A ModeMPEG2_C
    Friday, March 18, 2011 3:58 PM

All replies

  • Memory: 1024MB RAM
    Available OS Memory: 1014MB RAM


    You're system RAM does not meet minimum specs.  You need at least 2Gb of RAM in order to use the emulator reliably.

    Friday, March 18, 2011 5:01 PM
  • I suggest you try Intel's update utility to check for a newer driver: http://www.intel.com/p/en_US/support/detect/

    Your RAM can be expanded cheaply and easily if necessary.
    Friday, March 18, 2011 5:16 PM
  • Thanks for the response. Intel's update utility says that I have the latest drivers (WDDM 1.0)
    I have also heard of some kind of mod drivers as a workaround to this problem. Has anyone used them?
    Friday, March 18, 2011 11:32 PM
  • Have u found any workaround for this.....i am also stuck with the same

    Sunday, December 01, 2013 8:11 AM