locked
Cannot install an app in development on Windows 8.1 preview

    Question

  • I am having a problem deploying an app.  I have deployed it before, and uninstalled it successfully until today. 

    On a Windows 8.1 Preview build when I run the Add-AppDevPackage.ps1 script I get the following output:

    Installing app...
    Found dependency package(s):
    C:\Users\pgrimes\Downloads\Win8TestBed_1.2.0.0_Win32_Test\Win8TestBed_1.2.0.0_Win32_Test\Dependencies\Microsoft.WinJS.2
    .0.Preview.appx
    C:\Users\pgrimes\Downloads\Win8TestBed_1.2.0.0_Win32_Test\Win8TestBed_1.2.0.0_Win32_Test\Dependencies\x86\Microsoft.VCL
    ibs.x86.12.00.appx
    C:\Users\pgrimes\Downloads\Win8TestBed_1.2.0.0_Win32_Test\Win8TestBed_1.2.0.0_Win32_Test\Dependencies\x64\Microsoft.VCL
    ibs.x64.12.00.appx

    The app doesn't proceed past initializing.

    Looking in EventViewer, the last message in AppDeployment-Server is:

    Creating Resiliency File C:\ProgramData\Microsoft\Windows\AppRepository\89a6d891-30ae-4bb9-bf1b-c5e1a52a26a4_S-1-5-21-697466147-1865113505-931750244-66096_9.rslc for Add Operation on Package win8_1.2.0.0_x86__151pqn5g9d81t.

    Any ideas on how to fix this issue?

    Thursday, September 12, 2013 9:21 PM

All replies

  • Can you send the app so we can reproduce the problem?

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Friday, September 13, 2013 2:37 PM
    Moderator
  • PM me with a secure way please.

    One data point, I seem to be the only one in the office with this problem.  Everyone else installs and uninstalls fine...

    Friday, September 13, 2013 8:41 PM