none
Registration tool: Unable to connect to phone.

    Question

  • Hello - I have a Samsung Omnia 7, its been working and syncing with Zune for almost two weeks but today, when I make my first stab at phone development, it won't play ball. I'm using the latest developer tools. Zune is 4.7.1404.0. The Windows Phone Developer Registration tool does not allow me to log in, the boxes are grey (probably these activate once the device is detected). The error I receive in full is: Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established. Thanks for your assistance, Luke
    Wednesday, November 10, 2010 5:14 PM

Answers

  • Wondering whether it was a networking issue, it turns out that by disabling the Wifi connection it lets me get the "Error communicating with the developer portal. Please set the correct date and time on the phone, check the Internet connection and try again later (ErrorCode:0x64)" message - which makes me feel a whole lot better. Edit: then after a quick visit to the unlock and try again message, I'm in. And my family breath a sigh of relief.
    Wednesday, November 10, 2010 7:23 PM
  • Here's a thread with some more tips:
    http://forums.create.msdn.com/forums/t/65663.aspx

    Regarding Marketplace registration incomplete; if you got a student registration, i.e. did not need to pay, then you need to upload a simple dummy app (that can fail certification) in order to complete the registration process.
    Thursday, November 11, 2010 6:47 PM

All replies

  • I had the same problem yesterday when I tried hooking up my samsung focus to the registration tool. It's quite maddening and I don't think I've fully figured out what's wrong. But my process was just unconnecting the usb from the phone, closing the tool and zune. Then connecting the usb, starting zune, and then the tool But I was able to do it after about 10 tries. and the messages varied every now and then Sometimes I would get the "unable to connect, check zune's sync partnership", othertimes I would get "time incorrect, make sure it's correct and have internet connection". Also, as mentioned by the msdn docs, make sure that Zune is NOT syncing with your phone at the time of your registration as it will throw that message. Hope that helps!
    Wednesday, November 10, 2010 5:25 PM
  • Thanks for your prompt response Brian. I feel completely deflated. Not by your response, ;-) There's not much else I can do - Zune works fine, checked that it wasn't syncing, rebooted everything. This app is the culmination of 2 years work. I went without any mobile for 7 weeks prior to ensure I could get the first batch and I was all set... then it fails here.
    Wednesday, November 10, 2010 5:34 PM
  • Is there an official support line for any of this? I need to have this working, NOW.
    Wednesday, November 10, 2010 6:22 PM
  • Wondering whether it was a networking issue, it turns out that by disabling the Wifi connection it lets me get the "Error communicating with the developer portal. Please set the correct date and time on the phone, check the Internet connection and try again later (ErrorCode:0x64)" message - which makes me feel a whole lot better. Edit: then after a quick visit to the unlock and try again message, I'm in. And my family breath a sigh of relief.
    Wednesday, November 10, 2010 7:23 PM
  • Information regarding support offerings is listed on the feedback page for this site.  (Resources -> Support and Feedback)
    Here's a direct link: http://create.msdn.com/en-us/home/feedback

    In regards to your current problem, Try these steps:

    1. Disconnect the phone.
    2. Close the Zune software.
    3. Close the Developer Registration tool.
    4. Connect the phone.  (Make sure to connect to a root USB hub.)
    5. If the Zune software does not start automatically then launch it manually.
      5a. Unlock the phone if prompted.
    6. Launch the Developer Registration tool.


    Some additional tricks that may help:

    * After step 1 turn off the phone (hold power button for 6 seconds) and then turn it back on again.
    * Try using a different USB port on the desktop.
    * Increase the screen timeout to 5 min. 
    * If the device goes to the lock screen or screen off while connected then disconnect and reconnect before running the registration tool. 
    FWIW: For good measure I also close the Zune software whenever I disconnect my phone.

    Thanks,
    -Eric.



    Wednesday, November 10, 2010 7:31 PM
    Owner
  • Hi Eric, thanks very much for your assistance. Tucked away in one of my replies above is the answer. Sadly, this site (and MSDN) can't handle CRLF in comments from Google Chrome, so I couldn't make it stand out. Anyway, the fix is to disable wifi. It may be something to do with IP routing and having two IPs for the same device on the LAN. Maybe. Thanks and sorry for getting stressed - I'm really up against it and have worked on my own for >14 hours a day for two years. This app is the home straight.
    Thursday, November 11, 2010 4:58 PM
  • Is there any more information on how to get a phone registered? I am getting the "check the time" message over and over again. I checked it it is correct :P. It is set to automatic time.

    I have also followed Eric's suggestions. I have also disabled the wireless. so my process now is:

    1. turn off my phone (hold the power button till it shuts off) (Samsung focus)
    2. turn my phone on
    3. plug phone into computer (zune launch automatically)
    4. wait for sync to finish
    5. open windows phone developer registration
    6. wait for the message saying phone is ready (phone is unlocked)
    7. click register
    8. fail

    I get these messages every time

    1. 1st Try: Error communicating with the developer portal. Please set the correct data and time on the phone, check the Internet connection and try again later (ErrorCode:0x64)
    2. 2nd Try: Marketplace registration incomplete. Please return to the developer portal for more information. (ErrorCode 0x80043009)

    The only thing that sticks out to me is "Marketplace registration incomplete". But i've looked all over for marketplace settings that may not be complete and i cannot find any.

    Please help.
    Thursday, November 11, 2010 6:12 PM
  • Here's a thread with some more tips:
    http://forums.create.msdn.com/forums/t/65663.aspx

    Regarding Marketplace registration incomplete; if you got a student registration, i.e. did not need to pay, then you need to upload a simple dummy app (that can fail certification) in order to complete the registration process.
    Thursday, November 11, 2010 6:47 PM
  • OK thanks. That's definitely it.
    Thursday, November 11, 2010 6:49 PM
  • Just curious which suggestion resolved your issue?
    Friday, November 12, 2010 3:27 AM
  • I registered as a student and needed to upload a dummy app so that i could get GeoTrust to validate me. Other than that, following the steps I laid out above worked perfectly.
    Friday, November 12, 2010 3:47 AM
  • I too had the unable to connect to portal. But retrying did work fine.
    Friday, November 12, 2010 3:48 AM
  • Thanks for confirming that. It might be an idea to mark Mark's answer as answer (did you see what I did there? hehe ;) for other people to find easily.
    Friday, November 12, 2010 3:52 AM
  • I initially had problems connecting to my phone to register it. But after several attempts I was successful.

    I ended up disconnecting my phone, closing down  Zune, closing down the registration tool. I also closed out VS 2010.

    I connected my phone back up to the pc which started up Zune, then after everything synced up I opened up the phone registration tool and I was able to register my phone.

    Friday, November 12, 2010 4:23 AM
  • Did you have to fill out all the tax info as a registered student? I just want to test the apps that I'm playing around with on my own phone.
    Monday, November 15, 2010 9:37 PM
  • The Tax info did not affect whether i could set up registered devices as far as i could tell. The only thing that seemed to be important was the Geotrust verification.
    Monday, November 15, 2010 10:10 PM
  • My workaround for 'Unable to connect to phone' problem.

    Few days earlier I got in to well known 0x80043009 status of the registration and today decided to check if anything has happened.
    Well something had because Windows Phone Developer Registration tool did not even connect to the phone.
    I finally got it back to 0x80043009 error screen by:

    1. Turning off the phone by keeping power button down for 6 seconds and then starting it again
    2. At this point WiFi and 3G data were OFF
    3. Connection to phone was established but got 0x64 error
    4. Changed time from auto to manual => 0x64
    5. Enabled WiFi and changed time from manual to auto => 0x64
    6. Enabled 3G data and changed time from auto to manual => 0x80043009

    It looks like the connection error 0x64 is not related to connection between the PC and AppHub rather than the network connection the phone itself is using. It's a bit strange though that I got it 'working' only after enabling the 3G data, I'd expect WiFi to be enough.
    Tuesday, December 07, 2010 6:45 AM
  • Yes!! Thank you guys. Disable wifi on the phone and follow the steps above fixed this problem. Here's the screenshot of it failing for future reference http://twitpic.com/3gn4vf Thanks!
    Hi Eric, thanks very much for your assistance. Tucked away in one of my replies above is the answer. Sadly, this site (and MSDN) can't handle CRLF in comments from Google Chrome, so I couldn't make it stand out. Anyway, the fix is to disable wifi. It may be something to do with IP routing and having two IPs for the same device on the LAN. Maybe. Thanks and sorry for getting stressed - I'm really up against it and have worked on my own for >14 hours a day for two years. This app is the home straight.
    Friday, December 17, 2010 5:28 AM
  • Yes!! Thank you guys. Disable wifi on the phone and follow the steps above fixed this problem. Here's the screenshot of it failing for future reference http://twitpic.com/3gn4vf Thanks!
    Hi Eric, thanks very much for your assistance. Tucked away in one of my replies above is the answer. Sadly, this site (and MSDN) can't handle CRLF in comments from Google Chrome, so I couldn't make it stand out. Anyway, the fix is to disable wifi. It may be something to do with IP routing and having two IPs for the same device on the LAN. Maybe. Thanks and sorry for getting stressed - I'm really up against it and have worked on my own for >14 hours a day for two years. This app is the home straight.


    I don't think it has got anything to do with WiFi disabling. I didn't disable WiFi before unlocking my phone.

    Secondly, I have not tried from Google Chrome, but if your comments are not formatted, then check if you have set to 'HTML' in your profile. If you have, then it is true that Google and MS don't see eye to eye.
    Friday, December 17, 2010 3:36 PM
  • Nothing is working for me, i've tried everything in the above steps... I've got a LG-E900, but it always says: 'Unable to connect to phone...' I'm running out of ideas... :|
    Thursday, February 17, 2011 10:29 AM
  • Ok, turns out i need to hard reset my phone :| Worked fine after that... What a PITA.... Btw any idea why carriage returns don't work here in chrome?
    Thursday, February 17, 2011 11:44 AM
  • Thanks so much.

    I had tried connecting, disconnecting, restarting, relinking, resyncing many times with a different sequence.

    Finally after seeing this, i disabled wifi, auto time set, and manual syncing in zune, everything to manual and then restarted phone and zune and finally i was able to developer unlock my dell venue pro.

    Fortunately, when i tried htc hd7, it was very easy, i didnot have to do all this.

    Anyways, now its all fine.

    Thanks.

    Roshan

    Monday, March 07, 2011 6:37 AM
  • I have a LG-E900 too, the "Unable to connect to phone..." usually happened (for some reason) when i had the ports 80 used on the computer ;o

    Check the following:

    1. If you have a IIS Server running on port 80, stop it.
    2. Close Skype ( it tends to use port 80 and 443 )
    3. Disable windows firewall.
    4. Close any unnecessary processes running in the background.
    5. Restart the Device and Zune.
    6. Make sure that the Device is at the "start screen" / not having its screensaver running / locked. Things like that.
    7. Try again.

    If that does not work, then I'm not sure what may cause it, since that was the problem for me :p
    Friday, March 11, 2011 1:01 PM
  • Thanks Eric, that solved my issue.
    Thursday, April 28, 2011 3:32 PM
  • I had the same problem, it worked fine for a few weeks and then suddenly it refused to connect. (HTC HD7 T9292)

    Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established. 

    So I reinstalled the Phone Tools, reinstalled Zune and gave the Phone a hard reset ! Nothing helped. The phone synchronized with zune but wouldn't  work with the registration tool.

    Finally i removed a USB extensioncable..... and it worked ! Connected it again and did not work. So with the faulty extension cable it would connect and syncronize with Zune but no longer with the Registration tool !!!

    Hope this helps someone else.


    Friday, May 13, 2011 7:35 PM
  • I have the same problem, tried various combinations, no luck.

    Wednesday, June 08, 2011 5:22 PM
  • OK, very frustrating... I've got the same problem with my HD7 - is there a definative answer on this?
    Thursday, June 30, 2011 12:04 AM
  • This is a serious problem and there should be a definative answer this seems to be an on going issue that happens a lot and there should be answers
    Monday, July 04, 2011 1:47 AM
  • NO ANSWER TO THIS STILL??????????????????????????????????????????????
    Thursday, July 07, 2011 2:46 PM
  • There are a number of different things which can cause the developer phone registration tool to show an error but here are some tips for this particular error message:

    "Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established."

    Possible causes:
     ○ Communications timeout or noisy signal.
     Try this:
     · Ensure you are using the USB cable provided by the phone manufacturer.
     · Remove any USB extension cables.
     · Connect to a root USB hub.
     · Close all non-esential desktop applications.

     ○ Device did not detect previous disconnect event. 
     Try this:
     · Ensure you are using the USB cable provided by the phone manufacturer.
     · Disconnect USB cable from the phone.
     · Power cycle the phone , turn off and back on. 
       (To turn off, hold power button for 6 seconds.)
     · Close all running processes including Zune and PhoneReg.exe.
     · Connect the USB Cable to the phone.  (Zune should start automatically.)
     · Wait for Zune to complete all sync operations before starting phonereg.exe.
      
     ○ Incorrect version of Zune software.
            Try this:
     · Check for updates to the Zune software. In Zune software select "Settings" -> "Software" -> "General" and click on "CHECK FOR UPDATES" button.
     · Reboot the PC, after applying an update, before retrying the phone registration.

     ○ Phone Sync relationship changed since connection initiated.
     Try this:
     · Remove the USB cable from the phone.
     · Wait a few seconds. 
     · Insert USB cable into phone.
     · If connection still fails try device power cycle as per first listed cause.
      
     ○ Corrupted tools install.
     · Run a repair of "Microsoft Windows Phone Developer Tools -ENU", reboot PC after repair before retrying the Phone Registration.
     · Reapply the latest tools update.

     ○ HTC Arrive configuration issue.
     Try this:
     · if connected, unplug the phone device from the computer.

     _on the phone_:
     · Press the Windows button.
     · Press the right arrow button, or swipe left, to expose application list.
     · Select “Settings” option from the application list.
     · Select “Cellular” option in the settings list.
     · Select “Change Network Profile” and wait for this operation to complete.  (This is a key step! However, you don’t need to actually change anything on the resulting page.)
     · Press the back button or Windows key to exit the Settings application.
     · Retry the phone registration process.



    Thursday, July 07, 2011 11:02 PM
    Owner
  • Thanks Eric, as soon as I get home from work I will try this. and let you know how it works out :)
    Friday, July 08, 2011 12:56 PM
  • So I have the HTC Arrive for Sprint and this step that Eric gave worked right away HTC Arrive configuration issue. Try this: · if connected, unplug the phone device from the computer. _on the phone_: · Press the Windows button. · Press the right arrow button, or swipe left, to expose application list. · Select “Settings” option from the application list. · Select “Cellular” option in the settings list. · Select “Change Network Profile” and wait for this operation to complete. (This is a key step! However, you don’t need to actually change anything on the resulting page.) · Press the back button or Windows key to exit the Settings application. · Retry the phone registration process.
    Saturday, July 09, 2011 3:44 AM
  • I have tried every single step I have seen in the forums and I still see the "Unable to connect to phone.  please check that the Zune software is running..." error.  I have a Samsung Focus and I can connect to Zune properly.  I am out of ideas

    Any ideas?
    Wednesday, July 13, 2011 5:56 PM

  • We need a bit more information about your particular setup to provide something more than generic advice...

    For example, desktop OS version and Service Pack level, Zune software version, the "About" information from your phone, Developer tools version and updates applied, etc...

    Wednesday, July 13, 2011 10:57 PM
    Owner
  • Sure, no problem--here are the details:

    OS:  Windows 7 Enterprise 64 bit (no Service Pack)
    Zune:  4.7.1404.0
    Samsung Focus (SGH-i917)
    WP7 OS:  7.0.7390.0
    Windows Phone Developer Tools 7.0
    Windows Phone Developer Tools January 2011 Update and the Windows Phone Developer Tools Fix.
    Wednesday, July 13, 2011 11:23 PM
  • The same problem here. In my case I had a wrong date on the phone. Now it's working ok.
    Wednesday, July 13, 2011 11:57 PM
  • The same problem here. In my case I had a wrong date on the phone. Now it's working ok.


    I verified my date/time was correct.  I also went in and changed it to Manual (and it still failed to connect).  I went back in and changed it to Automatic (and it failed to connect).  It is currently set on Automatic with the correct date/time.
    Thursday, July 14, 2011 12:03 AM
  • Have you setup a sync relationship between your phone and the Zune software?  (... on any PC.)
    Have you power cycled the phone at least once since setting up the sync relationship or changing your device name?
    Have you restarted your desktop at least once since installing the most recent Zune software update?

    You can minimize delay related issues by closing all applications and disconnecting uneeded peripherals.
    Also make sure the phone is unlocked and at the home (Tile) screen when initiating the connection and when starting PhoneReg.exe.
    After connecting wait for Zune to show "Last Sync ..." in the Phone summary page before starting PhoneReg.exe.

    Are you logged into an administrator account when attempting the registration?
    You can also ensure the required registry keys for the tools are set by importing the .reg files from these locations:
     C:\Program Files (x86)\Common Files\microsoft shared\CoreCon\5.01\Misc\DtptProxyPortsAdd.reg
     C:\Program Files (x86)\Common Files\microsoft shared\CoreCon\5.01\Misc\DtptProxyPortsAdd2.reg
     C:\Program Files (x86)\Common Files\microsoft shared\CoreCon\5.01\Misc\SirepProxyPortsAdd.reg
     - and -
     C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v7.0\Tools\Phone Registration\PhoneRegAdd.reg


    FWIW: I suggest installing Windows 7 SP1 and latest security updates though I have no reason to believe that is related to your issue.
    Thursday, July 14, 2011 3:41 PM
    Owner
  • Hi,
    I'm trying to register my two phones but i got the same error "unable to connect to phone...".
    I followed all the instructions above with no luck.
    This happens with both the phones and also trying on another PC...
    Please help me.

    Kind regards

    Giovanni
    Tuesday, July 26, 2011 7:35 AM
  • So I have the HTC Arrive for Sprint and this step that Eric gave worked right awayHTC Arrive configuration issue.Try this:· if connected, unplug the phone device from the computer._on the phone_:· Press the Windows button.· Press the right arrow button, or swipe left, to expose application list.· Select “Settings” option from the application list.· Select “Cellular” option in the settings list.· Select “Change Network Profile” and wait for this operation to complete. (This is a key step! However, you don’t need to actually change anything on the resulting page.)· Press the back button or Windows key to exit the Settings application.· Retry the phone registration process.

    This worked for me. I wonder what it did?
    Saturday, July 30, 2011 1:10 AM
  • Hi,
    I'm trying to register my two phones but i got the same error "unable to connect to phone...".
    I followed all the instructions above with no luck.
    This happens with both the phones and also trying on another PC...
    Please help me.

    Kind regards

    Giovanni

    I have the same issue!  
    Saturday, August 13, 2011 10:19 PM
  • Change relationship between zune and phone to guest and try. If don´t help try to run in another pc.
    Sunday, August 14, 2011 7:05 PM
  • Sure, no problem--here are the details:

    OS:  Windows 7 Enterprise 64 bit (no Service Pack)
    Zune:  4.7.1404.0
    Samsung Focus (SGH-i917)
    WP7 OS:  7.0.7390.0
    Windows Phone Developer Tools 7.0
    Windows Phone Developer Tools January 2011 Update and the Windows Phone Developer Tools Fix.


    I have almost the exact same setup and nothing is working for me either...

    OS: Windows 7 64-bit (SP1)
    Zune: 4.7.1404.0
    Samsung Focus (SGH-i917)
    WP7 OS: 7.0.7390.0


    I've tried every suggestion in this forum, restarted everything, flipped date settings and WiFi. I've played with every setting in Zune and per the MS KBs, ran the fix tool (nothing to fix) and verified the Zune sync service is running. The ONLY way I have even briefly been able to get it to respond is to connect the device, Zune pops-up then start the Phone Developer Registration tool. Once everything is open, I power-down and restart the device. When it powers-up, the registration tool briefly sees the device, lets me type in username/password, says "connecting to the developer portal..." then loses connection and gives me the error message again. It's almost like the device and Zune are competing with each other.

    Any other suggestions? Is the Samsung Focus just not compatible with the developer tools? It syncs fine with Zune.
    Tuesday, August 16, 2011 10:51 PM
  • I was able to make it work by installing everything on a different machine.  It worked perfect on my 2nd machine so I have no idea why it did not work on the 1st machine.  The only real difference is that my 1st machine had a firewall running that I could never really disable...
    Tuesday, August 16, 2011 11:05 PM
  • I was able to make it work by installing everything on a different machine.  It worked perfect on my 2nd machine so I have no idea why it did not work on the 1st machine.  The only real difference is that my 1st machine had a firewall running that I could never really disable...


    Insane. I installed the WinPhone developers tools on my wife's laptop and it worked perfectly the first try. Thanks for the suggestion. Her laptop is about 3 years old, Vista and no Visual Studio installed. Oh well. Through that ordeal at least...
    Wednesday, August 17, 2011 12:35 AM
  • I cannot get it to work either here is what I got:

    32 bit Win 7, Zune Player 4.8, WP7.1 SDK RC, HTC Arrive on NoDo

    What I have tried:

    -Reinstalled the SDK
    -Reinstalled Zune 4.8
    -Rebooting Computer and Device
    -Different USB Ports
    -Change Network Profile on my Arrive (several times)
    -My Phone has a sync relationship
    -Change the time out from 3 to 5 min
    -Turn off Wifi on Phone

    In the Zune Player I recieve a notification that says something like "Connection Failed: Unable to connect to the phone through the internet, but you can still sync through a USB cable" I think it even popped up when the registration tool was not running.
    Thursday, August 25, 2011 4:28 PM
  • What is the exact status message shown in the phone registration tool?

    Have you tried the suggestions in the following phone registration trouble-shooting post?
    http://social.msdn.microsoft.com/Forums/en-US/wptools/thread/7d24f5be-fe62-4d7e-86cf-e98925ce9f1d/
      (...suggestions are broken out by status message.)

    Thursday, August 25, 2011 8:20 PM
    Owner
  • Registration Tool Message is:
    "Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established."

    And since updating the Zune Software to 4.8 I have been receiving :
    "Connection Error. We can't create a connection from your phone to the internet. You can still sync content between your computer and your phone."

    Every time I connect the phone with my manufacturer micro usb cable. I never saw it before the update.

    I read through the trouble shooting guide and tried most everything. I am looking over it again to make sure I didn't miss something that could help.
    Thursday, August 25, 2011 11:41 PM
  • The Zune error message definitely indicates a problem that would prevent the phone registration tool from working.

    Here is a link to a Knowledge Base article regarding that message which may help:
    http://support.microsoft.com/kb/2468384

    Friday, August 26, 2011 4:40 PM
    Owner
  • That worked, it appears it was a driver issue. Thank you Eric!
    Saturday, August 27, 2011 2:15 AM
  • I'd like to add to this with the solution that worked for me; using the same Samsung device, I tried all solutions given in this thread, to no use.

    I was trying to register with my phone completely offline (no SIM card, no wi-fi connection); I always had the "Unable to connect to phone" error. Turns out turning Wi-Fi back on and making the phone online to internet made it work instantly for me.

    So... for me I needed to have a computer that was online, and a phone that was online. Hope this helps someone.  
    Tuesday, September 27, 2011 9:03 PM
  • I have the same problem. Tried all suggestions posted in this thread, but nothing worked.

    OS: Windows 7 SP1 64Bit Prof.
    Zune Software: 04.08.2345.00
    Windows Phone SDK 7.1 installed
    All Updates installed.

    Phone: Nokia Lumia 800
    Phone OS Version : 7.10.7740.16

    Please help me.

    Sunday, December 04, 2011 1:05 PM
  • Hi,

    I get this error: "Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established". This error message I have received every time since I first tried to register my phone. Synchronisation of pictures/files with Zune is all right, so seems everything else.

    Other things I've tried:
    - restart phone and computer
    - restart Zune, phone registration tool
    - turn off wifi
    - switch between manual/automatic time/date setting
    - fix/reinstall of Windows Phone Developer Tools
    - Tried all USB ports on my computer (with original cable)
    - etc.

    I have an LG Optimus 7 E900.
    OS version: 7.10.7740.16
    Zune is up to date.
    Windows Vista SP 2.
    Thursday, December 08, 2011 12:06 PM
  • Now it works for me with WiFi deactivated. But this isn't an option for productive work...
    Friday, December 09, 2011 6:29 PM
  • Now it works for me with WiFi deactivated. But this isn't an option for productive work...


    Once the phone is registered you should be able to enable WiFi on the phone again and continue to use the other tools for deployment and debugging.

    Monday, December 12, 2011 4:53 PM
    Owner
  • Nope this doesn't work. After the registration process is done, the phone doesn't connect to Visual Studio with WiFi enabled. Once i turn WiFi off, everything works great. Since i had contact to other developers who haven't problems with their Lumia 800, i suppose its a bug on my phone. I will contact the Nokia Care Service and hope they can fix it.
    Monday, December 12, 2011 5:06 PM
  • It worked now by doing a reset of the phone to default settings.
    I might also mention that I chose another timezone after start of the phone (same UTC +01 but another list of cities), but I guess it was the reset itself that was the reason for it now to work.

    The registration process went fine and without problems the first time I tried after the reset.
    Tuesday, December 13, 2011 10:14 AM
  • I'm sharing this because I know this is extremely frustrating. Hopefully it will help someone else:

    I spent a several hours dealing with "Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established." I read all of the threads out here and tried all of the suggestions except the hard, factory reset.

    Basically, I had no communication to the device (HTC Radar 4G). The following conditions existed:

    I couldn't connect from VS2010
    I couldn't connect from the Registration Tool
    I couldn't connect from WPConnect.exe
    I couldn't manually deploy an XAP using the Deployment Tool
    Zune worked fine with the device and recognized it everytime I connected the device regardless of which USB port I used and whether WiFi or BlueTooth were turned on

    Prior to this problem occurring, I'd been deploying and debugging on the device routinely without incident, including earlier in the day. The problem seemed to have started after I installed an App Update from Marketplace for HTCs "Attentive Phone".

    I was able to restore the phone back to a previous state using Zune and the problem was fixed immediately. The only thing I had to do was to re-register/unlock the phone because the restore point was earlier in time than the unlock.

    Note to Microsoft: there needs to be a way to create restore points on demand via Zune if such app updates are capable of creating situations like this. I should have been able to restore to the state earlier in the day as opposed to the device state 3 weeks ago.
    Thursday, March 01, 2012 1:20 PM
  • I had the phone connected to a USB hub and it showed this problem (although Zune was able to connect to the phone just fine). After several retries I unplugged the USB cord from the hub and connected it directly to the computer and it was able to connect immediately.
    Friday, March 16, 2012 2:32 AM
  • I'd like to confirm that this worked for me as well.  Cheap USB extension cord was the source of the problem.
    Wednesday, March 21, 2012 4:11 PM
  • I have a Samsung device and for me it ended up being a difference in the time between the host machine and the device.  Once I adjusted the machine's time to match the time on the phone it was recognized immediately.  Hope this helps someone.
    Tuesday, March 27, 2012 1:45 PM
  • I am Hvaing Nokia Lumia 800 and i installed windows developer tool in my windows 7 pc and i also registered in apphub as a student but when i try to register the device in windows phone developer registration it shows this message"Unable to connect to phone. Please check that the Zune software is running and that Zune's sync partnership with your phone has been established" i tried all the possible steps recommended by various guys like restarting the phone, zune and developer tool but still it shows the same message . also i turned off my phones wifi and cellular and switched to airplane mode

    OS VERSION;7.10.8107.79

    FIRMWARE REVISION NUMBER;1600.2487.8107.12070

    HARDWARE REVISION NUMBER;112.1402.2.4

    RADIO SOFTWARE VERSION;8255

    RADIO SOFTWARE VERSION;1.6.00.24

     

    PLEASE HELP ME OUT

    Tuesday, May 29, 2012 7:08 AM