none
Publishing in VS2005 is very slow

    Question

  • Hi,

    I have simple Windows form project which I choose to publish. Usually it works fine but for my current project for whatever reason it'll sit for 3-5 minutes showing "publish building" while VS is doing nothing (no high CPU utilization, nothing) and then it'll finally publish. Manually building project is very quick.

    What can be possibly a reason for this behaviour?

    Sunday, November 05, 2006 4:24 PM

All replies

  • Hi,

    I have the same problem. It is even slower when publish a net3.0 WPF application. I've re-install my Visual Studio, and it does not help. What went wrong? Any specila requirement for a web server to host ClickOnce app?

    Although it is slow, I can publish .NET 2.0 application, I read in the forum that there are some issues regarding to .NET 3.0 bootstrap files. I have the latest .NET runtime components and VS extention installed. Would I be able to publish .NET 3.0 application with pre-requsite framewoek assemblies using the publish wizard now?

    Is there any log file that I can look to resolve the issue?  Please help!!!

    Regards,

    Reggie

    Tuesday, December 19, 2006 9:58 PM
  • Have you guys tried installing VS2005 SP1? I think this is one of the issues addressed by the service pack.
    Wednesday, December 20, 2006 5:36 AM
  • If you deploy your prerequisites on the same install location as your application, VS has to create the prerequisites on every build.  Just tell the installer to get the prerequisites from the vendors website.
    Monday, December 10, 2007 6:12 PM
  • We encountered the same problem - applcation build time was about 1 minute but publish time was about 6-7 minutes, we published to a server on our local network.

     

    Solution: From the Publish tab, change the "Publishing Folder Location" to a local network path (i.e. \\my_server\my_publish_folder) and put the internet publish url in the "Installation Folder URL".  After this change publish time dropped to just over 1 minute.

     

    Slow settings:

       Publishing Folder Location = http://mywebserver.com/my_app_publishfolder

       Installation Folder URL = <empty>

     

    Fast Settings:

      Publishing Folder Location = \\my_server\my_publish_folder

      Installation Folder URL = http://mywebserver.com/my_app_publishfolder

     

     

    Hope this helps someone.

     

    Cheers,

    Dean

    Monday, August 18, 2008 6:31 AM