none
problem publishing

    Question

  • I need to create a deployment for an application. I'm using vb2010

    I can build successfully. After built I can go to my release folder and run the executable with no issues.

    When I try to publish I get 2 errors:

    Error 1 Cannot publish because a project failed to build.  1 1 DDM SS

    Error 2 An error occurred generating a bootstrapper: Unable to begin updating resource for bin\Release\app.publish\setup.exe with error 80070002 DDM SS

    Thanks


    Ros

    • Moved by Mike FengModerator Monday, April 30, 2012 7:06 AM ClickOnce (From:Visual Basic General)
    Friday, April 27, 2012 9:15 PM

Answers

All replies

  •  If I uncheck the create setup program ti install prerequisite components I can publish.

    With this cheked I got the same error.

    I  deleted the bin and obj folders, restart the machine, change the configurations, plattaform.. nothing seems to make a difference.

    Thanks


    Ros

    Friday, April 27, 2012 10:52 PM
  • I need to create a deployment for an application. I'm using vb2010

    I can build successfully. After built I can go to my release folder and run the executable with no issues.

    When I try to publish I get 2 errors:

    Error 1 Cannot publish because a project failed to build.  1 1 DDM SS

    Error 2 An error occurred generating a bootstrapper: Unable to begin updating resource for bin\Release\app.publish\setup.exe with error 80070002 DDM SS


    Ros

    Friday, April 27, 2012 10:59 PM
  • This could be related to permission on the "bin\Release\app.publish\" folder, try to delete and re-publish the application.

    #) Do you really want any pre-requisite with your application? if not then please remove the pre-requisite from the app.

    Also it would be better if you share the complete log file.

    Regards,
    Keshav Jain

    Sunday, April 29, 2012 7:01 PM
  • http://connect.microsoft.com/VisualStudio/feedback/details/551674/vs-2010-rtm-returns-error-cannot-publish-because-a-project-failed-to-build-even-though-solution-builds-fine

    It seems that there're some workarounds for this kind problem.

    Try to right click on the project and publish your project, and also ensure your PC's time is very correct and the files datetime attribute(right click a file-> Properties).

    If there's any concern, please feel free to let me know.

    Best wishes,


    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 30, 2012 4:05 AM
  • Hi Rosvb,

    Welcome to the  MSDN  Forum.

    Please take a look at this similar thread: http://social.msdn.microsoft.com/Forums/en/winformssetup/thread/e81d47d9-5df6-49b9-84b4-7bdbe77d3eaa 

    Did you have try this method:

    See http://social.msdn.microsoft.com/forums/en-US/vssetup/thread/240c82e9-1696-4618-846c-aaae21427a52

    There's a reply there about clearing your %TEMP% folder to get rid of the bootstrapper error.  I tried this, and it worked for me.  

    Finding your TEMP folder:

    To find your %TEMP% folder (in Windows XP, which I am using; if you're not using XP, search for "Windows 7 Environment variables"), right-click My Computer, select the Advanced tab, and then click the Environment Variables button.  An alternative way is to hold the Windows button and click the Pause/Break button; select the Advanced tab, and then click the Environment Variables button.

    Under the list titled "user variables for <your username>", find the listing for 'TEMP'.  On my machine, 'TEMP' has a value of ' %USERPROFILE%\Local Settings\Temp'.  Therefore, I navigate to C:\Documents and Settings\jdobson\Local Settings\Temp\.  This is my %TEMP% folder.  Note that the Local Settings directory will not be visible unless you have 'Show hidden files and folders' selected in your Folder Settings.  If you don't see Local Settings (or a folder which should be there as described), then you'll need to turn 'Show hidden files and folders' on.

    Turning on 'Show hidden files and folders':

    1. Open up any windows explorer window

    2. Press alt-T

    3. Select 'Folder Options' from the drop-down menu

    4. Select the 'View' tab

    5. Under 'Hidden Files and Folders', select 'Show hidden files and folders'

    Before you proceed, close all programs.

    Once you're in your TEMP directory, ctrl-A to select everything and then press 'delete'.  The deletion process might stop before it is finished, telling you that it cannot delete such-and-such file.  When it stops, all the remaining files in the directory should still be all selected.  Ctrl-deselect the single file that could not be deleted (it should be the first one in the directory at this point), and then press delete again.  Continue this until you have deleted everything that can be deleted.

    Fire up your project, and attempt to Build.  This may or may not work, but it sure cleared up everything for me.

    Good luck.

    I hope this will be helpful.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 30, 2012 7:05 AM
  • Hi Mike,

    I tried all the above and got the same results..........


    Ros

    Monday, April 30, 2012 3:27 PM
  • re-installing vs2010 solved


    Ros

    • Marked as answer by rosvb Monday, April 30, 2012 11:10 PM
    Monday, April 30, 2012 11:10 PM
  • Any way, I'm glad to hear that the problem was gone.

    Have a good day!


    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, May 01, 2012 3:55 AM
  • I am having this same issue with an absurdly simple project. (bootstrapper with error# 80070002)  I'm trying to publish an empty wpf project with .NET 4.0 framework and Windows installer as only prereqs.  I have tried all of the workarounds short of reinstalling VS2010.  I have deleted the bin and obj folders; reviewed (and replaced just in case) the bootstrapper package files; cleared the temp folders; unbound the source control; etc.etc.  I simply cannot believe that a VS reinstall is the recommended solution. 

    Has anyone come across a less ambiguous solution?

    Wednesday, May 23, 2012 6:03 PM
  • Hi multithreadedMama,

    You can get this build error if you have add-ins installed in Visual Studio; it has to do with race conditions between doing the Build and something about the add-ins.

    Try using the menu option Build/Publish instead of the Publish button in the properties pages. The menu option goes through a different process, and uses msbuild to build the application rather than VS, so it takes any problem caused by the add-ins out of the equation.

    RobinDotNet


    Click here to visit my ClickOnce blog!
    Microsoft MVP, Client App Dev

    Friday, May 25, 2012 7:23 AM
  • yes, I ran into that thread a few days ago and tried publishing from the Menu.  Didn't work though.  I'll run through and check the add-ins.  Only thing I think I have is .NET Reflector.  Thanks for the suggestion.

    Friday, May 25, 2012 7:19 PM