none
Error 1722. There is a problem with this Windows Installer package.

    Question

  • Hi Friends,

    I 'm facing the following issue with my Setup package when installing it in Windows 7 Professional SP 1 64 bit:

    MSI (s) (C4:54) [07:51:31:652]: Product: Purchase Analyzer -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action _B03D2528_1836_4042_A1D4_EF97AD50A934, location: C:\Program Files (x86)\Audio\Purchase Analyzer\cmd.exe, command: /c "C:\Program Files (x86)\Audio\Purchase Analyzer\RestartMSSQL.bat"

    Can anyone please shed some light on what could be wrong and process to fix this?

    Thanks,

    Hemant.

     


    Hemant
    Saturday, February 04, 2012 10:27 AM

All replies

  • As this forum supports setup and installation of Visual Studio itself, you'll get the best suggestions if you post your question in the forum dedicated to application deployment, here:

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads

    Saturday, February 04, 2012 1:30 PM
  • Hi Hemant,

     

    Welcome to the MSDN forum.

    According to your description, I'd like to move this thread to " ClickOnce and Setup & Deployment Projects" forum for better support.

    Thanks for your understanding.

     

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    Monday, February 06, 2012 4:06 AM
    Moderator
  • Thanks Team,

    Any thoughts/suggestion around the Issue how to solve it? Also, thanks for posting my question to the right forum :)

    Thanks,

    Hemant.


    Hemant
    Monday, February 06, 2012 5:22 AM
  • It looks like you ran that program as a custom action and it either crashed or returned a non-zero exit code (another indication to fail the install).
    Phil Wilson
    Monday, February 06, 2012 6:24 PM
    Moderator
  • Yes Phil,

    We have removed the execution of batch file (custom step) from the package and now we are not seeing this issue. Not sure why we are facing this issue only with Windows 7 Professional SP 1 64 bit. We are executing the setup with "Run as Administrator" option but still no luck. We don't see issue with other OS such as Windows XP.

    Any suggestion around executing the batch file successfully with Windows 7? The purpose of the batch file was to restart sql server instance after the package installation. Now we have accomplished this writing installer code instead of executing batch file. But was just curios as what could be the solution for batch file with Windows 7.

    Thanks,

    Hemant.


    Hemant

    Tuesday, February 07, 2012 2:10 PM
  • Hi Hemant,

    How did you add the batch file Custom Action for the Setup project? I doubt it has anything related to Operation System, would you please try the steps in this link? http://stackoverflow.com/questions/2414956/how-to-run-a-bat-file-during-installation

    Or you may try Advanced Installer: http://www.advancedinstaller.com/user-guide/qa-launch-batch-file.html
    Windows Installer cannot launch batch files directly by using  installed or attached custom actions. However, in Advanced Installer you can run a CMD or BAT file through a Launch file or open URLpredefined custom action. In the case of a 64-bit CMD or BAT file you        can use another predefined custom action called Launch file or  open URL Using a 64-bit Launcher. 

    Please make sure the following are true:
    - your package is marked as 64bit from the Install Parameters page
    - your custom action is marked as 64bit if applicable. More information, please check http://www.advancedinstaller.com/forums/viewtopic.php?f=2&t=11082


    Helen Zhou [MSFT]
    MSDN Community Support | Feedback to us


    • Edited by Helen Zhou Wednesday, February 08, 2012 3:00 AM
    Wednesday, February 08, 2012 2:50 AM
  • Thanks Helen,

    I will ask my deployment team to try these options and see if this helps and keep you updated.

    Hemant.


    Hemant

    Wednesday, February 08, 2012 3:29 PM