none
ClickOnce through Proxy with Authentication

    Question

  • Hello,

    I have a problem with ClickOnce Deployment:
    My app runs on Windows Server 2003, IIS 6.
    In my university we have a proxy which needs authentication, and if I click the .application file, first there is a login window for the proxy, then the window ("verifying application...") comes up, but then there is an error message, saying that the file *.application can not be downloaded.
    In the log file is an entry: the server is unreachable, so I think the process which downloads the .exe and the other .dlls don't know the proxy authentication information. what can I do, to run the application behind such a proxy?
    thanks,
    marco

    Monday, November 28, 2005 12:46 PM

Answers

  • Obviously there is a fix:

    http://support.microsoft.com/kb/917952/en-us

    Hotfix information
    A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next .NET Framework 2.0 service pack that contains this hotfix.

    To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
    http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

     

    Friday, October 13, 2006 8:31 PM
  • Unfortunatley, proxy authentication is not supported in ClickOnce. We are looking to fix this issue in a future version.

    Thanks,
    Sameer
    Tuesday, November 29, 2005 1:35 AM

All replies

  • Unfortunatley, proxy authentication is not supported in ClickOnce. We are looking to fix this issue in a future version.

    Thanks,
    Sameer
    Tuesday, November 29, 2005 1:35 AM
  • Which port is ClickOnce using? if you know the port, you can configure the firewall / proxy properly (provided you are authorized to do that), so that ClickOnce -Deployment can be used.  Or is this a naive thought ?

    hope this can contribute a little

    greetings

    daniel

    Wednesday, January 11, 2006 8:36 AM
  • Click-Once uses HTTP (port 80) to download the required files.

    The problem is, that the launching app, which want to download via HTTP, don't know anything about proxies (which need another authentication than windows integrated), so it fails. Its not a firewall configuration problem. (and that is the advantage of click-once!)

    marco

    Wednesday, January 11, 2006 9:22 AM
  • You it found the solution?
    Tuesday, September 05, 2006 3:53 AM
  • Hi,

    No, sorry, there isn't a solution!

    marco

    Saturday, September 16, 2006 6:52 AM
  • I just came accross the same issue, I then googled and found this solution. so I thought I would share it.

    FIX: Error message when you try to install a ClickOnce application that you created in the .NET Framework 2.0 onto a client computer that is configured to use a proxy server: "Proxy authentication required"

    The Hotfix can be found here.

    http://support.microsoft.com/kb/917952/en-us

     

     

     

    Wednesday, September 20, 2006 7:37 PM
  • Obviously there is a fix:

    http://support.microsoft.com/kb/917952/en-us

    Hotfix information
    A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next .NET Framework 2.0 service pack that contains this hotfix.

    To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
    http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

     

    Friday, October 13, 2006 8:31 PM
  • The hotfix does not seem to work for me.

    Has anyone tried the hotfix with success?

    Monday, December 04, 2006 12:04 AM
  •  

    The issue could be if the Proxy Server doesn't use NTLM and requires user to enter username and password, how do you tell ClickOnce about this information?

    Monday, December 04, 2006 4:35 AM
  • BUMP.

    Will MS ever fix ClickOnce so it will work with Proxy Servers requiring non-integrated authentication.

    It would be nice if clickonce can pop up a dialog box to request for proxy server user credentials much like internet explorer.

    Wednesday, December 06, 2006 10:49 PM
  • I am having the same problem.The target install location uses a proxy server and the Click Once install keeps failing. We temporarily disabled the proxy to allow users to install but when it is re-enabled, the update functionality does not work. In some cases we get Cannot activate a deployment with earlier version than the current minimum required version of the application when we try to launch the application from the start menu, but the client pc has the minimum required version already installed. I checked the manifest to make sure.

    This is a real bummer.

    In some locations where the network is configured to route traffic through the proxy, if you disable the proxy in IE, you can still browse the web. As a work around, we are configuring the proxy settings in IE to not use the proxy for the install domain name, *.domain_name.net. Then every thing works. But not all target install locations can still access the internet with their browser if they don't go through the proxy server...

    I also tried adding the <defaultProxy enabled="true" useDefaultCredentials="true" /> to the machine.config file, but it did not help either.



    webbj@us.ibm.com
    Wednesday, December 13, 2006 11:32 PM
  • Hello Microsoft Representatives
    I am in this forum from Late 2005 and this question constantly emerge and I am still having problem with several of my clients on this issue, when I create an update they need to disable the proxy and re-enable it after updating the system. This unbearable plus my clients think that there is something wrong with my application and not the deployment platform and I truly can't blame them.

    If any of you Microsoft guys and girls can answer this question with an article that say exactly what should we do in machine.config to make it work (not just you need to config the machine.config) this would be great.
    and please post an answer only after you make it work.

    If you manage to make it work then:
    Can you please explain in details how you achieve that?
    What happen if it is not a local Proxy and I do not have access to it?
    Is it possible to config the machine.config instead?
    If it does, can you send me the exact definition that works for you?

    Thanx anyway.

    Itzik Katzav

    Thursday, January 11, 2007 8:42 AM
  • I am trying to understand if this is the same problem I am going to face. I am in a Corporate setting where IE users hit websites using a proxy. The clickonce files I have put on a intranet webserver are not protected. Now when my users will hit this website, will I run into proxy authentication issues?

    Thanks

    Thursday, January 18, 2007 5:19 PM
  • I get a 404 error when the automatic configuration script option is enabled. When I disable it, the application gets downloaded/installed. Is it the same proxy problem as other people are having in this thread??
    Monday, January 22, 2007 5:32 PM
  • We are experiencing the same difficulties already reported above.

    Ours is a .NET 2.0 ClickOnce application.  Clients in corporate environments that use proxy authentification simply cannot install unless they disable the proxy which is usually not an option.  This is a huge and recurring problem that makes us look bad -- and it pretty much defeats the purpose of ClickOnce.

     

    Microsoft: for starters, could we please get the HotFix listed here: http://support.microsoft.com/kb/917952/en-us ?

     

    Thanks.

    Wednesday, April 18, 2007 10:10 AM
  •  

    I am experiencing the same difficulties already reported above.

     

    The hotfix proposed is not a solution because in my installation process the Framework 2.0 is a prerequisite so the client won't be able to download the framework and the hotfix using ClickOnce !

     

    What are you waiting to solve this issue? Tools like InnoSetup implement proxy authentication !

    Wednesday, July 04, 2007 12:14 PM
  • I've similar issue, and i'ven't found solution...

     

    Thursday, December 06, 2007 9:17 AM


  • The solution I use is placing the following in the machine.config file last entry :
      </system.web>
       <system.net>
     <defaultProxy enabled="true" useDefaultCredentials="true">
          <proxy
            proxyaddress="http://urproxyname.urdomain.comStick out tongueort#"
            bypassonlocal="false"
          />
        </defaultProxy>
      </system.net>
          </configuration>


    This has worked for me on a few machine running clickone apps.


    Mark
    Thursday, February 14, 2008 8:11 PM
  • Has this been addressed in the latest version? 

    Friday, June 20, 2008 1:52 PM
  • Any solution to this yet?
    Friday, March 06, 2009 10:21 PM
  • As far as I am aware there is no fix for this in .Net 3.5. You can see my work around for this in my plog post on this issue:

    http://bronumski.blogspot.com/2009/06/clickonce-updates-via-authentication.html

    Bro Num
    • Proposed as answer by Bronumski Monday, June 15, 2009 1:36 PM
    Wednesday, June 10, 2009 10:56 AM
  • The proxy authetication  is not an isolated issue with Click once , a lot of microsoft applications having web installers cannot install behind a proxy. I don't understand why MS cannot solve this issue one and for all.
    Wednesday, September 14, 2011 8:56 AM
  • Any update on this issue. We already come very far in our application and cannot avoid proxy servers.
    Friday, January 18, 2013 9:48 AM