none
Updater block error with "The client does not have sufficient access rights to the requested server object."

    Question

  • I am using Microsoft application updater block with .net 2.0 and IIS 5.0.

    for security restrictions i am not using the click once.So i go for Application updater blocks for this auto updation functionality.

    so here is my problem -

    When i am running the 1.0.0.0 version in client and i deployed 1.0.0.1 version in deployment server and When i am starting the AppStart.exe it is asking for updation confirmation dialog with Yes or No buttons. when i clicked on Yes button it is giving the following error -

    "The client does not have sufficient access rights to the requested server object."

    I created one virtual directory and make that directory as Application by click on Create button in Properties page of the Virtual directory where i am deploying the 1.0.0.1 application.

    how can i solve this?

    Pleaser help me out in this regard?

     

    ThankQ!

    Monday, June 12, 2006 12:52 PM

All replies

  • Start small: In the properties of the virtual directory enable Write and/or other rights.  Also, check the permissions of the actual folder where the virtual directory is; try giving the Everyone group full rights to that physical directory.
    Monday, June 12, 2006 11:27 PM
  • The answer is copied from a post.. It worked for me
    I am putting it here because this is the first link given when the problem is searched on google.
    So users will save time, getting the answer at the very 1st post.

    Earlier versions of IIS include a wildcard character MIME mapping, which
    permits IIS to serve any file regardless of its extension. IIS 6.0 does
    not include this wildcard character MIME mapping and does not serve any
    type of extension that is not defined at the MIME Map node in the IIS
    metabase. You must add the .config extension to the list of registered
    MIME types to ensure that they are not filtered by the server. In
    addition, IIS does not allow downloading .config files, since they are
    used by ASP.NET. So you will remove .config from your application
    settings.

    To download .config files from the Web server, you will need to perform
    the following steps:

    Define the MIME type in IIS for the specific file extension (.config)
    Remove the App Mapping for certain file extensions (if required)
    Define the MIME type in IIS for the specific file extension:

    Open the IIS Microsoft Management Console (MMC), right-click the
    Virtual Directory, and then click Properties.
    On the HTTP Headers page, click MIME Types.
    Click New.
    In the Extension box, type.config or any required extension.
    In the MIME type box, type a valid MIME type (for example, text/xml for
    .config files).
    Apply the new settings. IIS now serves files with the extension that
    you added. In this example, IIS now serves files with the extension
    specified in step 4.
    Remove the App Mapping for certain file extensions (if required)

    Open the properties of Application Virtual Directory
    Select the Configuration option from the Virtual Directory Tab
    In the Application Configuration window (Mapping Tab), check whether
    App Mapping exists for the File Types (.config)
    If there is an App Mapping corresponding to the File Type (.config),
    you will need to remove it.

    Cheers!!!
    • Proposed as answer by Ankur Mundhra Friday, October 16, 2009 11:37 AM
    Friday, October 16, 2009 11:36 AM