none
ClickOnce "Deployment and application do not have matching security zones"

    Question

  • Hi,

    I've created a simple click-once application (console) that the only thing it does is running another exe.

    The application security is set to 'full trust', set to 'the application is available online only' and published into C:\myApp\ folder.

    I than copy it into a CD and using the auto-run that calls setup.exe, trying to install the app.

    On some computers (not all), windows 7, I'm getting the following error:

    Deployment and application do not have matching security zones

    (The entire clickonce log is below)

    I've tried to delete the '2.0' folder, and to re-install the .NET framework 2.0, which was a solutions offered over the web - nothing worked.

     

    Any idea anyone?

     

     

    The log:

     

     

    PLATFORM VERSION INFO

    Windows : 6.1.7600.0 (Win32NT)

    Common Language Runtime : 4.0.30319.1

    System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)

    clr.dll : 4.0.30319.1 (RTMRel.030319-0100)

    dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)

    dfshim.dll : 4.0.31106.0 (Main.031106-0000)

     

    SOURCES

    Deployment url : file:///E:/PokerPodRunner.application

     

    IDENTITIES

    Deployment Identity : PokerPodRunner.application, Version=1.0.0.9, Culture=neutral, PublicKeyToken=9c8847794f8b63fd, processorArchitecture=msil

     

    APPLICATION SUMMARY

    * Online only application.

     

    ERROR SUMMARY

    Below is a summary of the errors, details of these errors are listed later in the log.

    * Activation of E:\PokerPodRunner.application resulted in exception. Following failure messages were detected:

    + Deployment and application do not have matching security zones.

     

    COMPONENT STORE TRANSACTION FAILURE SUMMARY

    No transaction error was detected.

     

    WARNINGS

    There were no warnings during this operation.

     

    OPERATION PROGRESS STATUS

    * [29/09/2010 01:14:36] : Activation of E:\PokerPodRunner.application has started.

    * [29/09/2010 01:14:36] : Processing of deployment manifest has successfully completed.

    * [29/09/2010 01:14:36] : Installation of the application has started.

     

    ERROR DETAILS

    Following errors were detected during this operation.

    * [29/09/2010 01:14:36] System.Deployment.Application.InvalidDeploymentException (Zone)

    - Deployment and application do not have matching security zones.

    - Source: System.Deployment

    - Stack trace:

    at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)

    at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)

    at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)

    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

     

    COMPONENT STORE TRANSACTION DETAILS

    No transaction information is available.

     

     

     

     


    Eli Gazit (try this free icons site: http://www.iconbuffet.com/people/new?ref=EliGazit)
    Sunday, October 03, 2010 8:30 AM

Answers

  • Hi Eli,

     

    I did some research but cannot find valuable information on the issue.

     

    > I've tried to delete the '2.0' folder, and to re-install the .NET framework 2.0, which was a solutions offered over the web - nothing worked.

     

    I have also seen that solution when doing research. The error message doesn’t make the thing clear enough. Could you please catch the crash dump?

     

    Sincerely,

    Kira Qian

    MSDN Subscriber Support in Forum

    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework!
    • Marked as answer by Eli Gazit Wednesday, October 06, 2010 8:50 AM
    Wednesday, October 06, 2010 8:16 AM

All replies

  • Try changing "online only" to "online/offline".

    RobinDotNet


    Click here to visit my ClickOnce blog!
    Microsoft MVP, Client App Dev
    Monday, October 04, 2010 8:22 AM
  • Already tried, seems to work (but I need the online only)
    Eli Gazit www.softwear.co.il
    Monday, October 04, 2010 9:42 AM
  • Hi Eli,

     

    I did some research but cannot find valuable information on the issue.

     

    > I've tried to delete the '2.0' folder, and to re-install the .NET framework 2.0, which was a solutions offered over the web - nothing worked.

     

    I have also seen that solution when doing research. The error message doesn’t make the thing clear enough. Could you please catch the crash dump?

     

    Sincerely,

    Kira Qian

    MSDN Subscriber Support in Forum

    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework!
    • Marked as answer by Eli Gazit Wednesday, October 06, 2010 8:50 AM
    Wednesday, October 06, 2010 8:16 AM
  • It seems that the problem is that one of the files in the application folder is corrupted. I have no idea why the exception is 'security zone', but I will have to deal with the corruption of the file first (I'm deploying via an USB-device, it is easy to blame the hardware guys...).

     

    Thanks for now.

     

    Eli

     


    Eli Gazit www.softwear.co.il
    Wednesday, October 06, 2010 8:53 AM