none
did not send WWW-Authenticate header

    Question

  • When I try to publish a project to my web server I get the following error in the VS IDE Error list:

    Error 1 Failed to connect to 'http://apps.emuge.com/keyeng/' with the following error: Unable to create the Web site 'http://apps.emuge.com/keyeng/'.  The Web server does not appear to have any authentication methods enabled.  It asked for user authentication, but did not send a WWW-Authenticate header.

    Publishing computer
    Windows 7
    VB2008 Express + Visual Web Developer 2008 Express

    Web Server
    Server 2003 Standard
    IIS 6 + Frontpage Extensions
    /keyeng directory security configured with annonymous, basic & integrated options

    ...so as far as I can tell this should work...but I'm still getting the error message.

    Thanks for your help!

    Tuesday, November 17, 2009 6:58 PM

Answers

  • Hi Derek,

     

    These are the solutions:

    1.       You need to run the Visual Studio as administrator.

    2.       Ensure that you have the Microsoft Visual Studio Web Authoring Component installed on the machine that you are publishing from. For Express users, this component is not installed by default. For more information, see: http://go.microsoft.com/fwlink/?LinkId=102310 

     

    To troubleshoot more ClickOnce issues, you can follow the document below:

    http://msdn.microsoft.com/en-us/library/ms229001.aspx

     

    Let me know if this does not help.

    Aland Li


    Please mark the replies as answers if they help and unmark if they don't. This can be beneficial to other community members reading the thread.
    Thursday, November 19, 2009 6:27 AM
    Moderator