none
Properties Settings Not showing Types for My own Project

    Question

  • Hi I've been playing around with user settings, and in the settings designer you have a drop down list for picking a type. This Type seems to come from all the References you have in your project but not from the actual project. For example I started a new Windows Form project and create a Name class. The Type combo would not display my type even through browse and I couldn't type in the type either. So just for a quick hack I added my own project as a reference and low & behold my type now shows up but I get a bunch of warnings for duplicate names. So my question is do I just need to use seperate libs or is there a way to get my own project types to show up in the type combo-box for the settings designer?


    Thanks,
    Wednesday, September 19, 2007 9:45 PM

Answers

  •  

    Hi Patella,

    I test it, and I can type my own types’ name through browse. The only you should pay attention to is the name you typed must include the namespace.

    Hope this helps.
    Best Regards.
    Rong-Chun Zhang

    Friday, September 21, 2007 10:39 AM

All replies

  •  

    Hi Patella,

    I test it, and I can type my own types’ name through browse. The only you should pay attention to is the name you typed must include the namespace.

    Hope this helps.
    Best Regards.
    Rong-Chun Zhang

    Friday, September 21, 2007 10:39 AM
  • Thanks that did work. The big issue I saw though was it added my project as a reference when I did that and then I had to manually delete it to get rid of the duplicate warnings.

     

    Wednesday, October 10, 2007 2:13 PM