none
unexplained delays during MSI install VS2008 / .NET 3.5

    Question

  • I have a solution with a .NET 3.5/VS2008 WinForm app and a setup app. My setup app has been executing normally for a few weeks now, but this morning the install took a very long time complete, but there were no errors. I had it write a log, and here are the lines that show a time delay at two points. Unfortunately, the log doesn't really tell me anything. Perhaps someone else knows what's going on here?

    Action 10:52:52: ProgressForm. Dialog created
    Action ended 10:52:52: ProgressForm. Return value 1.
    Action 10:52:52: ExecuteAction. 
    Action start 10:52:52: ExecuteAction.

    ---- mysterious delay here 14 minutes -----

    Action 11:06:56: INSTALL. 
    Action start 11:06:56: INSTALL.
    Action 11:06:56: DIRCA_CheckFX. 
    Action start 11:06:56: DIRCA_CheckFX.

    .....

    Action 11:06:56: SetODBCFolders. Initializing ODBC directories
    Action start 11:06:56: SetODBCFolders.
    Action ended 11:06:56: SetODBCFolders. Return value 1.
    Action 11:06:56: InstallValidate. Validating install
    Action start 11:06:56: InstallValidate.
    Action ended 11:07:11: InstallValidate. Return value 1.
    Action 11:07:11: InstallInitialize. 
    Action start 11:07:11: InstallInitialize.

    --- mysterious delay here 10 minutes -----

    Action ended 11:17:12: InstallInitialize. Return value 1.
    Action 11:17:12: AllocateRegistrySpace. Allocating registry space
    Action start 11:17:12: AllocateRegistrySpace.



    • Edited by Adam ONeil Friday, May 11, 2012 3:54 PM
    Friday, May 11, 2012 3:53 PM

All replies

  • Hi Adam,
    Can you reproduce this issue on your machine again?
    Could you please try to install it on other environments and then tell us the result?
    How large is the setup project?
    Best Regards,

    Bob Wu [MSFT]
    MSDN Community Support | Feedback to us

    Monday, May 14, 2012 12:51 PM
    Moderator
  • That log doesn't look like a verbose one - I don't know how you set it but if it was logging policy in the registry it needs to be:

    REGEDIT4

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"="voicewarmupx"


    Phil Wilson

    Monday, May 14, 2012 5:56 PM
    Moderator