sticky
Great you've had a .NET Framework Setup Issue and now want some help getting to the bottom of it

ตอบทั้งหมด

  • dbg_x86.msi

    3 กุมภาพันธ์ 2551 20:41
  •  

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
       at HP.CUE.Video.PlaybackControl.UpdateProgressBar()
       at HP.CUE.Video.PlaybackControl._ProgressTimer_Tick(Object sender, EventArgs e)
       at System.Windows.Forms.Timer.OnTick(EventArgs e)
       at System.Windows.Forms.Timer.Callback(IntPtr hWnd, Int32 msg, IntPtr idEvent, IntPtr dwTime)


    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.2407
        CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll
    ----------------------------------------
    hpqimzone
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///C:/Program%20Files/HP/Digital%20Imaging/bin/hpqimzone.exe
    ----------------------------------------
    hpqiface
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqiface/4.0.0.0__a53cf5803f4c3827/hpqiface.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.2032
        CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.2032
        CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll
    ----------------------------------------
    System
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.2407
        CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll
    ----------------------------------------
    hpqcc2
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqcc2/3.0.0.0__a53cf5803f4c3827/hpqcc2.dll
    ----------------------------------------
    hpqutils
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqutils/4.0.0.0__a53cf5803f4c3827/hpqutils.dll
    ----------------------------------------
    hpqfmrsc
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqfmrsc/4.0.0.0__a53cf5803f4c3827/hpqfmrsc.dll
    ----------------------------------------
    hpqtray
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqtray/4.0.0.0__a53cf5803f4c3827/hpqtray.dll
    ----------------------------------------
    hpqovskn
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqovskn/3.0.0.0__a53cf5803f4c3827/hpqovskn.dll
    ----------------------------------------
    hpqthumb
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqthumb/3.0.0.0__a53cf5803f4c3827/hpqthumb.dll
    ----------------------------------------
    hpqimvlt
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqimvlt/3.0.0.0__a53cf5803f4c3827/hpqimvlt.dll
    ----------------------------------------
    hpqimgrc
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqimgrc/4.0.0.0__a53cf5803f4c3827/hpqimgrc.dll
    ----------------------------------------
    hpqntrop
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqntrop/4.0.0.0__a53cf5803f4c3827/hpqntrop.dll
    ----------------------------------------
    Interop.hpqcxm08
        Assembly Version: 3.0.0.0
        Win32 Version: 70.0.170.000
        CodeBase: file:///c:/windows/assembly/gac/interop.hpqcxm08/3.0.0.0__a53cf5803f4c3827/interop.hpqcxm08.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.2032
        CodeBase: file:///c:/windows/assembly/gac/system.xml/1.0.5000.0__b77a5c561934e089/system.xml.dll
    ----------------------------------------
    HPQDocViewer
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///C:/Program%20Files/HP/Digital%20Imaging/bin/HPQDocViewer.EXE
    ----------------------------------------
    LEAD
        Assembly Version: 13.0.0.113
        Win32 Version: 13.0.0.113
        CodeBase: file:///c:/windows/assembly/gac/lead/13.0.0.113__9cf889f53ea9b907/lead.dll
    ----------------------------------------
    LEAD.Wrapper
        Assembly Version: 13.0.0.113
        Win32 Version: 13.0.0.113
        CodeBase: file:///c:/windows/assembly/gac/lead.wrapper/13.0.0.113__9cf889f53ea9b907/lead.wrapper.dll
    ----------------------------------------
    LEAD.Windows.Forms
        Assembly Version: 13.0.0.113
        Win32 Version: 13.0.0.113
        CodeBase: file:///c:/windows/assembly/gac/lead.windows.forms/13.0.0.113__9cf889f53ea9b907/lead.windows.forms.dll
    ----------------------------------------
    LEAD.Drawing
        Assembly Version: 13.0.0.113
        Win32 Version: 13.0.0.113
        CodeBase: file:///c:/windows/assembly/gac/lead.drawing/13.0.0.113__9cf889f53ea9b907/lead.drawing.dll
    ----------------------------------------
    interop.hpqimgr
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.0.0
        CodeBase: file:///c:/windows/assembly/gac/interop.hpqimgr/4.0.0.0__a53cf5803f4c3827/interop.hpqimgr.dll
    ----------------------------------------
    hpqasset
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqasset/4.0.0.0__a53cf5803f4c3827/hpqasset.dll
    ----------------------------------------
    hpqmirsc
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///C:/Program%20Files/HP/Digital%20Imaging/bin/hpqmirsc.DLL
    ----------------------------------------
    hpqedit
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqedit/3.0.0.0__a53cf5803f4c3827/hpqedit.dll
    ----------------------------------------
    hpqvideo
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqvideo/3.0.0.0__a53cf5803f4c3827/hpqvideo.dll
    ----------------------------------------
    LEAD.Windows.Forms.DrawingContainer
        Assembly Version: 13.0.0.113
        Win32 Version: 13.0.0.113
        CodeBase: file:///c:/windows/assembly/gac/lead.windows.forms.drawingcontainer/13.0.0.113__9cf889f53ea9b907/lead.windows.forms.drawingcontainer.dll
    ----------------------------------------
    hpqmdmr
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqmdmr/4.0.0.0__a53cf5803f4c3827/hpqmdmr.dll
    ----------------------------------------
    LEAD.Drawing.Imaging.ImageProcessing
        Assembly Version: 13.0.0.113
        Win32 Version: 13.0.0.113
        CodeBase: file:///c:/windows/assembly/gac/lead.drawing.imaging.imageprocessing/13.0.0.113__9cf889f53ea9b907/lead.drawing.imaging.imageprocessing.dll
    ----------------------------------------
    hpqimlib
        Assembly Version: 3.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqimlib/3.0.0.0__a53cf5803f4c3827/hpqimlib.dll
    ----------------------------------------
    hpqglutl
        Assembly Version: 4.0.0.0
        Win32 Version: 065.000.117.000
        CodeBase: file:///c:/windows/assembly/gac/hpqglutl/4.0.0.0__a53cf5803f4c3827/hpqglutl.dll
    ----------------------------------------
    interop.hpqvideo
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.0.0
        CodeBase: file:///c:/windows/assembly/gac/interop.hpqvideo/4.0.0.0__a53cf5803f4c3827/interop.hpqvideo.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just in time (JIT) debugging, the config file for this
    application or machine (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the machine
    rather than being handled by this dialog.

    7 มีนาคม 2551 20:09
  •  

    help me i have windos xp at my house and im onley gonna be on for the next hour or so so plez hurry but ill get on tomorow cuz i dont have internet at hoem i cant get a bettewr net framewrk so i can use the new halo mads stuff so if neone could help me id be very thankfull
    1 เมษายน 2551 15:46
  • massage field is manual

     

    23 เมษายน 2551 18:02
  •  Aaronru - MSFT wrote:

    This should be the first stop in determining what is happening to your machine. When posting please follow the steps at the following blog post:

    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx

    23 เมษายน 2551 18:04
  • We have been running ASP 1.1 and SQL 2000 on our internal server for quite some time now, and we are trying to migrate to ASP 2.0 and 3.0 and SQL 2005.

     

    We have the frameworks installed and SQL 2005 is installed, however I am getting some errors and I cannot deploy any data driven applications.

     

    On my server, I have Visual Web Developer 2005, and with it whenever I try to create a .mdf data file I get the error:

     

    "Connections to SQL Server Files require SQL Server to function properly. Please verify installation or download from..."

     

    I have Visual Studio 2008 on my Laptop, which lets me create the .mdf file, and I can see my SQL 2005 databases on the server from my laptop, and I can run datasets and everything I want on my localhost, but when I deploy it to my intranet, I get errors saying that the app cannot connect to SQL 2005.

     

    Are there some simple configurations I can change to fix these errors?

     

    The blogs I have seen all recommend reinstalling everything, but even then I need to make sure that we reinstall correctly and configure everything properly.

     

    Does any one have ideas on what steps we should take?

    1 พฤษภาคม 2551 16:13
  • MASSAGE FIELD IS MANUAL

    1 พฤษภาคม 2551 17:23
  •  Aaronru - MSFT wrote:

    This should be the first stop in determining what is happening to your machine. When posting please follow the steps at the following blog post:

    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx

    1 พฤษภาคม 2551 17:24
  • firstly my sig isnt serious (ive got my comp partitioned so that linux can reside on F:, because i support open source, btw,  good work MS for starting the Open API project), i cant change it at the profile center though, which is strange,
    secondly, i previewed this post, then clicked edit and everything was erased so I'm rewriting this
    Thirdly, and most important. my Problem
    My problem is that .NET does not give me a choice of where to install it, so it keeps installing on D:, my boot partition, i cant have that because my Boot partition is very small (in order to encourage myself not to put stuff on it, i made it as small i thought would be appropriate). After installing .NET i had to go so far as to delete wallpapers and help files just to uninstall it so that  my computer could run w/o the boot partition being bogged down and slow
    help is  appreciated
    Thank you
    sergei
     
    29 พฤษภาคม 2551 10:23
  • just like the theorytical about .NET Framework from micosoft
    31 พฤษภาคม 2551 8:14
  • sergei.... .net framework has to be installed on the boot drive as most of the files are installed under the windows and the system root directory . So try to just push up ur boot partition by 1 gb or so... it will really help!!!
    10 สิงหาคม 2551 17:07
  • Hi,


    I understood your problem. As i guess u have installed the VS2005 and SQL 2005 Std. Edition.

    This error you are getting because If you want to create some MDF file. You must intall the SQL express edition 2005 which is free with VS2005..

    Once you done you can create the MDF file in your project the you can connect and can work  parellely on both of the SQL server edition to open the exiting MDF and Attach the old database of you old projects.

    So you no need to reinstall the full VIsual Studio only start the installation for SQL Server Express edition...


    Hope it can solve you problem


    Thanks and Regards,



    aryan
    29 พฤศจิกายน 2551 6:22
  • test
    25 กุมภาพันธ์ 2552 9:34
  • I just recently did a reinstall of Windows XP 32bit... everything went through with out a hitch. I did all the microsoft updates and when trying to install AION. It came up with an error saying i didn't have .NET 2.0, so I went and attempted to install it directly from microsofts download section. During the installation it came up with an error saying that a certain file was corrupt or missing in "my" system and it was unable to finish installing. I was able to get .NET 1.1 or 1.0 cant remember at the moment installed and tried to then install 2.0 again and still same problem....actually I get that problem with anything over 1.1 do you guys have any suggestions?

    Thank you,

    - J
    18 มิถุนายน 2552 18:36
  • Hi J,


    I need some more details:

    Can you please paste the error message which you got dueing installation?

     

     

     

    Thanks and Regards,


    Raman Katwal
    28 กรกฎาคม 2552 15:53
  • Thank you for the information!
    3 พฤศจิกายน 2552 2:11
  • I am trying to install "Microsoft .NET Framework 3.5 Service Pack 1" by following information at this web page ...

    http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&displaylang=en

    I am working on a box with this OS: MS Windows Server 2003, Enterprise Edition, Service Pack 2

    The blog post at the top of this forum thread suggests answering this question: "What .NET Framework Patches do you currently have installed?" ... and I'd love to be able to know how to answer that question ... I think that might be part of my problem!


    I did download "dotnetfx35setup.exe" ... and then executed it ... and that failed ... so I tried again, and it said it worked.

    Then the instructions said "IMPORTANT: After installing the .NET Framework 3.5 SP1 package (either the bootstrapper or the full package) you should immediately install the update KB959209 to address a set of known application compatibility issues.
    " ... and that's where I'm a bit stuck.

    This KB article: http://support.microsoft.com/default.aspx/kb/959209 ... has a link labeled "For Windows XP and for Windows Server 2003Download the Microsoft .NET Framework 3.5 Family Update for Windows XP x86 and Windows Server 2003 x86 package now." ... whichi says ...

    Please download and install all 3 updates available in the section titled Files in This Download. These updates should be installed in the following sequence:

    1. Install the update for the .NET Framework 2.0 Service Pack 2 - Windows6.0-KB958481-x86.msu
    2. Install the update for the .NET Framework 3.0 Service Pack 2 - Windows6.0-KB958483-x86.msu
    3. Install the update for the .NET Framework 3.5 Service Pack 1 - NDP35SP1-KB958484-x86.exe

    ... which I find a bit confusing ... because I don't know if I'm supposed to do all 3 of these because it seems like I've already installed the 3.5 SP1???  But I assumed I need to do all 3 of these ... and so I did the first one (which took a couple of tries :-() ... but then I tried the 2nd one and it keeps failing saying "Another installation is already in progress.  Complete that installation before proceeding with this install".  And that's after rebooting 2 times.  If I've just finished a reboot, how can an install be in progress?

    And since "install" thinks an install is in progress and therefore won't do the install I want it to, now what?

    The one thing I can think of is to check to see if the "Install the update for the .NET Framework 3.0 Service Pack 2 - Windows6.0-KB958483-x86.msu" has already been done ... how do I do that?

    Thanks for help!

    12 พฤศจิกายน 2552 0:17
  • I found an alternate path to getting .NET 3.5 SP1 installed ... it was via "Windows Update" ... http://www.update.microsoft.com/windowsupdate/v6/default.aspx?ln=en-us ... when I went to this web site, and clicked on the "Express" button, it told me I needed to do the "high-priority update" = .NET Framework 3.5 SP1 ... which is what I want to do!  Well, it didn't work right away, but just for the heck of it this morning I rebooted again and then tried this again and it worked!  Then that same web site told me I had another 21 "high priority updates" to do ... and so I did them (well, 20 of them, I skip'd updating to IE8) ... and that all appeared to go well.

    So, now I'm left wondering if I still need to do the 3 updates mentioned in this KB article: http://support.microsoft.com/default.aspx/kb/959209

    And so I think what I want to know is ... how can I tell what version of .NET Framework I have installed?  ... and what patches have been installed on top of it?

    Thanks for any help!
    12 พฤศจิกายน 2552 20:25
  • I'm running Windows 7 Ultimate 32Bit. I double click dotnetfx35setup.exe. The UAC pops up asking if I want to continue. I hit yes. Nothing happens.
    23 มกราคม 2553 17:20
  • Hi BobaFett2040,

    For you information the framework you want to install is inbuilt in Windows & ultimate. You just need to enable or diable as per requirement from the Windows features on off under Control Panel.

    Start -> Control Panel -> Programs and Features -> Turns Windows features on or oFf (on the left side if it the view is in classic view)


    Hope it works for you

    Raman Katwal
    24 มกราคม 2553 3:57
  • Hi,

    I have a problem with .NET Framework... I am trying to use rapidshare manager for downloads.. ( getting an error message from rapidshare ) ...to run this program they said you need .NET Framework2.0 .. which I had .. I have now upgraded ..first to 3.0 sp2 and then 3.5 ..I have them all listed in my program files.. I removed version 1.0 ... but am not sure what to do ? .. I though the download updated the files ..not adding more.. is there a conflict when there is more than 1 .NET Framework on a machine ? .. if so which one should I remove.  The latest update was from the MS update screen.  I run XP professional sp3.

    (btw I run the same rapidshare manager on a different machine with Vista ..and it runs perfectly)

    Would be grateful for some help *thnx

    Pam


    24 มกราคม 2553 13:39
  • I am having a problem trying to execute a web application to .NET 3.5 platform.

    I get the following binding error that was displayed on the fuslogvw.exe program

    *** Assembly Binder Log Entry  (1/26/2010 @ 1:50:08 PM) ***

    The operation failed.
    Bind result: hr = 0x80070005. Access is denied.

    Assembly manager loaded from:  c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorwks.dll
    Running under executable  C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_wp.exe
    --- A detailed error log follows.

    === Pre-bind state information ===
    LOG: User = Unknown
    LOG: DisplayName = JITCWebApps
     (Partial)
    LOG: Appbase = file:///C:/Inetpub/wwwroot/JITCWebApps2008/
    LOG: Initial PrivatePath = C:\Inetpub\wwwroot\JITCWebApps2008\bin
    LOG: Dynamic Base = c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\jitcwebapps\4b80b5fd
    LOG: Cache Base = c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\jitcwebapps\4b80b5fd
    LOG: AppName = ea7a2516
    Calling assembly : (Unknown).
    ===
    LOG: This bind starts in default load context.
    LOG: Using application configuration file: C:\Inetpub\wwwroot\JITCWebApps2008\web.config
    LOG: Using host configuration file: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet.config
    LOG: Using machine configuration file from c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
    LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
    LOG: Attempting download of new URL file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/jitcwebapps/4b80b5fd/ea7a2516/JITCWebApps.DLL.
    LOG: Attempting download of new URL file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/jitcwebapps/4b80b5fd/ea7a2516/JITCWebApps/JITCWebApps.DLL.
    LOG: Attempting download of new URL file:///C:/Inetpub/wwwroot/JITCWebApps2008/bin/JITCWebApps.DLL.
    LOG: Assembly download was successful. Attempting setup of file: C:\Inetpub\wwwroot\JITCWebApps2008\bin\JITCWebApps.dll
    LOG: Entering download cache setup phase.
    LOG: Assembly Name is: JITCWebApps, Version=2.0.3678.21285, Culture=neutral, PublicKeyToken=null
    LOG: A partially-specified assembly bind succeeded from the application directory. Need to re-apply policy.
    LOG: Using application configuration file: C:\Inetpub\wwwroot\JITCWebApps2008\web.config
    LOG: Using host configuration file: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet.config
    LOG: Using machine configuration file from c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
    LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
    ERR: Setup failed with hr = 0x80070005.
    ERR: Failed to complete setup of assembly (hr = 0x80070005). Probing terminated.


    If this is the wrong forum to help me resolve this issue then direct me to the correct forum


    I do not unserstand what Microsoft is trying to tell me here. The jitcWebApps.dll is in the correct directory that was listed. I am trying to migrate a working Web application executing upon .NET 2.0 software base to .Net 3.5 base.

    thank you for for help

    Bob carpenter
    26 มกราคม 2553 21:22
  • I have been having trouble with installing net framework version 3 for some time now.
    I am using XP home edition.
    I have tried all of the fixes I can find using google and on here. ( some I don't understand).
    I have downloaded the install files for all the previous versions I have on my computer, uninstalled and reinstalled them, used the clean up tools inbetween but still no joy.
    I have used varios versions of the files from microsft web and other suggested sources.

    The error code I am getting is as follows.

    Error Signature
    EventType : wap10setup     P1 : 13165     P2 : 3.0.04506.30_waprtm_x86_sfx    
    P3 : pr     P4 : inst     P5 : f     P6 : wic installer     P7 : baseret_failure
    P8 : -     P9 : 1603     P10 : -

    Any help would be very welcome.
    I could post my logs but I'm not sure which to post. They are very long.

    Thanks

    Tom
    8 กุมภาพันธ์ 2553 13:31
  • I found the following on another thread and it has solved my problem.


    I think I came up with a solution: I also had trouble installing Internet Explorer 7 and 8 and the same thing with Windows Media Player 10 and 11 (and of course .Net 3.0 and Service Pack 3).
    When searching for a solution vor the WMP error, i found this:
    http://www.microsoft.com/windows/windowsmedia/player/webhelp/default.aspx?&mpver=11.0.5721.5145&id=8007f00d&contextid=10050&originalid=8007f00d

    Renaming the spupdsvc.exe actually worked for WMP but surprisingly for all other errors, too. I have them all installed by now and I'm glad it was an quiet simple solution (although not easy to find). Maybe one of the above steps is necessary for you... i already did that, so I can't tell if it was spupdsvc.exe alone, or not. If you experience trouble with the update process after you renamed it, just rename it back...

    I hope this a help to you, when google came up with this page for you :)
    • Proposed As Answer by geldinho Monday, June 01, 2009 5:38 PM
    8 กุมภาพันธ์ 2553 15:39
  • hi. just want to say hi and hello.
    26 กุมภาพันธ์ 2553 18:21
  • Does anyone know about the error message "No assemblies specified" when using the .NET Framework Setup tool? I have specified all required assemblies. I have been trying to deliver one setup package along with FTP , SFTP , SSH Telnet , IMAP , POP3 , SMTP , Bounce Inspector , Email Validator , Mail Merge , Netkit , Template Engine and Zip components.

    14 มีนาคม 2553 22:13
  • For whatever reason I can't post a new message, so I'll ask the question here with the hope that someone reads it.

    I have installed the .net4 framework using VWD2008.  How do I make the VWD use the .net4 instead of .net3.5?  Seems the more I try to learn about web programming the more confused I get.

    Very frustrating....

    14 เมษายน 2553 15:44
  • i'm trying to run framework 4 on windows 7.  after installation is complete, and the computer re-boots, i cannot find the program anywhere.  where is it, how do i run it?

     

    thanks,

    jon

    29 เมษายน 2553 3:09
  • Since you are the moderator can you direct me to a quick reference as to what exactly NET Frame does? Thanks!
    21 พฤษภาคม 2553 0:57
  • Hi
    I think I came up with a solution: I also had trouble installing Internet Explorer 7 and 8 and the same thing with Windows Media Player 10 and 11

     

    Thomas Riccard,
    Dermatologist


    5 มิถุนายน 2553 5:01
  • I currently have Microsoft.NET Framework 1.1 and 3.5 SP1 installed on my computer.  I did have 4.0 but I uninstalled it as I was afraid it might conflict with the ones I already had installed.

    I would like to know which Microsoft.NET Framework is the best one to install on my computer and does each newer version update the older version, meaning should I uninstall Microsoft.NET Framework 1.1 and 3.5 SP1, and I've also heard that version 2.0 is the best Microsoft.NET Framework version to have on your computer.

    So I'd like to know if only one Microsoft.NET Framework version should be installed on my computer and if I uninstall versions 1.1 and 3.5 SP1, will doing that make some of my programs unstable or unable to be used.

    I really, really need an answer on this as I'm trying to install an application that is very important to me, and I can't get it downloaded and installed for some reason.  I think the problem has to do with the Microsoft.NET Framework as the tech said to be sure and have version 2.0 installed in order for the application to work.

    I found 2.0 but thought 3.5  SP1 would be better as it's improved and newer, but now I don't know whether to keep 1.1 and 3.5 SP1 plus install version 2.0, and I need to know if previous version need to be uninstalled before installing a newer and/or different version.

    Plus maybe you should only have one version installed as two versions might be conflicting when I'm trying to download my application.

    Thank you and I hope I can finally resolve my issue on this as even tech support didn't have an answer and sent my support ticket on to a programmer to figure out what I should do.


    Corinne Larimore
    15 มิถุนายน 2553 20:10
  • I have windows 2008 small business server 64bit and I need to install SQL on to it.

    But SQL requires to have installed .NET 3.5 SP1. On server is already installed .NET 3.0 which comes with server.

    I have tryed to update it to .NET 3.5 with windows update, but I get alway an error.

     

    I have downloaded full version .NET 3.5 SP1 and error is the same. I have downloaded compatibility pack and installed it, but still error is the same. I have also uninstalled version .NET 3.0 and all what is linked on .NET and trying then to install .NET 3.5, bust still no luck.

     

    Now I don't know what to do I can't use SQL because I can't install .NET 3.5 SP1.

    What should I do?

     

    error(s) found

    Code 80070005

    .NET Framework 3.5 Service pack 1 KB951847

    20 กรกฎาคม 2553 11:26
  • Hi,

    Please check your file permission and your user account permission. it will not have full admin right.

    30 กรกฎาคม 2553 9:24
  • Have no idea if this is the place for this.  I am trying to repair .Net 3.5 and the repair fails.  I get the same failure if I remove 3.5 and attempt a reinstall (saved by system restore).  I have followed your things to do - all appears consistent.  My need to repair resulted from this bright idea I had to purchase VS2010.  It fails to install of course.  Found Aaron's blog which seemed to suggest that mscoree.dll was at fault.  I did see that fellow in the TFS installer log - an entry point was missing.  I am on Vista 32 business SP2 w/o UAC - running all as administrator.  Registry for all .net versions checked out - and mscoree.dll is present and version 2.0.50727.4016.  When I attempt to repair .Net 3.5 I get the following

    Description:
      Microsoft .NET Framework 3.5 SP1 has encountered a problem during setup.  Setup did not complete correctly.

    Problem signature:
      Problem Event Name:    VisualStudio8Setup
      Problem Signature 01:    35101
      Problem Signature 02:    3.5.30729.01_ORCAS_X86_NET
      Problem Signature 03:    MC
      Problem Signature 04:    INST
      Problem Signature 05:    F
      Problem Signature 06:    System.Data.Services.Design,version="3.5.0.0"
      Problem Signature 07:    0x80004005
      Problem Signature 08:    1603
      Problem Signature 09:    CreateAssemblyCache
      Problem Signature 10:    gencomp301,{12cd
      OS Version:    6.0.6002.2.2.0.256.6
      Locale ID:    1033

    Additional information about the problem:
      LCID:    1033

    More information.  Apparently the version of mscoree.dll is not getting properly updated.  I find various references that indicate it should be 4.0xxxxxx and it is still 2.0.  I have tried installing .Net 4.0 and this file is left unchanged.  This appears to be causing all sorts of problems.  I am trying to manually update this dll.  Ugly ugly stuff.  

    Thanks

     

    20 พฤศจิกายน 2553 22:18
  • HOW TO FIX THE MSCOREE.DLL version problem:

    This problem arises because mscoree.dll is not properly updated when later .net version are installed.  Seems to affect 3.5 and 4.0.  Also prevents VS 2010 and Lord know what else from installing.

    1.  install .Net 4.0.  Then check the version of \windows\system32\mscoree.dll.  It should be 4.xxxxx - but if you are reading this it is probably 2.xxxxx.

    2.  Rename mscoree.dll.  This is a real pain.  Go here for instructions:  http://social.msdn.microsoft.com/Forums/en/setupprerelease/thread/150d05c4-4df4-47ec-b7a6-a66f3a55cd08

    3.  Replace the dll - the instructions for extracting the file from the .net installer did not work for me.  I found the correct version here

    c:\Windows\winsxs\x86_netfx-mscoree_dll_31bf3856ad364e35_6.1.6001.18242_none_7d658e19f5139de5\mscoree.dll

    The date is 11/08/2009 10:55.  Size is 292,808.  Version 4.0.31106.0.  I assume this directory is tied to the file GUID - but it might be tied to my machine.  However, you are looking for the version that matches the above information.

    My 2010 visual studio has been installing perfectly since I made this change.

    Cheers

    22 พฤศจิกายน 2553 18:30
  • Hi,

    I have a problem when debugging C#, that my movie can't be read.

    "Error    1    Video file demo.wmv is invalid. Please make sure that the video is not DRM protected and is a valid single-pass CBR encoded video file.    F:\WindowsGame2\Content\demo.wmv    Commencement (Windows)"

     

    What kind of file convertion do I need?

     

    25 ธันวาคม 2553 7:41
  • Step 1. It would be super helpful if you could provide the following information at the beginning of your post: 1.Version of .NET Framework you are trying to install.

    Version 3.5 SP1

    2.Where did you get it (web page, path, application that redistributed the framework)

    http://www.microsoft.com/downloads/en/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

    3.Is this a pre-release, CTP or beta version? Which? (Beta#, CTP (Month Year), RC, etc)

    4.What .NET Framework Patches do you currently have installed?

    Framework 1.1

    Framework 2.0 Service Pack 1.0 V2.1.21022

    I get the following error when trying to install 3.5 - Taken from the error log -

    [05/06/11,13:02:47] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    6 พฤษภาคม 2554 3:45