none
Error 0x80070002 when trying to add a new diagram from architecture menu

답변

  • Indeed...  I was in the process of re-applying SP1, as you responded, Nicole, and that seems to have resolved it. 

    (I was previously mislead, when I looked in the Visual Studio Help/About, it indicated SP1, so I initially believed it was already rolled into my Ultimate install... this was apparently not the case.)

    Thanks!

    2012년 2월 17일 금요일 오후 2:39

모든 응답

  • Hi

    Does this work:

    1. Create a modeling project:

    • Menu File> New> Project to get the new project dialog.
    • Under Installed Templates, click Modeling Projects, then in the middle click Modeling Project.
    • At the solution field, select Create New Solution
    • Make sure the Location is somewhere that you've got full access.

    2. Create a new diagram from Solution Explorer:

    • Right-click the modeling project > Add > New Item
    • From the dialog, select a diagram type; click Add.

    If that doesn't work, where does it go wrong?


    - Alan -MSFT
    2010년 7월 7일 수요일 오후 10:06
  • Also, which menu items are you selecting?  We create different diagram types from the different menu options...

     

    Thanks.


    Phil Lee | Program Manager | Visual Studio Architecture Tools
    2010년 7월 8일 목요일 오후 5:07
  • Hi. I'm having the same problem. I already have VS 2010 Pro and I wanted to try VS 2010 Ultimate to try the modeling tools. I think this is the problem, I don't have the templates? How can I install them?

    Thanks,

    Matt

    2012년 1월 25일 수요일 오후 8:16
  • Looks like I do have the modeling tools installed, but they don't appear under the installed templates and I can't find them in the online templates?

     

     

    Microsoft Visual Studio 2010

    Version 10.0.40219.1 SP1Rel

    Microsoft .NET Framework

    Version 4.0.30319 SP1Rel

     

    Installed Version: Ultimate

     

    Microsoft .NET Micro Framework v4.0   01019-315-4422961-70170

    Microsoft .NET Micro Framework SDK v4.0

    Version 4.0.1681.0

     

    Microsoft Visual C# 2010   01019-315-4422961-70170

    Microsoft Visual C# 2010

     

    Microsoft Visual Studio 2010 Architecture and Modeling Tools   01019-315-4422961-70170

    Microsoft Visual Studio 2010 Architecture and Modeling Tools

     

    UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

     

    Microsoft Visual Studio 2010 Code Analysis Spell Checker   01019-315-4422961-70170

    Microsoft Visual Studio 2010 Code Analysis Spell Checker

     

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

     

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

     

    Microsoft Visual Studio 2010 Team Explorer   01019-315-4422961-70170

    Microsoft Visual Studio 2010 Team Explorer

     

    Crystal Reports Templates for Microsoft Visual Studio 2010   

    Crystal Reports Templates for Microsoft Visual Studio 2010

     

    Microsoft Visual Studio 2010 Professional - ENU Service Pack 1 (KB983509)   KB983509

    This service pack is for Microsoft Visual Studio 2010 Professional - ENU.

    If you later install a more recent service pack, this service pack will be uninstalled automatically.

    For more information, visit http://support.microsoft.com/kb/983509.

     


    • 편집됨 WalkToFreedom 2012년 1월 25일 수요일 오후 8:36
    2012년 1월 25일 수요일 오후 8:35
  • Did you already create a modeling project first?
    Esther Fan | Visual Studio, Content Lead | If a post answers your question, please click "Mark As Answer" on that post and mark as Helpful. Thanks!
    2012년 1월 25일 수요일 오후 8:56
  • Hi Esther. It doesn't give me the option to create a modelling project? There is no modelling project in the installed templates?
    2012년 1월 25일 수요일 오후 11:20
  • I appear to have the same problem.  I just upgraded my Visual Studio install from Premium SP1 to Ultimate SP1, and I am experiencing similar issues...  no diagram project template in the list of installed templates, and when I pull down Architecture to "New Diagram..."   I get 0x80070002.    I can see the UML Explorer and Layer Explorer, but they're empty.

    Ironically, I upgraded to Ultimate almost specifically for this functionality.  

    Thanks in advance for any hints/pointers!  :)

    2012년 2월 17일 금요일 오후 12:22
  • Have you tried re-applying SP1 after your upgrade to Ultimate?
    2012년 2월 17일 금요일 오후 1:57
  • Indeed...  I was in the process of re-applying SP1, as you responded, Nicole, and that seems to have resolved it. 

    (I was previously mislead, when I looked in the Visual Studio Help/About, it indicated SP1, so I initially believed it was already rolled into my Ultimate install... this was apparently not the case.)

    Thanks!

    2012년 2월 17일 금요일 오후 2:39