none
w3wp.exe remote process is disabled so I can't attach to it with remote debugger

    질문

  • I'm trying to attach to the w3wp process on my remote server, but it is always greyed out.  I used to be able to attach to it.  I don't know what happened.  I work in a very large networked environment and it's possible someone somewhere added some layer of security behind the scenes.  But no one here can help or tell me if anything's changed on the server and I've searched everywhere to try and find an answer and nothing works. 

    On the remote server (Windows 2003 server), there is the w3wp process.  Then when I bring up my app on the web running on that server, it starts another w3wp process.  The new w3wp process has the "Managed, T-SQL" identifier next to it, but it is always greyed out.  I've attached to the original w3wp process that is not greyed out, but it always tells me there's no symbols attached.  I've tried saying not to use authentication but the process is still greyed out.  I've disabled all of my firewalls.  I've added devenv to the firewall list of exceptions.  I've attached to the process in native mode, but that does no good, because I need the symbols and anyway one of the w3wp process is still disabled and when I attach to the other one, I get the same error as when I'm not in native mode.  I've spent days and days searching and trying everything anyone can suggest.  Nothing works so that I can debug my code remotely.

    My development environment is Windows 7.  I've tried starting it in compatability mode to Windows XP SP 3, but the process is still greyed out.  And anyway, I know that I used to have no problem with the Windows 7 to Server 2003 issue. 

    I'm at a loss of even where to look.  Why is this process disabled, but every other process on the remote server is enabled?  This is the only one disabled so that I cannot attach to it.  I've started and restarted IIS.  Is there possibly some setting in there preventing attaching to this process?  The remote monitor shows that I'm connected.  Why is one of the w3wp's not disabled and lets me attach, but not the one I need?

    I've looked at many, many others who wrote in about this, but either none of their situations was comparable to mine, or their question wasn't answered, or I tried a suggested solution and it didn't change anything.  Any help would be most appreciated.

    2012년 3월 2일 금요일 오후 3:02

답변

모든 응답

  • It seems that the server changes made your work cannot go on.

    http://stackoverflow.com/questions/1288739/cannot-remote-debug-iis-w3wp-exe-is-grayed-out 

    From this discussion, I saw it would be caused by some debug tools on the server side made you cannot work. And in this discussion it is the Debug Diagnostic Tool. But I think maybe the others tool also can give you this effects to the process.

    Please try to research it according to this way, then let me know the results.

    If there's any concern, please feel free to let me know.

    Best wishes,


    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us

    • 답변으로 표시됨 tahitiandreams 2012년 3월 5일 월요일 오후 12:43
    2012년 3월 5일 월요일 오전 5:48
    중재자
  • Thank you so very much.  This was indeed my problem.  I had recently been running Debug Diagnostics to try and resolve some IIS issues I was having.  I had no idea that when this was running one couldn't remote debug.  Somehow, in all of my searches I missed this answer.

    Thank you for you prompt response and resolving my issue for me.

    2012년 3월 5일 월요일 오후 12:51
  • You're welcome!

    Have a good day!


    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us

    2012년 3월 7일 수요일 오전 11:53
    중재자