none
Problem using Star TSP100 printer - missing path maybe?

    質問

  • Hi

    I have an applaication (C#, POS for .NET) which is working fine with an Epson TM88IV and cash drawer.

    I now decided to test the application with a Star TSP100 USB printer.  I downloaded the Configuration Utility and OPUS driver from Star and have installed them giving both the printer and cash drawer a logical name.  Using the Star check health utilty the printer prints and the Cash Drawer opens. Happy days!!!!

    However, using the TestApp in the Microsoft Point of Service SDK. I navigate to the logical name of my start printer and click "open" and get the following error:

    POSControlException ErrorCode(Failure) ExtendedErrorCode(0) occurred: Method Open threw an exception.  The device cannot perform the requested procedure.
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException (0x8000FFFF): Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))
       --- End of inner exception stack trace ---
       at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
       at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
       at System.Type.InvokeMember(String name, BindingFlags invokeAttr, Binder binder, Object target, Object[] args, CultureInfo culture)
       at Microsoft.PointOfService.Legacy.LegacyProxy.InvokeMethod(String methodName, Object[]& parameters, Boolean[] byRef)
    System.Runtime.InteropServices.COMException (0x8000FFFF): Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))
    Created instance of device: Star TSP100 PosPrinter

    Using Service Object Manager by SJJmicro.com i see that the path of the service object is blank where as all my epson service objects point to a dll.
    It also has a Legacy value of TRUE where most of the others are false.

    Any ideas as to what is wrong?

    Thanks

     

    2010年11月16日 12:47

回答

すべての返信

  •  

    Downloaded the common control objects from http://monroecs.com/oposccos_current.htm and referenced them in my program and now all seems fine!  Only slight problem i have now is that on the receipts it is displaying a funny looking B character instead of a £.

    James

    • 回答としてマーク J de C 2010年11月16日 18:39
    2010年11月16日 18:38
  •  

    Downloaded the common control objects from http://monroecs.com/oposccos_current.htm and referenced them in my program and now all seems fine!  Only slight problem i have now is that on the receipts it is displaying a funny looking B character instead of a £.

    James

    Did you mange to solve the problem with funny B character instead of a £? I've noticed the same problem.

    Using CCO it printed fine once. But since then I keep getting following error when trying to set DeviceEnabled = true

    Type : Microsoft.PointOfService.PosControlException, Microsoft.PointOfService, Version=1.12.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    Message : Failed to set property DeviceEnabled.
    Source : Microsoft.PointOfService
    Help link :
    ErrorCode : Illegal
    ErrorCodeExtended : 0
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Void SetProperty(System.String, System.Object)
    Stack Trace :    at Microsoft.PointOfService.Legacy.LegacyProxy.SetProperty(String propertyName, Object propertyValue)
       at Microsoft.PointOfService.Legacy.LegacyProxy.set_DeviceEnabled(Boolean value)
       at Microsoft.PointOfService.Legacy.LegacyPosPrinter.set_DeviceEnabled(Boolean value)

    However, I managed to find the cause of this error. When I close my Pos application for some reason, the device is still remains blocked by StarSharedPort2009 application which starts when you first print. If I restart my Pos application I would not be able to set DeviceEnabled to true. Killing StarSharedPort2009 application lets me resolve this error. However, same thing continues.


    bhav27



    • 編集済み bhav27 2012年2月17日 22:41
    2012年2月17日 21:33