none
Multiple test project on Visual studio

    Question

  • Hi, I have created projects in solution like this

    MySolution
     Solution Items (This created when I added test project in solution) (includes Local.testsettings, Mysolution.vsmdi, TraceAndTestImpact.testsettings)
     +Project1
     +Project1.Test
     +Project2

    When I add new test project in solution, Project2.Tests for Project2, I can not run the this Project2.Test project. When I click run tests button, Project1 test projects are running.

    Is this is a bug?

    jeudi 1 mars 2012 11:37

Réponses

  • Hi youtubeline,

    Thank you for posting in the MSDN forum.

    Can you give us a screen shot about the “run tests button” where you click?

    I try to repro this project, open Test-> windows->Test View, select the Project2.Tests, and then click Run Selection, it works normally. Can you check it with my steps?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    vendredi 2 mars 2012 10:05
    Modérateur

Toutes les réponses

  • Hi youtubeline,

    Thank you for posting in the MSDN forum.

    Can you give us a screen shot about the “run tests button” where you click?

    I try to repro this project, open Test-> windows->Test View, select the Project2.Tests, and then click Run Selection, it works normally. Can you check it with my steps?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    vendredi 2 mars 2012 10:05
    Modérateur
  • Hi youtubeline,

    Any update? Could you get useful information from my reply?

    Would you mind letting us know the result of the suggestion?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    mercredi 7 mars 2012 05:59
    Modérateur
  • I've seen exactly the same problem in VS2012.  I have a Unit Test project that works.  I add another Unit Test project and none of the tests in that project can be run.  The .csproj file is clearly a unit test file, according to the instructions in http://social.msdn.microsoft.com/Forums/en-US/vststest/thread/2192fac0-0de7-45c6-872a-2be49e95ce2c/  The icon of the new project didn't even include the Unit Test project icon (which is probably a minor bug).

    The problem was that the test project didn't include any valid tests.  I thought that the test was valid, but they are only valid if they follow a specific signature:

        [TestClass]
        public class SomethingTests
        {
            [TestMethod]
            public void testSomething()
            {
                ...
            }
        }
    

    I had made my test async.  That's not allowed.


    mercredi 10 avril 2013 17:03