none
Unable to run projects in Visual Studio 2008 V 2 or 3.5 after uninstalling Visual Studio 2010 Ultimate

    Pregunta

  • Hi,

    I have installed the Visual Studio 2010 Ultimate and due to some reasons I have completely uninstalled 2010 and installed Visual Studio 2008. Also I have cleared the registry and the profiles. After installing 2008 I am not able to run any web projects in V 2.0 or 3.5. It is referencing to the V 4.0 framework DLL's. There is no reference DLL's in the project nor in GAC. Please guide me as I am unable to do any of the single projects because of the below issue. Find below the error I am getting.

    Server Error in '/WebSite3' Application.

    Could not load file or assembly 'System.Web.Mobile, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'System.Web.Mobile, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Source Error:
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Web.Mobile, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' could not be loaded.
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    

    Stack Trace:
    [FileNotFoundException: Could not load file or assembly 'System.Web.Mobile, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.]
       System.RuntimeTypeHandle._GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, Boolean loadTypeFromPartialName) +0
       System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +62
       System.RuntimeType.PrivateGetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +42
       System.Type.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +77
       System.Web.Compilation.BuildManager.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +105
       System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +64
    
    [ConfigurationErrorsException: Could not load file or assembly 'System.Web.Mobile, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.]
       System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +11206733
       System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement) +78
       System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList) +194
       System.Web.HttpApplication.GetModuleCollection(IntPtr appContext) +1891
       System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +166
       System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +336
       System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +350
       System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +382
    
    [HttpException (0x80004005): Could not load file or assembly 'System.Web.Mobile, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.]
       System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11335894
       System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88
       System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4355316
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.5448; ASP.NET Version:2.0.50727.5456


    viernes, 06 de abril de 2012 15:16

Respuestas

Todas las respuestas

  • Hello,

    Visual Studio 2008 not supported .Net framework 4.0

    you have to remove .net 4.0 reference and add similar 3.5 or 2.0 reference in your project.

    after that you are able to run project.

    Regards

    Gautam

    viernes, 06 de abril de 2012 18:10
  • Hi Gautam,

    Thanks for your reply. Please make a note that I have completely uninstalled .Net Framework 4.0 but even after that it is referring the V 4.0.0.0 assembly. I have checked the references. Its not showing any reference's in the project reference. Dont know where it is referring the assembly System.Web.Mobile. Also when I checked the reference it is showing as System.Web.Mobile 2.0.0 and not the Version=4.0.0.0.


    Regards,

    -Shankar

    sábado, 07 de abril de 2012 5:11
  • Dear All,

    Could anyone please help me to resolve the above mentioned issues as I am unable to run any of the localhost website.

    Thanks in Advance.

    Regards,

    Shankar


    • Editado Shansinnn sábado, 14 de abril de 2012 15:36
    sábado, 14 de abril de 2012 15:35
  • Hi Shansinnn,

    Welcome to the MSDN forum.

    I guess you haven't removed all the files from your OS since some settings of registry is remain.  I'm afraid you should repair your registry or oder to use the software. To perform a full uninstall of Visual Studio 2010, have you tried this tool with complete command?

    http://archive.msdn.microsoft.com/vs2010uninstall

    Please show us your status of your OS now.

    Thanks and regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    martes, 17 de abril de 2012 8:33
    Moderador