none
autoexp.dat Visualizers in VS11 Developer Preview broken?

    Question

  • It seems that if I add visualizer definitions to the autoexp.dat file in the Visual Studio 11 preview, they do not work. Is this a known issue, or is there some other way to define custom visualizers for 11?

    It appears that the file is identical to the VS 2010 version, so I would expect the visualizers I wrote for 2010 to work in 2011 as well.  The autoexp.dat file I am editing is found at "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Packages\Debugger"

    Thanks!

    Friday, October 07, 2011 3:58 PM

Answers

  • Hi Steven Bone,

    We are actually replacing autoexp.dat with a new xml file called default.natvis.  You can find this file in the following path:
    \Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Packages\Debugger\Visualizers
    I highly suggest you open up this file in Visual Studio and check it out.  There are instructions at the top that describe how it is used and more content is coming later.  And please let us know what feedback you have.

    Thanks,
    Brad


    Brad Sullivan - Program Manager - Visual Studio Debugger
    • Marked as answer by Steven Bone Monday, October 10, 2011 11:06 AM
    Saturday, October 08, 2011 12:46 AM

All replies

  • Hi Steven Bone,

    We are actually replacing autoexp.dat with a new xml file called default.natvis.  You can find this file in the following path:
    \Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Packages\Debugger\Visualizers
    I highly suggest you open up this file in Visual Studio and check it out.  There are instructions at the top that describe how it is used and more content is coming later.  And please let us know what feedback you have.

    Thanks,
    Brad


    Brad Sullivan - Program Manager - Visual Studio Debugger
    • Marked as answer by Steven Bone Monday, October 10, 2011 11:06 AM
    Saturday, October 08, 2011 12:46 AM
  • Oh, and if you want to force VS to use the old system, there is a way to do this.  For now, you can accomplish this by going to Tools->Options and then under the debugger settings, turn on native edit and continue.

     

    Thanks,


    Brad Sullivan - Program Manager - Visual Studio Debugger
    Saturday, October 08, 2011 12:47 AM
  • If you start using the new style XML-based visualizers in default.natvis, this issue may be interesting for you: Incorrect Type Name references in defaultvis.natvis visualizers for standard library
    Saturday, November 19, 2011 7:46 PM
  • Hi, I've seen the connect issue and you solution,  as you're saying "Relaunch Visual Studio 11" , I am wondering if this is changed compared to autoexp.dat, when I do some modificaions, I don't need to relaunch VS, but re-attach the debugger.

    Edit:  I've tried, no need to relaunch, just re-attach


    I am a passionate game programmer.


    • Edited by Trout.Z Friday, February 24, 2012 4:31 AM
    Friday, February 24, 2012 4:15 AM
  • When I open this file, with either VS11 or Notepad, I do not find any instructions.

    Is this file is used for datatips in VS? Some types of data do not display properly.

    Saturday, June 02, 2012 5:26 PM
  • Yes, I think it is enough to re-attach or re-launch the debugger as it will reload the visualisers.
    Saturday, June 02, 2012 6:44 PM
  • Hi Brad Sullivan,

    Please allow us install custom C++ Debugger Visualizers throw extensions.

    http://visualstudio.uservoice.com/forums/121579-visual-studio/suggestions/2945081-allow-extensions-install-additional-c-debugger-v

    WBR,

    Arkadiy Shapkin

    Monday, June 25, 2012 4:58 PM
  • I saw the file \Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Packages\Debugger\Visualizers\default.natvis in VS11 Beta, but in 2012 RC it is no longer there (or anywhere else, that I can find).

    Has it been replaced? Where is documentation on how to use the new XML files to write our own visualizers, in particular one that invokes a user-written pgm to display graphics?

    Monday, June 25, 2012 7:26 PM
  • Hi Brad Sullivan, Please consider fixing the bug reported here: http://social.msdn.microsoft.com/Forums/en-US/vsdebug/thread/c118df4d-01b4-4e1f-9cc2-4a7626c9fe93 There really is a problem with the debugger bocking the .pdb file. Thanks!
    Monday, January 21, 2013 12:22 PM
  • I'll try to be as polite as possible, but can you please explain who is that retard that pushed natvis to use xml?!

    I can't even imagine what could be more dumb than xml for stuff that's full of &, <, >. I'm sorry... but I cannot even suggest what would be worse than xml in this case.

    I was sticking with 2008 for a few reasons, and one of the reasons is that I didn't have time to port autoexp.dat for my project. It's second time I'm trying to do and I end up swearing.

    Sunday, February 23, 2014 8:23 PM