none
Fail to install Microsoft Visual Studio 2010 Professional on Windows 7 Professional

    Question

  • I have tried to install Microsoft Visual Studio 2010 Professional several times without any success.
    My computer is a 32 bit DELL Precision M4400 and my operative system is Windows 7 Professional (x86).

    On the computer is Visual Studio Professional 2005 (SP1 + SP1 Update for Windows Vista) and Visual Studio Professional 2008 (SP1) already installed. I have a MSDN subscription license. I have tried to install Visual Studio 2010 from both the shipped DVD and an iso-image which I have downloaded from the MSDN web. The result is the same: “Unknown Error”.

    When I uninstall Visual Studio 2010 then Visual Studio 2005 and 2008 fail to start. I have to do a repair to get them to work.

    Om my computer I also have Windows XP mode installed as a virtual PC. In the XP mode I also have Visual Studio Professional 2005 (SP1 + SP1 Update for Windows Vista) and Visual Studio Professional 2008 (SP1) installed. When running XP mode there was no problem at all to install Visual Studio 2010 Professional. My conclusion of this is that my installation files must be alright.

    On the Web , I have not found any solution to the installation problem.

    I have used the .NET Framework Setup Verification Tool and don’t find anything strange.

    I have also used Microsoft Visual Studio and .NET Framework Log Collection Tool to create vslogs.cab file.

    I don’t know how to get Microsoft Visual Studio 2010 to be successfully installed and urgently need you help to success.

    Log-files and a PDF-document with screen dumps from the installation is available at http://www.iat.inadire.se/VS2010Problem.zip

    Thanks in advance for help.

    Monday, January 10, 2011 11:42 AM

All replies

  • Hi jc02970,

    Thank you for posting.

    First of all, can you reproduce this issue on other windows 7 machines?

    From your description and log files, I found some error information as follows.

    [12/30/10,22:21:44] Microsoft Visual Studio 2010 Professional - ENU: CMSIDirectory::EnumerateVIProducts: Error enumerating Vertical Integration clients

    I suggest you to disable UAC and try to reinstall it again. How to disable UAC?

    In addition, I found a similar thread like yours. Please check it.

    http://social.msdn.microsoft.com/Forums/en/vsexpress2008installationandsetup/thread/ee878641-4db6-44c4-9aac-85b4ca35de41

    Furthermore, I suggest you can type ‘Devenv.exe /SafeMode’ and try it again.

    You can also type ‘Devenv.exe /Log’ to collect log file which can help us analysis your issue better and share it with me.

    Best Regards,

    Larcolais

     


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 12, 2011 2:54 AM
  • Hi Larcolais,

    Thanks for your reply.

    I don't have another windows 7 machine so therefore I can't reproduce this issuse on another computer.

    I have dissabled the UAC and I also have dissabled my virus protection software (Symantec Norton Internet Security version 17.8.0.5).

    Then I have uninstalled Visual Studio 2010 Professional and Visual Studio 2008 Professtional.

    After that I have to repair my Visual Studio 2005 Professional to get it able to run again.

    Then I installed Visual Studio 2008 + SP1 without any problem.

    Finally I tried to once again install Visual Studio 2010 Professional but it failed with the same result "Unknown Error".

    When I type ‘Devenv.exe /SafeMode’ I only get a message box saying 'Unknown Error'

    When I type ‘Devenv.exe /Log’ I only get a message box saying 'Unknown Error' but I can't find any log file.

    I have also used Microsoft Visual Studio and .NET Framework Log Collection Tool to create a new vslogs.cab file which can be found at    http://www.iat.inadire.se/vslogs-2.cab

    Best regards,

    Janne



    Thursday, January 13, 2011 12:38 AM
  • Hi jc02970,

    Thank you for your feedback.

    Regarding ‘Devenv.exe /Log’ command, it can generator a ActivityLog.xml on your machine. The file’s path is: %APPDATA%\Roaming\Microsoft\VisualStudio\<version>\ActivityLog.xml.

    Please see: http://msdn.microsoft.com/en-us/library/ms241272.aspx for more detailed information.

    If you have any concern, please feel free to let me know.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, January 13, 2011 6:05 AM
  • Hi Larcolais,

    The result of ‘Devenv.exe /Log' is now available at http://www.iat.inadire.se/ActivityLog-1.zip

    Best regards,

    Janne
    Friday, January 14, 2011 9:06 AM
  • Hi Janne,

    I’m checking your installation log file and if I have any finding, I’ll let you know as soon as possible.

    Thank you for your patient.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 18, 2011 3:47 AM
  • Hi Janne,

    Sorry for the late reply.

    After I checked your log file, I found the following information. It looks that this issue might be related with license.

      <entry>

        <record>7</record>

        <time>2011/01/13 00:19:51.523</time>

        <type>Information</type>

        <source>VisualStudio</source>

        <description>AppId stopped registry detouring</description>

    </entry>

    First of all, I suggest you to download Visual Studio 2010 Professional Trial and install it on your Windows 7. Does it work?

    If you have any finding, please feel free to let me know.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 19, 2011 4:30 AM
  • Hi Janne,

    Any update?

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Sunday, January 23, 2011 3:18 PM
  • Hi Larcolais,

    No success so far.

    To get as god resultat as possible I have:
    + Dissabled my anti-virus software
    + Dissabled the UAC
    + Uninstalled all previous versions of Visual Studio (2005+2008)
    + Uninstalled Visual Studio 2010 from the virtual XP-mode
    + Uninstalled Microsoft Office Professional 2010

    This is what is left after I have removed 'as much as possible'

    Then I install by using Visual Studio 2010 Professional Trial as you suggested but I got the same result as earlier (Unknown Error).
    I have tried to install from the shipped  MSDN subscription DVD, the downloaded iso image from MSDN and finally Visual Studio 2010 Professional Trial version. All of them give the result and the installation fail to success although the setup program says that installation was successful. The setup.exe seem not to be aware of that a message with 'unknown error' was showed.
    In a desperate attempt I also downloaded the en_ja_visual_studio_2010_sp1_beta_x86_x64_611999.exe it didn't solve my initial problem.

    The "Unknown Error" allways occurs in VsaEnv_Setup_x86_enu. What is VsaEnv_Setup_x86_enu? Registry setup? Environment setup?

    What is 'AppId stopped registry detouring'?

    I have used CCleaner from www.piriform.com to scan for issues (not to fix issues) in the registry. It reports some missing shared DLL but I don't know if Visual Studio 2010 is dependent of any of thoose. See http://www.iat.inadire.se/VS2010/3/CCleanRegistryReport.pdf


    I have once again used Microsoft Visual Studio and .NET Framework Log Collection Tool to create a new vslogs.cab file which can be found at http://www.iat.inadire.se/VS2010/3/vslogs-3.cab

     

     

    I'm trying to install a Microsoft product (Visual Studio 2010 Professional) which I have licens to use, on an operative system from Microsoft. Is this really so impossible ? I have put an enormous amount of time to get this to work. And sometimes I have to reinstall earlier versions of Visual Studio to get them to work after I have uninstalled Visual Studio 2010. This is very annoying and time consuming.

    What to do next?

    Best regards,

    Janne

     

    Monday, January 24, 2011 1:39 PM
  • Hi Janne,

    Thank you for your detailed feedback.

    Based on your description, did you use one license to active two VS product? I think you might consult license question to license experts.

    Since the question is a license issue, you can call 1-800-426-9400, Monday through Friday, 6:00 A.M. to 6:00 P.M. (Pacific Time) to speak directly to a Microsoft licensing specialist, and you can get more detail information from there. Worldwide customers can use the Guide to Worldwide Microsoft Licensing Sites to find contact information in their locations: http://www.microsoft.com/licensing/

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 25, 2011 11:09 AM
  • Hi Larcolais,

    I'm not sure I understand what you intend.

    Is this really a license problem ?
    Is not Visual Studio 2010 Professional Trial to be installed correctly in all situations ?
    However , the program should not be able to start , if
    the trial period has expired and no valid license information exist.
     
    During installation of Visual Studio 2010 Professional Trial , I have never been requested to enter any license information . I assume that it will function for several days and then closed off when the trial period ends unless I enter the correct license information .

    Not on a single occasion , the installation of Visual Studio 2010 Professional succeeded on Windows 7. Not even the first time I tried to install Visual Studio 2010.
    At that time there were no license rate limit that allowed the installation failed . All installation attempts gave the same message ' unknown error ' .
    Can it really affect that I managed to install XP again in fashion on the same computer ? That time I used DVD from the MSDN subscription that I have and I had allready done several attempt to install on Windows 7.

    Furthermore : If I have a valid license of a program , I must be allowed to uninstall the program and later install it again without getting any kind of license problem .

    Someone who has been creating the installation file should be able to see the specific line that is executed when the ' unknown error ' occurs ? Should not someone be able to provide a more detailed hint of what it is to be performed when the error occurs ?

    Best regards,

    Janne


    Tuesday, January 25, 2011 3:26 PM
  • Hi,

    In the log files sent in I see portions of Visual Studio 2010 installed (MsiInv.txt)file. These need to be uninstalled prior to installing VS2010 again. You can use the uninstall utility to remove the 2010 portions. (link below)

    This is one example of (more) the components I saw in log file: Installed Products: {D6B15AE6-B052-363E-B6BB-C4714CBA6509} Microsoft Visual Studio 2010 Professional - ENU

    After running uninstall utility run a MsiInv again to ensure they are all cleared off, if some remain you must uninstall by using the product code for VS2010 in the MsiInv.txt

    Using MsiInv to gather information about what is installed on a computer

    http://blogs.msdn.com/b/astebner/archive/2005/07/01/using-msiinv-to-gather-information-about-what-is-installed-on-a-computer.aspx

    By running a command i.e. uninstall the product by running msiexec /x <product code> (make sure that you include the curly braces in this command line).

    I am also seeing a successful install notification in the log files: ?

    MSI (s) (58:34) [00:47:28:323]: Note: 1: 1707

    MSI (s) (58:34) [00:47:28:323]: Product: Microsoft Visual Studio 2010 Professional - ENU -- Installation completed successfully.

    MSI (s) (58:34) [00:47:28:323]: Produkten installerades med Windows Installer. Produktnamn: Microsoft Visual Studio 2010 Professional - ENU. Produktversion: 10.0.30319. Produktspråk: 1033. Tillverkare: Microsoft Corporation. Slutförande- eller felstatus efter installationen: 0.

     

    ****Please check out the known installation issues in the Visual Studio 2010 Readme that addresses prerequisites, uninstall reinstall, trial license etc. And reverify your prerequisites ****

     Prior to reinstall please try to clear out the temp folder

    start>run>%temp% hit enter and clean it out.

     

    VS2010RTM ReadMe

    http://download.microsoft.com/download/8/C/E/8CE18AE7-CAA8-4A4C-87CF-0C3DF772322D/VS2010RTM.htm

     

     

    VS2010 uninstall utility

    http://archive.msdn.microsoft.com/vs2010uninstall

     

     

     


    bill boyce
    Thursday, February 24, 2011 4:14 PM