none
Could not load file or assembly 'file:///C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\dotnet1\crdb_adoplus.dll' or one of its dependencies.

    Question

  • windows 7

     

    running visual basic 2010 with crystal reports

     

    When I try to generate the report I get the error - the crystal report dll is not in the path

     

    Here's the error

    Could not load file or assembly 'file:///C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\dotnet1\crdb_adoplus.dll' or one of its dependencies. The system cannot find the file specified.

     

    The file is actua;lly in the folder

    'file:///C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\


    Thursday, July 26, 2012 8:12 AM

Answers

All replies

  • I am working with WonForms

    Thanks, Dai Nguyen Quang

    Thursday, July 26, 2012 8:15 AM
  • Is your machine is 64 bit? If yes, then probably it's the issue related to 64 bits. Change the Target Platform your application to x86 and then try running your application.

    I hope this helps.


    Please mark this post as answer if it solved your problem. Happy Programming!

    Thursday, July 26, 2012 8:19 AM
  • Target Platform of my application is x86,

    Please give me another solution,

    Thanks, Dai Nguyen Quang


    Thursday, July 26, 2012 8:54 AM
  • The error is

    Could not load file or assembly 'file:///C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\dotnet1\crdb_adoplus.dll' or one of its dependencies.

    but the Reference Path as below:

    Thursday, July 26, 2012 8:56 AM
  • I'm using Win 7, VS2010, Cystal report 13, I have changed the target framework as below.

    Please help me,

    Thanks, Dai Nguyen Quang.

    Thursday, July 26, 2012 8:59 AM
  • My problem was fixed by changing in app.config

    from:

    <!--<startup>
      <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>-->

    to:

    <startup useLegacyV2RuntimeActivationPolicy="true">

        <supportedRuntime version="v4.0"/>

      </startup>

    Thanks for all replies, Dai Nguyen Quang

    Thursday, July 26, 2012 9:44 AM
  • Thanks for your answer.
    Thursday, July 26, 2012 11:01 AM
  • Hello Dai,

    Just an additional information in case you need.

    As you are setting the target platform to x86; if you try to run your application on 64 bit machine then you need to install

    the 32 bit version of crystal reports and not 64 bit; because you target platform is x86.


    Rohit Rokade

    Thursday, July 26, 2012 11:22 AM
  • add this on appconfig

     <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
      </startup>

    Tuesday, August 28, 2012 7:48 AM
  • tnx Dai. it worked for me fine :)
    Sunday, November 11, 2012 8:54 AM
  • Thanks Dai its worked for me :)


    Saturday, December 08, 2012 8:03 AM
  • SAP has the following knowledge base article describing the same solution (the app.config change) and I can confirm it worked for me as well

    http://search.sap.com/ui/notes?id=0001525432&boj=/sap/bc/bsp/spn/scn_bosap/notes.do?access=69765F6D6F64653D3939382669765F7361706E6F7465735F6E756D6265723D30303031353235343332&ssocompatible

    • Edited by Marius Els Wednesday, January 16, 2013 9:03 AM
    Wednesday, January 16, 2013 9:02 AM
  • I don't know how to thank you Dai. I was trying to find this solution for months. May be I was a bad searcher. However, your solution has fixed one of my biggest issue. Thanks alot.
    Monday, March 11, 2013 3:10 AM
  • Thank you!  This fixed my issue as well, after hours of debugging and seaching.
    Monday, March 25, 2013 7:17 AM
  • The type initializer for 'CrystalDecisions.Shared.SharedUtils' threw an exception.

    i get this error by this dont get wats wrong with it 

    thank you in advance


    Dhaval

    Friday, August 09, 2013 7:08 AM
  •  Dear Dai Nguyen Quang

    Thank you very much,  my problem solved by this solution ,

    thanks and Best Regards,

    Moein Mohebbi

    Email: Moeinmohebbi@gmail.com

    Monday, August 12, 2013 11:36 AM
  • thank you.. your answer is useful to me....
    Sunday, September 01, 2013 12:04 PM
  • Thank and regards
    Friday, September 20, 2013 7:14 AM
  •  
    aid friends as I set my app config so that I do not throw error report thanks you for your great support

    <?xml version="1.0"?>
    <configuration>
      <configSections>
      </configSections>
      <connectionStrings>
        <add name="CN" connectionString="SERVER=JK_SISTEMAS\DELL;DATABASE=KIM;INTEGRATED SECURITY=TRUE" />
        <add name="KIM.My.MySettings.KIMConnectionString" connectionString="Data Source=JK_SISTEMAS\DELL;Initial Catalog=KIM;Integrated Security=True"
          providerName="System.Data.SqlClient" />
      </connectionStrings>
        <system.diagnostics>
            <sources>
                <!-- En esta sección se define la configuración del registro para My.Application.Log -->
                <source name="DefaultSource" switchName="DefaultSwitch">
                    <listeners>
                        <add name="FileLog"/>
                        <!-- Quite los comentarios de la sección posterior para escribir en el registro de eventos de la aplicación -->
                        <!--<add name="EventLog"/>-->
                    </listeners>
                </source>
            </sources>
            <switches>
                <add name="DefaultSwitch" value="Information"/>
            </switches>
            <sharedListeners>
                <add name="FileLog" type="Microsoft.VisualBasic.Logging.FileLogTraceListener, Microsoft.VisualBasic, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=MSIL" initializeData="FileLogWriter"/>
                <!-- Quite los comentarios de la sección posterior y reemplace APPLICATION_NAME con el nombre de su aplicación para escribir en el registro de eventos de la aplicación -->
                <!--<add name="EventLog" type="System.Diagnostics.EventLogTraceListener" initializeData="APPLICATION_NAME"/> -->
            </sharedListeners>
        </system.diagnostics>
    <startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup></configuration>
    
    

    
    
    
    
    Friday, February 07, 2014 5:42 PM
  • Gracias     answer solo cambie lo que indicas en tu post y todo nitido mil gracias 

        

    <!--<startup>
      <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>-->

    to:

    <startup useLegacyV2RuntimeActivationPolicy="true">

        <supportedRuntime version="v4.0"/>

      </startup>


    Willy Colindres

    Friday, April 25, 2014 4:49 PM
  • <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
        <configSections>

        </configSections>

        <connectionStrings>
            <add name="CrystalReportWpfApplication1.Properties.Settings.InventoryDBConnectionString"
                connectionString="Data Source=192.168.168.40;Initial Catalog=InventoryDB;Persist Security Info=True;User ID=sa;Password=cardeverp"
                providerName="System.Data.SqlClient" />
        </connectionStrings>
    </configuration>

    That is my app.config file content. Where should I put <startup> Code? I didn't know where.

           
    Wednesday, June 04, 2014 1:58 PM
  • <?xml version="1.0" encoding="utf-8" ?>
    < configuration>
        <configSections>

        </configSections>

        <connectionStrings>
            <add name="CrystalReportWpfApplication1.Properties.Settings.InventoryDBConnectionString"
                connectionString="Data Source=192.168.168.40;Initial Catalog=InventoryDB;Persist Security Info=True;User ID=sa;Password=cardeverp"
                providerName="System.Data.SqlClient" />
        </connectionStrings>
    < /configuration>

    That is my app.config file content. Where should I put <startup> Code? I didn't know where.

    • Proposed as answer by Gaeseong Park Wednesday, June 04, 2014 2:15 PM
    • Unproposed as answer by Gaeseong Park Wednesday, June 04, 2014 2:15 PM
    Wednesday, June 04, 2014 2:14 PM