none
Visual Studio 2010 SP1 installation - cannot find Silverlight.msi

    Question

  • Hello.

    I have attempted to install Visual Studio 2010 Service Pack 1 on the development server at work but I am encuntering an error shortly after the installation starts.

    I am logged into the server remotely using an account with administrative privileges. The source files for the service pack are located on a network drive. I have attempted the installation from there and also tried copying the source files to the local C: drive on the server but I receive the same error either way.

    ERROR:

    The feature you are trying to use is on a network resource that is unavailable.

    Click OK to try again, or enter an alternative path to a folder containing the installation package 'silverlight.msi' in the box below.

    The path shown is d:\temp\ext37558 but the msi file does not exist there.

    I located the file in the d:\476685b07733d24e1a85f13267daff64 folder but even when I select this, the above message appears again.

     

    Server information:

    Operating system: Windows Server 2003 R2

    Software installed: Visual Studio 2008 (with SP1) / Visual Studio 2010 / Sourcegear Vault (source control) / CruiseControl.NET (for continuous integration builds).

    Both the Silverlight 3 SDK and Silverlight 4 SDK are installed.

    Below are the contents of the error log produced by the service pack installation. I have provided a link to download the log file as posting the entire log exceeds the maximum body length for a post.

    http://www.filefactory.com/file/caf977b/n/Microsoft_Visual_Studio_2010_Service_Pack_1_20110312_094306295.html

    Saturday, March 12, 2011 12:53 PM

Answers

  • I have just managed to fix this issue!

    I had tried to install Silverlight 4 manually and it failed. The link provided for troubleshooting installation errors indicated that this may be due to an older version of Silverlight causing conflicts. 

    I went into Add/Remove programs and Silverlight 2.0.xxx.xx was installed. When I tried to remove this I received the same error about not finding silverlight.msi

    After some more searching on google, I found the following site which helps with silverlight installations. 

    http://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_install/trying-to-install-update-for-microsoft-silverlight/6eb96c95-13f6-44d5-814e-bb95e5a01e69#2c208137-0b33-4079-8b82-876d3759233f

    I followed the suggestion for deleting the registry key associated with silverlight. When I navigating to this key in regedit, I saw the last source was pointing to the exact location where silverlight.msi was being looked for when installing Visual Studio 2010 SP1. 

    I deleted this registry key then installed Silverlight 4 manually without any errors and then tried applying Visual Studio 2010 SP1 again and it has installed without any errors.

    I hope this helps other people.

    • Marked as answer by AdamEllison82 Sunday, March 13, 2011 9:18 AM
    Sunday, March 13, 2011 9:17 AM

All replies

  • I'm having exactly the same problem on my dev PC. I can't seem to go backwards or forwards. There's a Silverlight CAB file in a Silverlight4 folder, but no MSI. I can't get past it.
    jon b
    Saturday, March 12, 2011 9:45 PM
  • Yo me too. SP1 beta installed perfectly. I already have the silverlight 4 SDK installed. Could some1 tell us what is happening here with SP1? If I cancel it, it rolls back everything.

     

    Machine spec:

     

    Windows 7 64 bit

    4gb ram

    2.1ghz intel i5.

    Saturday, March 12, 2011 10:59 PM
  • In the Silverlight4 folder there are a couple of folder named like 1038, 1041 etc. Don't know what they're for, maybe culture/language or something like that. Anyway, they all contain the silverlight_msi, just try them one by one, eventually it should work (at least that's what worked for me), otherwise you'll get another error saying it's not the right version, and then you can just try the next folder.
    Saturday, March 12, 2011 11:28 PM
  • In reply to Christopher, I tried your suggestion but each folder only contained 'silverlight_sdk.msi' and not 'silverlight.msi' so even when I tried each file I received the message that 'silverlight.msi' cannot be found. 

    Also, when updating the server via Microsoft Update, trying to install Silverlight updates kb978464 and kb2416427 also fail with the original error message I posted.

    Sunday, March 13, 2011 8:18 AM
  • I have just managed to fix this issue!

    I had tried to install Silverlight 4 manually and it failed. The link provided for troubleshooting installation errors indicated that this may be due to an older version of Silverlight causing conflicts. 

    I went into Add/Remove programs and Silverlight 2.0.xxx.xx was installed. When I tried to remove this I received the same error about not finding silverlight.msi

    After some more searching on google, I found the following site which helps with silverlight installations. 

    http://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_install/trying-to-install-update-for-microsoft-silverlight/6eb96c95-13f6-44d5-814e-bb95e5a01e69#2c208137-0b33-4079-8b82-876d3759233f

    I followed the suggestion for deleting the registry key associated with silverlight. When I navigating to this key in regedit, I saw the last source was pointing to the exact location where silverlight.msi was being looked for when installing Visual Studio 2010 SP1. 

    I deleted this registry key then installed Silverlight 4 manually without any errors and then tried applying Visual Studio 2010 SP1 again and it has installed without any errors.

    I hope this helps other people.

    • Marked as answer by AdamEllison82 Sunday, March 13, 2011 9:18 AM
    Sunday, March 13, 2011 9:17 AM
  • Hi,

     

    A bit of a late reply to this issue, but canceling the silverlight sdk request (pop up) seems to resume the service pack1 setup.

     

    In my situation, this issue seems to be resolved.

     

    Hope this helps !

     

    best regards

    Saturday, September 24, 2011 2:55 PM