none
Microsoft .NET Framework Version 2.0 Redistributable Package won't instal

Answers

All replies

  • What is your Windows version?

    Because some Windows versions come with .NET Framework 2.0 as part of the OS, we need to know your Windows version before any specific suggestions can be offered.

    If you have Vista or Windows 7, you ALREADY have .NET Framework 2.0, and you should use this tool to verify your .NET Framework.

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET Framework 2.0 selected, then post the first 15 lines and last 15 lines of tool output here.

    If you have an older Windows version, you can try this cumulative installer for .NET Framework 3.5 SP1 (this includes .NET 2.0 and 3.0):

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Friday, July 06, 2012 9:35 PM
  • ======================================================================
    [07/09/12,06:59:30] Beginning of new SetupVerifier activity logging session
    [07/09/12,06:59:30] Activity log file location: C:\Users\rene'\AppData\Local\Temp\setupverifier_main_07-09-12_06.59.30.txt
    [07/09/12,06:59:30] Error log file location: C:\Users\rene'\AppData\Local\Temp\setupverifier_errors_07-09-12_06.59.30.txt
    [07/09/12,06:59:30] Build created on June 29, 2012
    [07/09/12,06:59:30] Detected operating system: Windows 7 (x64)
    [07/09/12,06:59:30] Install state for .NET Framework 1.0: not installed.
    [07/09/12,06:59:30] Install state for .NET Framework 1.1: not installed.
    [07/09/12,06:59:30] Install state for .NET Framework 2.0: installed with service pack 2.
    [07/09/12,06:59:30] Install state for .NET Framework 3.0: installed with service pack 2.
    [07/09/12,06:59:30] Install state for .NET Framework 3.5: installed with service pack 1.
    [07/09/12,06:59:30] Install state for .NET Framework 4 Client: installed with no service packs.
    [07/09/12,06:59:30] Install state for .NET Framework 4 Full: installed with no service packs.
    [07/09/12,06:59:30] Install state for .NET Framework 4.5: not installed.
    [07/09/12,06:59:30] Not adding product '.NET Framework 1.0' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 1.1' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 2.0' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 3.0' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 3.5' because it is not currently installed
    [07/09/12,06:59:30] Not adding product '.NET Framework 4.5' because it is not currently installed

    [07/09/12,06:59:35] Section [Registry GE - .NET Framework 2.0 SP2 (Common)] - stop parsing entries
    [07/09/12,06:59:35] Not running action 'Registry GE - .NET Framework 2.0 SP2 (32-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [07/09/12,06:59:35] Section [Registry GE - .NET Framework 2.0 SP2 (64-bit)] - start parsing entries
    [07/09/12,06:59:35] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
     Value: SP
     Expected Data: 2
     Actual Data: 2
    [07/09/12,06:59:35] Section [Registry GE - .NET Framework 2.0 SP2 (64-bit)] - stop parsing entries
    [07/09/12,06:59:35] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [07/09/12,06:59:35] ExecutablePath = 'Netfx20TestApplication.exe'
    [07/09/12,06:59:35] FriendlyName = '.NET Framework 2.0 test application'
    [07/09/12,06:59:35] TimeoutSeconds = '300'
    [07/09/12,06:59:35] WaitOnExit = 'true'
    [07/09/12,06:59:35] Silent = 'true'
    [07/09/12,06:59:35] Launching process 'Netfx20TestApplication.exe' now
    [07/09/12,06:59:35] Process successfully launched. Waiting 300 seconds for it to complete.
    [07/09/12,06:59:35] Process 'Netfx20TestApplication.exe' exited with return code 0
    [07/09/12,06:59:35] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [07/09/12,06:59:35] Verification succeeded for product .NET Framework 2.0 SP2

    Here you are, thanks for your help, now what do i do?


    rbd07

    Monday, July 09, 2012 2:01 PM
  • You still have not answered my original question.

    WHAT IS YOUR WINDOWS VERSION?

    The .NET Framework setup verifier indicates that you have .NET Framework 2.0 installed and working properly.

    In this situation, you need to contact the publisher of the software that cannot recognize the existing .NET Framework on your system.

    As you did not mention the make or model of your printer, I cannot offer a link to their support.

    As I still do not know your Windows version, this is a guess, but if you have Windows Vista or 7 and are trying to install using old drivers/software not designed for Windows Vista or 7, that could well be your problem.

    Again, you need to contact your printer maker's technical support for software/drivers certified for your Windows version.

    Monday, July 09, 2012 3:48 PM
  • Sorry, yes windows 7. Thr printer is a Lexmark X7675, might be getting a little old. It is working on my laptop w Vista.

    rbd07

    Monday, July 09, 2012 3:52 PM
  • You'll need to contact Lexmark tech support for Windows 7 certified drivers/software and/or ask them about your issue.

    Please be sure to let them know that you've verified your .NET Framework as correctly configured.

    Again, the inability to "see" an embedded .NET Framework is not an uncommon problem with older software not designed for Windows 7.

    Here's the link to Lexmark tech support:

    http://support.lexmark.com/index?page=productSelection&channel=supportAndDownloads&locale=EN&userlocale=EN_UK

    Tuesday, July 10, 2012 12:17 AM