none
What is error Sys.Webforms.PageRequestManagerServerErrorException

    Question

  • I have a server button in an aspx page. On click of the button I am opening a new aspx page as follows:

    Protected Sub btnView_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnView.Click

    Dim script As String = "OnLoadComplete();window.open('ViewReport.aspx?id=" & requestId & "','mywindow','width=1000,height=675,toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,copyhistory=no,resizable=yes,left=10,top=10');"
    ScriptManager.RegisterClientScriptBlock(Me, Me.GetType(), "script1", script, True)
          
    End Sub

    Sometimes not frequently when I click the button, I get an alert box with message as follows:

    Sys.Webforms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was : 500

    Please let me know why I am getting this error randomly and what is the solution to this.

    I guess there is some configuration issue as on one machine I am getting error, on other its working fine.

    Thanks
    Vikas

    Wednesday, June 25, 2008 7:31 PM

Answers

All replies

  • This is a known bug you may have caused it or maybe you did not check below for how to fix it.  If you still need help post again so I can provide more info.


    http://weblogs.asp.net/leftslipper/archive/2007/02/26/sys-webforms-pagerequestmanagerparsererrorexception-what-it-is-and-how-to-avoid-it.aspx
    Asp.net MVP, MCPD Web C#, MCITP BI & MCTS SQL Server 2005
    • Marked as answer by Figo Fei Wednesday, July 02, 2008 2:02 AM
    Thursday, June 26, 2008 12:05 AM
    Moderator
  • I am using the asp.net with c# and using the update panel(ajax), i am getting the error sometime not all time and no page navigate after then .

    following is the massange on the pop up window:-

    "Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 0 or 500"

     

     

    how  to solve this problem.
    Tuesday, June 29, 2010 6:41 AM
  • I am using the asp.net with c# and using the update panel(ajax), i am getting the error sometime not all time and no page navigate after then .

    following is the massange on the pop up window:-

    "Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 0 or 500"

     

     

    how  to solve this problem.

    This is a known bug but I am not sure if it is related to navigation because in AJAX if you did not implement history you will loose navigation, so you need to find out if you have the known bug and check your page history implementation.  What I am saying is you have two unrelated issues.
    MCPD Web C#, MCTS TFS, MCITP BI and DBA
    Tuesday, June 29, 2010 11:18 PM
    Moderator
  • Hi,

    Did this bug get resolved in the meantime?

    Tuesday, July 13, 2010 8:18 AM
  •  Common causes for this error are when the response is modified by
    calls to Response.Write(), response filters, HttpModules, or
    server trace is enabled on web.config file.
    Saturday, July 17, 2010 11:55 AM
  • An unknown error occurred while processing the request on the server.

     

    http://sysisundefined.blogspot.com/2010/09/unknown-error-occurred-while-processing.html

    Wednesday, September 08, 2010 10:55 AM
  • Sys.Webforms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was : 500

    I got solution for this problem. I will explain my problem first.

    I got this problem when i replaced the code in IIS. Unfortunately i copied 

    <

    add key="ERRORLOGPATH" value="C:\Inetpub\wwwroot\leave\errorlog\errorlog.txt" />

     

     in web.config file under <connectionstrings/> block. Then it dint thrown error for this block of code but given the following error

    Sys.Webforms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was : 500

       So, Please check your web.config file thoroughly.

     

    Thank you..

    Thursday, January 27, 2011 11:27 AM
  • I had this bug...

    My problem was that I had a single quote contained in a textbox on the form.

    If I entered:  Bob’s Stuff into a textbox named txtStuff, my code would save the data to the database after I used the encoding  i.e.  Server.HtmlEncode(txtStuff.Text).

    My problem was when I read it back from the database I did not use Server.HtmlDecode() so when the form loaded, it would show Bob&#39;s Stuff.  When I tried to use a drop down list contained in an UpdatePanel on the form, the page threw the Sys.Webforms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was : 500 error

    Once I used Server.HtmlDecode(row.stuff.ToString()) to read back the data as I had originally typed it, I did not get the 500 error anymore.

    Hope this helps.

    Saturday, April 30, 2011 7:36 PM
  • I had the exact same problem,

    All I had to do is to use the full url (http://server/app/default.aspx instead of http://server/app/)

    Hope this helps someone.

    greetings!

    Friday, April 20, 2012 9:17 PM
  • Hi Please add this two webconfig entry all web front end servers 

    How to fixed:

    To solve this issue we need to add below web.config entry to WFS the servers.

    <appSettings>

      <add key="aspnet:MaxHttpCollectionKeys" value="100000" />

    </appSettings>

    <system.web.extensions>  <scripting>   <scriptResourceHandler enableCompression="false" enableCaching="true"/>  </scripting> </system.web.extensions> 



    Guruprasad Marathe

    • Proposed as answer by Sophorn Seang Wednesday, August 08, 2012 9:08 AM
    Friday, June 08, 2012 10:38 AM
  • Hi All,

    Immediate help is needed, I have reporting server, i have put my RDL into my document library and getting the reports, for every report is works fine.. for one report, it is giving below error. I have added and tried all the about solutions here.. I run the SQL query it is taking 7 minutes to give data, I increased the HTTPRUNTIME to  3600( it is almost one hour, but still not getting reports.. please help is needed

    PRODUCTION ERROR

    Webpage error details User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.3) Timestamp: Tue, 19 Jun 2012 06:52:57 UTC Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 500 Line: 5 Char: 62099 Code: 0 URI: http://<URL>/ScriptResource.axd?d=zt4LUguhgm25hic9WIY_abPpN_IauxXxgA3osIEKVeJha9DNZE2UafDdeYngmUL0rfBxSFGhKDf1IsUQ_i4vy3iK1PbNPjWEaHzk0Lto368OaSeYMpSkMG2Cp08sT4DHMuuh9cc2NSB-p8TIsYv5_C3CySQ1&t=ffffffffb868b5f4

    Staging ERROR

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.3) Timestamp: Tue, 19 Jun 2012 06:54:05 UTC Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 12152 Line: 5 Char: 62099 Code: 0 URI: http://<URL>/ScriptResource.axd?d=0lK6iSgiGZHRCm_U4zK2a951ZwdtpD70i3zbCNwmRSEvDAOoSZStOIi38PGoVScGGIgRMRQIF-p03fYovVa_1_3AY851HBBp5jjPH6jjatHaHxFKJsLOMelkb9rntixRb4BASZ8xLQUXrsVYtLzdzP9QCvY1&t=ffffffffb868b5f4

    PLEASE HELP


    Guruprasad Marathe

    Tuesday, June 19, 2012 6:54 AM
  • Awesome, it's fixed my problem.

    thanks

    Wednesday, August 08, 2012 9:09 AM
  • Even am facing the exact above error said by GuruPrasad.Can anyone please help on this?


    Tuesday, January 08, 2013 10:20 AM
  • I had the same problem when i tried to postback a field with some html as content.

    To avoid this validation add ValidateRequest="false" in the <%@ Page /> directive.

    Tuesday, January 29, 2013 6:00 PM
  • Thanks a lot GuruPrasad Marathe...

    Hopefully it will will work when I deploy my apps to the server.

    Actually,  I have a RadGrid which when increased to its some max PageSize, we were not able to FILTER the any column. It was working fine at my local end but was not workin at server.

    Thanks though...

    Wednesday, June 19, 2013 7:55 AM
  • Thanks  Guruprasad, It working for me .. i just addbelow line in web.config file.

    <appSettings>

        <add key="aspnet:MaxHttpCollectionKeys" value="8001"/>

      </appSettings>

    Thanks

    Sangram Bishi

            
    Friday, June 28, 2013 7:44 AM
  • Thanks Guruprasad. It worked for me.

    Gopi Srinivas K

    Monday, July 01, 2013 6:53 AM
  • Wonderful! Thank you! This solved my problem!
    Thursday, March 27, 2014 6:58 PM
  • it's works, you saved me, thank you very much
    Friday, March 28, 2014 8:52 AM