none
Unrecognized configuration section 'connectionStrings'

    Question

  • Hello ,can someone help me in the following :

     I have some pages that have been created with VWD express but when I try to test these pages with Dreamweaver or when I upload these pages on to a Host provider I get the following error message:

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized configuration section 'connectionStrings'

    Source Error:

    Line 10: <configuration>
    Line 11: 	<appSettings/>
    Line 12: 	<connectionStrings>
    Line 13:   <add name="membersConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|/members.mdb;Persist Security Info=True"
    Line 14:    providerName="System.Data.OleDb" />


    Source File: c:\inetpub\wwwroot\entrep\web.config    Line: 12

     

    what could I do to overcome this error?


    Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032

    Wednesday, December 21, 2005 8:54 PM

Answers

  • change the Framework to version 2.0 in IIS (tab of ASP.NET).

     

    Tuesday, January 03, 2006 12:28 AM
  • If you don't want to (or can't) change the framework, try doing the following:

    <configuration>
        <configSections>
           <sectionGroup name="test">
              <section name="test1" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
              <section name="text2" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
           </sectionGroup>
        </configSections>
    </configuration>


    <test>
        <test1>
           <add key="testA" value="A" />
           <add key="testB" value="B" />
        </test1>
        <test2>
           <add key="testZ" value="Z" />
           <add key="testY" value="Y" />
        </test2>
    </test>
    Saturday, January 14, 2006 3:29 PM
  • check this http://support.microsoft.com/kb/311091/ko it works for me
    Saturday, June 16, 2007 1:25 PM

All replies

  • change the Framework to version 2.0 in IIS (tab of ASP.NET).

     

    Tuesday, January 03, 2006 12:28 AM
  • If you don't want to (or can't) change the framework, try doing the following:

    <configuration>
        <configSections>
           <sectionGroup name="test">
              <section name="test1" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
              <section name="text2" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
           </sectionGroup>
        </configSections>
    </configuration>


    <test>
        <test1>
           <add key="testA" value="A" />
           <add key="testB" value="B" />
        </test1>
        <test2>
           <add key="testZ" value="Z" />
           <add key="testY" value="Y" />
        </test2>
    </test>
    Saturday, January 14, 2006 3:29 PM
  • how?
    Friday, February 03, 2006 1:45 PM
  • from IIS go to ASP.NET tab and change the asp.net version to 2.0XXX
    Saturday, March 11, 2006 6:59 AM
  • There is no ASP.NET tab in my IIS window.

    Doh.  Ah, to clarify for other noobs out there, in IIS go to the specific virtual directory of the web application for which you are recieving this error.  Right-click on it, and in the properties there will be an ASP.NET tab which you can toggle to .NET

    Friday, April 07, 2006 10:27 PM
  • I launch IIS 6, expand websites, right click on the one in question, select properties and don't see an ASP.NET tab.  Am I still in the wrong place?
    Monday, April 10, 2006 6:28 PM
  • I already changed version in ASP.NET tab. Now it displays "page not found error".

    Narendra Singh Panwar

    narenpanwar@hotmail.com

     

    Tuesday, April 25, 2006 12:27 PM
  • After changing version 2.0 i am getting "page can not be displayed" eror message.

     

    Tuesday, April 25, 2006 12:39 PM
  • make sure that you IIS is running
    Tuesday, April 25, 2006 1:22 PM
  • How
    Tuesday, April 25, 2006 2:07 PM
  • sometimes there isn't a tab.  It's some sort of MS bug.  To fix there's a registry hack you need to do.  If that scares you, MS recommends a this file called version switcher:


    http://www.denisbauer.com/NETTools/ASPNETVersionSwitcher.aspx
    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=90552&SiteID=1


    It solved the prob on my server.

    Tuesday, April 25, 2006 5:02 PM
  • 1-open IIS

    2-select your computer name [your server]

    3-from action menu > choose All tasks > then choose Restart IIS ..

    then reconfiger your web application , and start browsing .

    Wednesday, April 26, 2006 7:01 AM
  • ok i restarted IIS Server but it still give me the same error page "page can not be found"
    Wednesday, April 26, 2006 7:18 AM
  • check if the page actually exists !
    Monday, May 08, 2006 11:04 AM
  • To resolve this, do the following steps:-

    This article applies for Windows Server 2003, IIS 6.0 environment.

    Download ASP.net 2.0 framework form
    http://msdn.microsoft.com/netframework/downloads/updates/default.aspx

     

    Click on start then select Run. Copy and paste this command then click okay. That will reregister ASP.NET to IIS
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -I

    from IIS go to ASP.NET tab and change the asp.net version to 2.0XXX
    (in IIS go to the specific virtual directory of the web application for which you are recieving this error.  Right-click on it, and in the properties there will be an ASP.NET tab which you can toggle to .NET)

    From your Run command, type inetmgr and press enter.
    Expand the appropriate nodes in the IIS to locate the "Webservice Extensions" Node
    Click on the same.
    You will find a list of "prohibited" extensions in the right.
    Click on ASP.NET and "allow" it.

    That should resolve this issue.

    Friday, June 16, 2006 4:14 PM
  • check this http://support.microsoft.com/kb/311091/ko it works for me
    Saturday, June 16, 2007 1:25 PM
  •  

    Its very use full tahnk u.
    Friday, November 02, 2007 10:56 AM
  • Do the following-
    1. Click Start
    2. Click on Run
    3. Write inetmgr
    4. Expand your computer (Whatever your computer's name)
    5. Expand Default Websites
    6. Select your website, Here i used UIUEC
    7. Right click
    8. Properties
    9. Select ASP.Net Tab
    10. In ASP.Net version select version 2
    11. You can go through this screenshot also.

    NOTE: Above configuration is according to Windows 2000 Pro. I don't have any idea about XP of other versions.
    Thursday, January 03, 2008 7:56 AM
  • Tnx. Saved me some trouble. Forgot that this is the issue with this error.
    Wednesday, July 21, 2010 3:10 PM
  • To overcome that problem, in the windows command type

    c:\windows\Microsoft.NET\Framework\V1.1.4322>aspnet_regiis -i

    Friday, May 25, 2012 10:33 AM