none
Visual Studio 2008 Version 3.0

    Question

  • Hi,

    I am experiencing 2 issues.  I have a C# application.  There is an executable file, when running gives an error stating, 'Unable to install or run the application.  The application requires that assembly Microsoft.Office.Tools.Common.v9.0 Version 9.0.0.0 be installed in the Global Assembly Cache (GAC) first. Please contact your system administrator.'  I don't know how to correct this issue.  Please give me instructions on what to do.

    The other issue is the application was originally written in version 2.0.  I currently have version 3.0.  Would I be able to compile, run, debug, open the project, execute the project, with the version that I have?  When currently opening a project, it's says it's an older version.  I need a workaround to this.  What can be done?

    Thanks.

    Tuesday, May 10, 2011 2:51 PM

Answers

  •  

    Hi lulu50,

    Thanks for posting in the MSDN Forum.

    It’s based on my experience that you are not implied correct component for you application.

    I would recommend you remove the Microsoft.Office.Tools.Common component from your project’s reference list by right click it at the solution explorer,and add the new Microsoft.Office.Tools.Common component version into it by right click mouse on solution explorer and select "Add Reference..." then select right component in the "Add Reference" dialog.

    I hope it can help you.

    Have a good day,

    Tom

     


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Thursday, May 12, 2011 6:07 AM
    Moderator