none
Problem with use-cachecluster command (ErrorCode<ERRCAdmin040>:SubStatus<ES0001>)

    Question

  • Hi,

    I've just installed the version 1.1 of Windows Server AppFabric caching on my development machine.
    I have a problem when I try to execute the command use-cachecluster, I've got this error :

    PS C:\Windows\system32> use-cachecluster
    Use-CacheCluster : ErrorCode<ERRCAdmin040>:SubStatus<ES0001>:Failed to connect to hosts in the cluster
    At line:1 char:17
    + use-cachecluster <<<<
        + CategoryInfo          : NotSpecified: (:) [Use-CacheCluster], DataCacheException
        + FullyQualifiedErrorId : Microsoft.ApplicationServer.Caching.DataCacheException, Microsoft.ApplicationServer.Caching.Commands.UseCacheClusterCommand

    I have the same result with xml or sql configuration provider.
    Is someone have an idea or workaround for this problem ?

    Best regards,
    Matthieu

    Thursday, January 05, 2012 2:39 PM

All replies

  • Are you on a VM without any network connected to it, perhaps?

    I know there's an issue with accessing the cache when the server isn't connected to a network.

    Two options

    1) Modify your hosts file (system32\drivers\etc\) and point your host name to 127.0.0.1. See http://social.msdn.microsoft.com/Forums/en/velocity/thread/abbb7ea0-5e0e-4c7b-b182-0e0b8eb52398.

    2) Install the loopback adapter and disable your other NICs when you're not connected to a network. See http://blogs.msdn.com/b/bizintegration1/archive/2011/10/23/playing-with-windows-server-appfabric-cache-error-creating-cache-errorcode-lt-errps009-gt-substatus-lt-es0001-gt-datacacheexception.aspx.

    Friday, January 06, 2012 3:14 PM
  • I'm not on a VM. AppFabric is installed on my computer which is connected to a network.
    So I have tried the first option, but it didn't change anything. I have the same behavior with the commande get-cacheclusterhealth.

    An other thing is really strange. I could do a start/stop-cachecluster. My host start, but the the version information is 0 [0,0] [0,0].

    HostName : CachePort    Service Name            Service Status Version Info
    --------------------    ------------            -------------- ------------
    MyHost:22233 AppFabricCachingService UP             0 [0,0][0,0]

     

    Monday, January 09, 2012 11:06 AM
  • Matthieu I am having the exact same issue you are seeing.  Adding my machine name to the hosts file fixed the Use-CacheCluster issue but now when I start the cache cluster I get time-out error.  My cache creating scripts worked fine in AppFabric 1.0.  I have found that this issue for me at least only occurs when setting up AppFabric 1.1 in a domain.  The issue does not reveal itself in a workgroup environment.  
    Tuesday, January 10, 2012 6:06 PM
  • Matthieu - I had the same problem. These two steps resolved it: 1. Start the Remote Registry service, if not started. AppFabric uses this service even to connect to your local machine (unless the hosts file is modified). If this step doesn't resolve the issue (which was the case with me), do Restart-CacheCluster from AppFabric Caching Admin PowerShell prompt, after remote registry is started.

    Hope this helps.

    • Proposed as answer by Matthieu Klotz Monday, January 16, 2012 3:09 PM
    Thursday, January 12, 2012 5:20 AM
  • Thanks Siva!  Remote Registry service solved my issue.
    Thursday, January 12, 2012 8:21 PM
  • Thanks Siva, your solution also solved my issue :)
    Monday, January 16, 2012 3:09 PM
  •  hi Siva , i also have the issue,  Remote Registry service is running and my computer is connecting to network good. but when i run program "Cache management PowerShell" the error is appear.

    Sunday, May 13, 2012 8:36 AM
  • Hi Lention,

       Are you running the Caching Administration Windows PowerShell as an administrator?

    The admin tries to ping all the machines in the cluster while it opens. When it is not able to reach them because of network issue or lack of administrative permissions, you could face this issue

       If the above step doesnt solve your issue, please check whether you running the Caching Administration Windows PowerShell under the same domain account you used to create the cluster

    Wednesday, May 23, 2012 5:48 AM
  • Matthieu - I had the same problem. These two steps resolved it: 1. Start the Remote Registry service, if not started. AppFabric uses this service even to connect to your local machine (unless the hosts file is modified). If this step doesn't resolve the issue (which was the case with me), do Restart-CacheCluster from AppFabric Caching Admin PowerShell prompt, after remote registry is started.

    Hope this helps.

    The Remote Registry start fixed my connection issue as well. Thanks for the tip.

    Brendan Sullivan

    Tuesday, June 19, 2012 1:21 PM
  • Matthieu - I had the same problem. These two steps resolved it: 1. Start the Remote Registry service, if not started. AppFabric uses this service even to connect to your local machine (unless the hosts file is modified). If this step doesn't resolve the issue (which was the case with me), do Restart-CacheCluster from AppFabric Caching Admin PowerShell prompt, after remote registry is started.

    Hope this helps.

    Restart-CacheCluster fixed the same issue on my laptop. The Remote Registry service remains disabled.
    Wednesday, July 04, 2012 7:59 AM
  • Matthieu - I had the same problem. These two steps resolved it: 1. Start the Remote Registry service, if not started. AppFabric uses this service even to connect to your local machine (unless the hosts file is modified). If this step doesn't resolve the issue (which was the case with me), do Restart-CacheCluster from AppFabric Caching Admin PowerShell prompt, after remote registry is started.

    Hope this helps.

    That fixed my problem: remote registry service was disabled.

    Thanks !


    Thursday, December 06, 2012 3:32 PM
  • I am having trouble with this.

    Environment:

    1 SQL 2008R2 server for the caching database

    3 AppFabric caching servers in a cluster

    I get this same error when running the Get-CacheClusterHealth command.

    I am running the console as Administrator
    The servers are all running on the network
    Remote Registry is running

    The Firewalls have been enabled both inbound and outbound
    Permissions on the database have been enabled

    Got any suggestions on what is next?

    • Edited by ArkAngelSeattle Friday, February 22, 2013 7:13 PM I wasn't done with the post.
    Friday, February 22, 2013 7:11 PM