none
Vusial Studio 2012 error Net Freworks

Answers

All replies

  • Same Problem Here :(
    Sunday, August 12, 2012 7:54 PM
  • Hi Pr0c3ss, pApModerN,

    As far as I know that if you install VS2012RC on Windows8 Developer Preview or Customer Preview machines, you will get the above erorr message. However, I noticed that you are working on the Windows8 Release Preview machine, in my opinion you should be able to install VS2012RC on it.

    Please try to use the collect.exe tool to collect the installation log files then upload the vslogs.cab file in the %temp% folder to the SkyDrive site, then send back me the link, I will take a look at the installation logs for you.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, August 13, 2012 1:54 AM
    Moderator
  • Hello Vicky Song

    I try to install it on Release Preview
    today I test it On Win7 and installed with no problems!! and beside of VS2012  , installed .net framework 4.5 with no error

    here is what you need to help us >> http://sdrv.ms/P7dOnO

    Tnx
    Monday, August 13, 2012 12:22 PM
  • Hi pApModerN,

    Which verion of .NET Framework you have in the Control Panel? .NET Framework 4.5 Beta or .NET Framework 4.5 RC? If you have .NET Framework 4.5 Beta installed, please try to first uninstall it to apply .NET 4.5 RC and then re-install VS2012RC to see if it helps.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, August 15, 2012 4:03 AM
    Moderator
  • I have the same issue, build 8400 and cant install as I have the wrong .net version. Might be missing something but where do I see which .net I have installed. I have tried removing it from windows features, however it still wont let me reinstall .net 4.5 

    Thanks

    Tim

    Wednesday, August 15, 2012 7:49 PM
  • forgot to mention I'm running it inside hyper-v though I assume that shouldn't matter.

    Tim

    Wednesday, August 15, 2012 7:55 PM
  • @ pApModerN, how about your issue now? Does my reply help you?

    @ Tim, please make sure you install VS2012 on the Windows 8 Preview machine. Installing it on the Windows 8 Developer or Customer preview is not supported.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, August 16, 2012 3:36 AM
    Moderator
  • Exact same issue here.  Running Windows 8 Release Preview build 8400.

    Attempting to install Visual Studio Express 2012 for Windows 8 results in the error, "The .Net Framework installed on this machine does not meet the minimum required version: 4.5.50709."

    Attempting to install the latest .NET Framework 4.5 (from: http://www.microsoft.com/visualstudio/11/en-us/downloads#net-45) results in the error, "Microsoft .NET Framework 4.5 is already a part of this operating system.  You do not need to install the .NET Framework 4.5 redistributable."

    The currently installed version of .NET 4.5 is 4.5.50501 but because of the install error above, it's impossible to update.  No updates for .NET Framework released through Microsoft Updates either.

    • Proposed as answer by adburg Saturday, September 22, 2012 3:28 AM
    Thursday, August 16, 2012 5:15 AM
  • After watching the installer with Process Monitor, I've found a workaround:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    After that, I was able to get the installer to complete and Visual Studio appears to run just fine.

    Thursday, August 16, 2012 5:49 AM
  • Visual Studio 2012 RTM is only supported on Windows 8 RTM, which includes the correct version of the .NET Framework 4.5. If you have problems installing VS2012 on Windows 8 RTM, please run http://aka.ms/vscollect and share the logs (vslogs.cab) it generates on a share, like http://skydrive.com.

    - Heath @ http://blogs.msdn.com/heaths; Visual Studio Professional Deployment

    Thursday, August 16, 2012 5:58 AM
    Moderator
  • Probably works fine for Windows 8. Trying it on Windows Server 2012 doesn't work. Even running regedit in administrator mode, errors out saying you can not edit "Version".
    Friday, August 17, 2012 5:55 PM
  • This is unsupported and Visual Studio 2012 may not work correctly afterward. VS2012 RTM is only supported on Windows 8 RTM.

    If you do not have an MSDN or TechNet Subscription, you can still install and run VS2012 RC which is still available from http://www.microsoft.com/en-us/download/search.aspx?q=Visual+Studoi+2012+RC.


    - Heath @ http://blogs.msdn.com/heaths; Visual Studio Professional Deployment

    Friday, August 17, 2012 6:49 PM
    Moderator
  • Pr0blem Solved no ..??

    Microsoft  Plesa Help..!!

    Friday, August 17, 2012 6:53 PM
  • VS2012 RTM is only supported on Windows 8 RTM which is currently available to MSDN and TechNet Subscribers, and will be generally available to everyone at some future date.

    Installing VS2012 RTM on a pre-release build (like the Release Preview) is not supported and any attempts to work around the blocks will lead to broken features in VS (there were breaking changes in Windows / .NET between RP and RTM on which VS RTM depends).


    - Heath @ http://blogs.msdn.com/heaths; Visual Studio Professional Deployment

    Friday, August 17, 2012 7:00 PM
    Moderator
  • Hey ,did it work for you?? i changed my setting to administrator .did till the last step, but i had an error "error writing the values new content" , maybe i didnt get the full control as an administrator.can you elaborate a bit..thanks..:) 
    Friday, August 17, 2012 7:26 PM
  • I did it. It was very hard to grant permissions, but I finally did it.

    Here are the steps I did to grant the permission:

    1. Open the Explorer and navigate to C:\Windows. Right click on regedit.exe and click Properties.

    2. Go to Security tab page and click Advanced button.

    3. Click the Change (from the second line - Owner) and in the following textbox write Administrators and click OK. Click the Apply button from bottom right area.

    4. From the users list select Administrators and click Edit. Grant Full Control and Save. Apply.

    5. Make sure all changes are applied.

    6. Now, right click on regedit.exe and Run as Administrator.

    7. Navigate to the path described by Eric and right click on the Full folder and click for Permissions.

    8. Go to Advanced area (click Advanced from the bottom) and make sure the Owner is "Administrators" and not "TrustedInstaller". Otherwise, make the change, give the "Administrators" user full control and apply the settings. 

    9. Now you should be able to change the version number.

    10. After all these steps you can run the Visual Studio 2012 Express installer.

    Hope this might help ;)

    Note: After all these stupid steps, seems that the installer crashed when finalizing the installation...

    Update: I finally installed the Visual Studio 2012 Express by downloading the ISO file.

    You will not be able to develop applications because you will get this error:

    The package requested Windows version 6.2 with AppModel version 1, while the current Windows version is 6.2 with AppModel version 0.

    I had to make some registry changes to make it work: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModel -> change the version number to 1 (of course, first you must grant permissions -> right click -> permissions -> change owner to Administrators -> full controll -> apply).

    Now I just tested a sample application so it seems to works now. Note: All these steps are available to Windows 8 Consumer Preview. 

    Saturday, August 18, 2012 10:20 PM
  • Gracias David me funciono el Instalador ya lo Pude Instalar 
    Sunday, August 19, 2012 12:07 AM
  • Hi,

    I just solved that problem.

    Install "Microsoft Visual Studio Ultimate 2012 RC" on Windows8 ReleasePreview.

    refer to the link,

    http://www.microsoft.com/en-us/download/details.aspx?id=29917

    good luck.

    Sunday, August 19, 2012 2:05 PM
  • Right. As I can see from the description this is supported even by Windows 7. But Visual Studio Ultimate 2012 RC is not the same as the final version. Here you have a lots a bugfixes and the final version really works! Of course, with some tricks.

    Off-topic: I just created some Javascript Apps. Nice work for Microsoft!

    Monday, August 20, 2012 5:25 PM
  • Thank you, Alex. Can you give a vote (thumb up) for my comment? Thanks ;)

    Happy development! ;)

    Monday, August 20, 2012 5:26 PM
  • You're right, but with some tricks (regedit.exe) you can make it work. I already did and I was able to create some Javascript apps.
    Monday, August 20, 2012 5:29 PM
  • This answer worked, I got it to install on Server 2012
    Tuesday, August 21, 2012 4:34 AM
  • Thanks David. This answer work! You have my vote.

    Wednesday, August 29, 2012 4:54 AM
  • Still having the same problem when changing the value "error writing the values new content". Do i need to install the windows 8 RTM version inorder to install it??
    Thursday, August 30, 2012 5:38 PM
  • Thankyou David..i figured it out, visual studio is installing..:)

    Thursday, August 30, 2012 6:20 PM
  • Thank you so much. It helped!!!
    Friday, September 14, 2012 10:18 PM
  • Thank you David Emanuel Oprea, worked perfectly, you are a god!

    Friday, September 21, 2012 11:12 PM
  • Thank you for me work well ;-)


    Alex

    Monday, September 24, 2012 9:16 AM
  • Yes this is gr8 solve

    It works

    can go through

    After watching the installer with Process Monitor, I've found a workaround:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    After that, I was able to get the installer to complete and Visual Studio appears to run just fine.


    • Proposed as answer by Rajendra b p Tuesday, September 25, 2012 6:31 AM
    Tuesday, September 25, 2012 6:30 AM
  • if the above given solutions are not working 

    here is something you can do 

    1. download visual studio 2012 express rc .iso

    2.download visual studio 2012 express .iso

    3.in visual studio 2012 express rc .iso there is a folder 

       packages .Delete this folder .

    4.copy packages folder from visual studio express in the same folder 

      that is visual studio rc folder .

    5. now install.you will see express features installed in rc .

    Saturday, September 29, 2012 10:55 AM
  • After watching the installer with Process Monitor, I've found a workaround:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    After that, I was able to get the installer to complete and Visual Studio appears to run just fine.

    It worked for me, thanks.
    Saturday, September 29, 2012 6:20 PM
  • thanks))) works great on win8 x64 8400=)))
    Sunday, September 30, 2012 2:45 PM
  • hi same prob am also facing...did u get the solution?
    Friday, October 05, 2012 10:18 AM
  • I had to delete the entire contents of the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4 to make it work...
    Monday, October 29, 2012 11:41 PM
  • After watching the installer with Process Monitor, I've found a workaround:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    After that, I was able to get the installer to complete and Visual Studio appears to run just fine.

    Nice it work !! thank you !!

    Sunday, December 16, 2012 2:10 AM
  • ¿Cómo lo hiciste? No soy capaz de darle control total al administrador, por lo tanto no me deja cambiar "Version", me sale un error al cambiar el nuevo contenido de valor.
    Wednesday, March 27, 2013 3:41 AM
  • Thanks it works

    In order to change registory

    plz download RegistrarHome from following link

    http://www.resplendence.com/download/RegistrarHomeV7.exe

    Saturday, May 18, 2013 4:30 PM
  • After watching the installer with Process Monitor, I've found a workaround:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    After that, I was able to get the installer to complete and Visual Studio appears to run just fine.

    Nice it work !! thank you !!

    It works for me too!!! But first I did what David Emanuel Oprea wrote. Thanks a lot!!!

    • Edited by BernaQro77 Thursday, May 23, 2013 5:52 AM
    Thursday, May 23, 2013 5:51 AM
  • How to change the owner ?
    Tuesday, July 09, 2013 9:25 PM