none
I have net framework 4.0 installed but I keep getting auto update for 3.5

    Question

  • I have net framework 4.0 installed but I keep getting auto update Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86

    Download size: 9.4 MB

    You may need to restart your computer for this update to take effect.

    Update type: Important

    This update is applicable to Windows Vista Service Pack 2 and Windows Server 2008 Service Pack 2. The Microsoft .NET Framework 3.5 Service Pack 1 is a full cumulative update that contains many new features building incrementally upon .NET Framework 2.0, 3.0, 3.5, and includes cumulative servicing updates to the .NET Framework 2.0 and the .NET Framework 3.0 subcomponents. The .NET Framework 3.5 Family Update provides important application compatibility updates. This update is provided to you and licensed under the Windows Vista and Windows Server 2008 License Terms.

    More information:
    http://go.microsoft.com/fwlink/?LinkId=133335

    Help and Support:
    http://support.microsoft.com

     

    What's up with this?

    Thursday, November 04, 2010 11:49 PM

Answers

  • You seem to be under the impression that you replaced earlier frameworks when you installed .NET Framework 4.0. That is not the case. The different framework versions are designed to work side by side on a computer.

    Further, if you have Windows 7, Framework 2.0/3.0/3.5 (this is a single framework. 3.0 and 3.5 are extensions of 2.0) through 3.5 SP1 are integral parts of the OS. Vista includes 2.0/3.0.

    So, tell us which Windows version you are using. You are being offered the updates because you *do* have .NET 2.0/3.0/3.5.

    • Marked as answer by Larcolais Gong Thursday, November 11, 2010 6:38 AM
    Friday, November 05, 2010 2:23 PM