none
How do I get the WCF RIA in Visual Studio LightSwitch 2011

    Question

  • I have gone through a number of great presentations on using WCR RIA services to call a stored procedure in a database. For what I need to ultimately accomplish with my app, I will need to do this at different points in the workflow. I keep seeing the WCF as an installed template in screen shots but I haven't figured out how to get that into the IDE that I mentioned in the title. I even followed the instructions for setting up the Web Display whatever, installed VS 2010 express [BTW where I can see the WCF services template], But alas VS LS 2011 didn't pick up on it. There are a preponderance of tools out there and I am quickly becoming overwhelmed. So the question is How do I get the WCF RIA services as in installed template in VS LS 2011?

    Thanks in advance for your help

    Harold


    Harold Rosenkrans

    Wednesday, February 22, 2012 4:51 PM

Answers

  • Ok, on a hunch I reran the RiaServices.msi and now it is showing up as Project type in the Silvlerlight Installed templates in VS Lightswitch 2011. Whew!, now I can get to work.

    Harold Rosenkrans

    • Marked as answer by Hal Rose Friday, February 24, 2012 7:23 PM
    Friday, February 24, 2012 7:23 PM

All replies

  • You don't need this Hal. Here you can find a detailed introduction to using RIA Services. Domain Service is the template you need and I believe you have it.

    1+1 = 3 for large values of 1

    Thursday, February 23, 2012 1:43 PM
  • Well - I am familiar with the Domain Service template. It is mentioned quite often in the articles and videos about the RIA services. It shows up in my VS 2010 express as does the WCF.

    But in VS Lightswitch 2011 I see nothing that matches any of the screen shots I have seen in the articles [many of which came from Beta editions] In the VS LightSwitchn template. Is that the same thing? I don't know how many of the articles and videos you have seen but there are a number of IDE's being used but I have not seen any using the one I downloaded from MSDN.

    So what do I need to enable my IDE to see the Domain Service template?

    Much appreciated.


    Harold Rosenkrans

    Thursday, February 23, 2012 5:31 PM
  • Ok, on a hunch I reran the RiaServices.msi and now it is showing up as Project type in the Silvlerlight Installed templates in VS Lightswitch 2011. Whew!, now I can get to work.

    Harold Rosenkrans

    • Marked as answer by Hal Rose Friday, February 24, 2012 7:23 PM
    Friday, February 24, 2012 7:23 PM
  • You guys are all very bad men (Babu scolding Jerry). Why didn't someone tell me to install VS 2010 on the same machine I had the Lightswithch development IDE installed on? Once I did that everything showed up! The fact that VS Lightswitch 2011 installs all by itself leads one to believe that everything you need is there or can be added later. Had someone told me that VS Lightswitch is more accurately an adjunct to VS 2010 I would have installed VS 2010 first, then Lightswitch. Thing make so much more sense now!

    Harold Rosenkrans

    Monday, February 27, 2012 4:36 PM