none
Microsoft.NET Framework 2.0

    Question

  • I have currently installed Microsoft.NET Framework 1.1  I tried to install .NET Framework 2.0 got this error message:

    Error 25015 Failed to install assembly 'C:\\WINDOWS\Microsoft.net\Framework\V2.0.50727\SystemSecurity.dll' because of system error 0x80131107

     

    Any help would be appreciated

    Thank You

    Saturday, August 07, 2010 3:17 AM

Answers

  • Hi Jennifer,

    Thank you for your post in MSDN forum!

     

    Some clarification with you

    What is your OS?

     

    Please first try the workaround in this article: Assembly load failure installing the 2.0 Framework which described an issue similar to yours.

    If this does not solve your problem, you can try using the following steps to solve this problem:

    1, Uninstall the version of framework on your machine via Add/Remove Program

    2, Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.1 or .NET Framework 2.0)

    3, (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed

    4, Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update.  Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them

    Frankly speaking, if your OS is Windows 7, you could install directly .NET Framework 3.5 Full on your machine. It includes .net framework 2.0 sp2, .net framework 3.0 sp2 and .net framework 3.5 sp1.

     

    Look forward for your good news!

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 09, 2010 8:26 AM

All replies

  • i just installed .net framwork 4, works fine...no longer need help thank you anyway
    Saturday, August 07, 2010 4:02 AM
  • Hi Jennifer,

    Thank you for your post in MSDN forum!

     

    Some clarification with you

    What is your OS?

     

    Please first try the workaround in this article: Assembly load failure installing the 2.0 Framework which described an issue similar to yours.

    If this does not solve your problem, you can try using the following steps to solve this problem:

    1, Uninstall the version of framework on your machine via Add/Remove Program

    2, Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.1 or .NET Framework 2.0)

    3, (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed

    4, Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update.  Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them

    Frankly speaking, if your OS is Windows 7, you could install directly .NET Framework 3.5 Full on your machine. It includes .net framework 2.0 sp2, .net framework 3.0 sp2 and .net framework 3.5 sp1.

     

    Look forward for your good news!

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 09, 2010 8:26 AM
  • Hi Jennifer,

    I'm writing to follow-up this post. Do the above suggestions help you solve your concerns?

    I'm marking this post as Answered. If you have any findings and concerns, please feel free to unmark this post.

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, August 13, 2010 3:34 AM
  • Hello, Jennifer and Larcolais Gong. May you answer me, how i can download Microsoft NET. Framework 2.0 and install it?


    Thursday, December 01, 2011 12:20 PM