none
kb971090 fails to install

    Question

  • Instead, I get the ever-so-helpful msiexec.exe help window, which doesn't tell me what's actually wrong.

    I have Windows ® Installer. V 4.5.6001.22159 installed (updating that was the first thing I tried).

    This is the relevant portion of the log:

                + Core patch application
                   Target Product: {D407F7C0-579E-4CCB-91FD-855CE5084E86}
                   Command line: "C:\WINXP\system32\msiexec.exe" REBOOT=ReallySuppress  /i {D407F7C0-579E-4CCB-91FD-855CE5084E86} PATCH="C:\Documents and Settings\jabelli\Local Settings\Temp\ZNW8C\VS80sp1-KB971090-X86-INTL.msp" /l*v C:\Documents and Settings\jabelli\Local Settings\Temp\VS80sp1-KB971090-X86-INTL\VS80sp1-KB971090-X86-INTL-msi.0.log
                   + Launching process
                      Command line: "C:\WINXP\system32\msiexec.exe" REBOOT=ReallySuppress  /i {D407F7C0-579E-4CCB-91FD-855CE5084E86} PATCH="C:\Documents and Settings\jabelli\Local Settings\Temp\ZNW8C\VS80sp1-KB971090-X86-INTL.msp" /l*v C:\Documents and Settings\jabelli\Local Settings\Temp\VS80sp1-KB971090-X86-INTL\VS80sp1-KB971090-X86-INTL-msi.0.log
                   - Launching process
                   Command returned: 1639
                - Core patch application
                ERROR: Applying patch to product {D407F7C0-579E-4CCB-91FD-855CE5084E86} failed. Error = 1639
    
    
    • Edited by John Belli Wednesday, July 29, 2009 2:21 AM preview != post. This forum software is teh win
    • Changed type YiChun Chen Monday, August 03, 2009 5:27 AM Do not follow up
    • Changed type John Belli Friday, September 18, 2009 4:03 AM replied with solution
    Wednesday, July 29, 2009 2:15 AM

Answers

  • Sorry, I forgot to come back and report.

    I solved my problem. The problem was that the installer was not quoting the log file name. Since I was installing on XP, the %TEMP% directory contained a space (well several spaces). This was the error in the command line argument. I temporarily changed the %TEMP% environment variable to C:\temp and the installation completed successfully.
    • Marked as answer by YiChun Chen Friday, September 18, 2009 5:41 AM
    Friday, September 18, 2009 4:00 AM

All replies

  • Hi John,

    Some clarification:
    What's your OS?

    KB971090 is Visual Studio 2005 Service Pack 1 ATL Security Update. Please upgrade your Visual Studio 2005 to SP1 before applying this update.
    See: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7c8729dc-06a2-4538-a90d-ff9464dc0197
            http://support.microsoft.com/kb/971090/

    Error code 1639 mean "Invalid command line argument. Consult the Windows Installer SDK for detailed command-line help." From this error message, it seems that the issue could be related to Windows Installer.

    For further troubleshooting, could you please try collecting the log files of VS80sp1-KB971090-X86-INTL from your "%temp%" folder?
    You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Download Visual Studio 2005 Service Pack 1 ATL Security Update
    - Try to clean your "%temp%" folder
    - Install this KB
      (For Vista or later, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
    - Upload log file

    Thanks


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.

    • Edited by YiChun Chen Thursday, July 30, 2009 9:10 AM typo
    Thursday, July 30, 2009 9:03 AM
  • Hi John,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 03, 2009 5:27 AM
  • I am getting this error for the 971090 patch on Vista SP1, VS2005 SP1:

    MSI (s) (80:50) [03:33:10:339]: Product: Microsoft Visual Studio 2005 Team Edition for Software Developers - ENU -- Error 1935.An error occurred during the installation of assembly 'policy.8.0.Microsoft.VC80.DebugOpenMP,type="win32-policy",version="8.0.50727.4053",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86"'. Please refer to Help and Support for more information. HRESULT: 0x80073712. assembly interface: IAssemblyCacheItem, function: Commit, component: {81D21DF1-1859-2738-A01F-C8B3B9A1E18E}

    Error 1935.An error occurred during the installation of assembly 'policy.8.0.Microsoft.VC80.DebugOpenMP,type="win32-policy",version="8.0.50727.4053",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86"'. Please refer to Help and Support for more information. HRESULT: 0x80073712. assembly interface: IAssemblyCacheItem, function: Commit, component: {81D21DF1-1859-2738-A01F-C8B3B9A1E18E}


    80073712 means "The component store has been corrupted.".  Any idea how to workaround this?  thank you.

    Tuesday, August 04, 2009 1:21 PM
  • Note: I had originally tried writing this in the Opera browser, but the javascript magic doesn't work right in it.

    I am having the same problem.  I'm running Windows XP SP2.  Regardless of whether I manually install the update or I use automatic update, I get the same error.


    I have uploaded the log files for installation of this and another recent VS update to my sky drive .


    Here is an excerpt from the log file for this update:

     
    + Core patch application
     Target Product: {AB6F4AB9-AC85-4002-9829-B6EEA55AE3A5}
     Command line: "C:\WINDOWS\system32\msiexec.exe" REBOOT=ReallySuppress /i {AB6F4AB9-AC85-4002-9829-B6EEA55AE3A5} PATCH="C:\DOCUME~1\njyoder\LOCALS~1\Temp\ZNW45F4\VS80sp1-KB971090-X86-INTL.msp" /q /l*v C:\DOCUME~1\njyoder\LOCALS~1\Temp\VS80sp1-KB971090-X86-INTL\VS80sp1-KB971090-X86-INTL-msi.0.log
     + Launching process
     Command line: "C:\WINDOWS\system32\msiexec.exe" REBOOT=ReallySuppress /i {AB6F4AB9-AC85-4002-9829-B6EEA55AE3A5} PATCH="C:\DOCUME~1\njyoder\LOCALS~1\Temp\ZNW45F4\VS80sp1-KB971090-X86-INTL.msp" /q /l*v C:\DOCUME~1\njyoder\LOCALS~1\Temp\VS80sp1-KB971090-X86-INTL\VS80sp1-KB971090-X86-INTL-msi.0.log
     - Launching process
     Command returned: 1612
     - Core patch application
     ERROR: Applying patch to product {AB6F4AB9-AC85-4002-9829-B6EEA55AE3A5} failed. Error = 1612
    Thursday, August 06, 2009 12:00 AM
  • Sorry, I forgot to come back and report.

    I solved my problem. The problem was that the installer was not quoting the log file name. Since I was installing on XP, the %TEMP% directory contained a space (well several spaces). This was the error in the command line argument. I temporarily changed the %TEMP% environment variable to C:\temp and the installation completed successfully.
    • Marked as answer by YiChun Chen Friday, September 18, 2009 5:41 AM
    Friday, September 18, 2009 4:00 AM
  • Hi John,

    Thank you for your kindly sharing.

    Have a good weekend.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, September 18, 2009 5:41 AM
  • Hi
    I do not know how to change

    temporarily changed the %TEMP% environment variable to C:\temp

    Tuesday, March 02, 2010 7:53 PM