none
WCF Instrumentation problem

    Question

  • Hi there

    I cannot see my WCF Log.xml file when application uses the local IIS server.

    For Cassini server everything works fine, I can see and parse my log file, created in accordence to the following setting:

    <system.diagnostics>
        <sources>
          <source name="System.ServiceModel"
          switchValue="Information, ActivityTracing, Verbose" propagateActivity="true">
            <listeners>
              <add name="log"
              type="System.Diagnostics.XmlWriterTraceListener"
              initializeData="LogPortal.xml" />
            </listeners>
          </source>
        </sources>
      </system.diagnostics>

    As soon as I switch from "Use Visual Studio Development Server" to "Use Local IIS Web server" (I need it for SSL connection debugging), no file LogPortal.xml can be found neither in root directory nor somewhere else on my computer.

    What I have done so far to fix a problem:

    1 . I set Full righites for IUSR, NETWORK and DefaultAppPool users for the project folder

    2. I stop IIS each time I'm looking for the file to make it commited to disk

    Nothing helps.

    How to make the WCF to create the file I need?

    Thanks.

    Monday, January 21, 2013 5:41 PM

All replies

  • Hi,,

    It seems no problem with your config, do you check it under bin folder?

    Best Regards.


    Haixia
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 23, 2013 3:49 AM
    Moderator
  • >neither in root directory nor somewhere else on my computer

    Thanks.

    Wednesday, January 23, 2013 4:10 PM
  • Hi,

    I tried on my side both VS2010 and VS2012(Use IIS Express, the file is located at bin folder). In with VS2010, after creating the Virtual Directory, you need enable Directory browsing, the log file is located under service project folder. I'd suggest you try on another machine with IIS configured properly.

    Best Regards.


    Haixia
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, January 25, 2013 1:47 AM
    Moderator
  • Hi Haixia

    I enabled the directory browsing for the site, but it does not help. I cannot see my LogPortal.xml somewhere on my computer.

    BTW, my another project, cofigured pretty much the same way, has no problems with diagnostics: log file is put in the root directory each time I enable system.diagnostics section and run it.

    Any clue?

    Thanks.

    Thursday, January 31, 2013 4:32 PM