none
VS2010 TeamBuild fails with CS0234: The type or namespace name 'Linq' does not exist in the namespace 'System'

    Question

  • I'm haveing a problem with TeamBuild on Vs2010 using the build server.

    When building from the command line using msbuild .\TfsBuild.proj my build works fine, but when launch a build from TFS my build fails with "CS0234: The type or namespace name 'Linq' does not exist in the namespace 'System'"

    Any ideas as to why there would be a difference?

     

    -Michael Clark

    Friday, January 21, 2011 3:30 PM

Answers

All replies

  • Hi Michael,

     

    Thanks for your post.

     

    For this issue, I want to confirm with you that: have you installed .NET Framework 3.5 on your Build machine? If not, please install .NET Framework 3.5 on your Build Machine, and then try again.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, January 24, 2011 11:24 AM
    Moderator
  • Hi Michael,

     

    What about the progress for this issue?


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 25, 2011 11:05 AM
    Moderator
  • John

    I have VS2010 Utimate and when building a pre-existed working code I am having the same error.  I tried to install .NET Framework 3.5 but it would not let me since .NET Framework 4.0 already includes previous .NET Framework versions meaning 3.5, 2.0 and 1.1.  Please let me know how I can tackle this error.  BTW, I already added System.Core, System.xml.linq and System.Data.linq to no avail.  Any help from anyone out there will be appreciated.

    James

    Friday, August 26, 2011 6:58 AM
  • I am also having this issue - I have every Linq resource added I can think of but still getting this error on VS2010 Pro - shouldn't Linq be baked in by now??

    The type or namespace name 'Linq' does not exist in the namespace 'System' (are you missing an assembly reference?)


    Monday, August 29, 2011 5:56 PM
  • Problem: If you have .Net 4.0 installed and use the MSBuild.exe under v3.5 the build will fail where it can not find the Linq assembly even if you have your projects set to build with .Net 3.5.

    Solution: If you have .Net 4.0 installed use the MSBuild.exe under C:\Windows\Microsoft.NET\Framework\v4.0.xxxx instead of the MSBuild.exe under v3.5.

    Monday, January 07, 2013 5:50 PM