none
File Untrusted

    Question

  • Hi,

    I am having an msi file which is digitally signed using signtool.exe. The entire setup projects contains the setup and msi files. The prerequisites are downloaded from vendors site.

    The problem (which is not found in all environments (total xp,vista,win7) but consistant with 64 bit vista and 7 ) 

    The problem is when I install setup.exe the downloading of prerequisites(.NET 4.0 Framework Full) starts and the setup throws the error File untrusted with error log at Temp directory. This is very fast (Means I am sure it's not downloading the framework from internet) and if I cancel the setup and delete the folder in temp directory and try to install again the installation happens fine.

    The error log has the error returned -2146869232 with exit code 9. I have seen similar (-214*******) errors on web but this is different.

    Why is this behavior? Is there any solution for this?

    Saturday, September 08, 2012 12:18 PM

Answers

  • The setup works without even deleting the temp file. In Vista and Win 7 the dialog box have only cancel option .So the setup exits. In Win xp Ok and cancel button is there. Pressing OK will continue the installation with no problems. I saw the issue in 64 bit machines first, But the issue is across all platforms. The difference is in XP vc++ runtimes throws the error and in vista 4.0 Framework. 

    If there is no internet connected then the installation wont happen any way. (Seems ok cause the signed msi should be verified I believe).

    No antivirus is on the machine (Image from Ghost). I have the install.log with me. Can't find much info from it.

    Friday, September 14, 2012 4:44 AM

All replies

  • Assuming that by:

    "I am having an msi file which is digitally signed using signtool.exe. The entire setup projects contains the setup and msi files. The prerequisites are downloaded from vendors site."

    you mean an application that you developed and are now trying to deploy, you need to post here:

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads

    This forum supports setup and installation of the Visual Studio product itself.

    Saturday, September 08, 2012 1:01 PM
  • Hi,

    I am having an msi file which is digitally signed using signtool.exe. The entire setup projects contains the setup and msi files. The prerequisites are downloaded from vendors site.

    The problem (which is not found in all environments (total xp,vista,win7) but consistant with 64 bit vista and 7 ) 

    The problem is when I install setup.exe the downloading of prerequisites(.NET 4.0 Framework Full) starts and the setup throws the error File untrusted with error log at Temp directory. This is very fast (Means I am sure it's not downloading the framework from internet) and if I cancel the setup and delete the folder in temp directory and try to install again the installation happens fine.

    The error log has the error returned -2146869232 with exit code 9. I have seen similar (-214*******) errors on web but this is different.

    Why is this behavior? Is there any solution for this?

    Sunday, September 09, 2012 8:52 AM
  • Hi Jorge,

    Does the issue still exist now after you delete the temp directory? Are there any detail information of the log?

    You said that the issue only appears on 64 bit machine. Have you created different installer packages targetting to x86 and x64? You can find the TargetPlatform property in setup project's property grid.

    Also, would you like to check whether the issue is caused by anti-virus software?

    If there are any new findings, please feel free to let us know.

    Best regards,


    Chester Hong
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, September 11, 2012 5:24 AM
  • The setup works without even deleting the temp file. In Vista and Win 7 the dialog box have only cancel option .So the setup exits. In Win xp Ok and cancel button is there. Pressing OK will continue the installation with no problems. I saw the issue in 64 bit machines first, But the issue is across all platforms. The difference is in XP vc++ runtimes throws the error and in vista 4.0 Framework. 

    If there is no internet connected then the installation wont happen any way. (Seems ok cause the signed msi should be verified I believe).

    No antivirus is on the machine (Image from Ghost). I have the install.log with me. Can't find much info from it.

    Friday, September 14, 2012 4:44 AM