none
Web Publishing Problems, what does this Error Msg mean?

    Question

  • Hi im trying to publish to a webserver i created, however im having difficulty.. What does this mean? 

    Friday, May 25, 2012 10:54 AM

Answers

  • i just restarted using a good guide i found online. and realised that it pointed out missing parts in the other guide i used. 

    Anyways all working now and published. cheers for the input anyway :) 

    • Marked as answer by EvoVix Friday, May 25, 2012 2:44 PM
    Friday, May 25, 2012 2:44 PM

All replies

  • Hi

    This issue was occurred because of Web Deployment Agent service version.

    Kindly go to your control panel and open Add or Remove Program. then search for Web Deployment Tool 2.0. Uninstall the 2.0 version and install 1.0 version from here.

    Now publish your application. It should work.

    Regards


    Rashmi Ranjan Panigrahi

    Friday, May 25, 2012 11:57 AM
  • Hello!

    before anything else try these two things:

    1- FOR THE MOMENT, before uploading, disable firewall on the server and try again

    2- also make sure that password for  server is typed in correctly in publishing wizard

    dont forget to turn firewall back on! :-) and than configure it to meet your reqs, if that was the problem.

    Cheers

    Friday, May 25, 2012 12:02 PM
  • Hello!

    before anything else try these two things:

    1- FOR THE MOMENT, before uploading, disable firewall on the server and try again

    2- also make sure that password for  server is typed in correctly in publishing wizard

    dont forget to turn firewall back on! :-) and than configure it to meet your reqs, if that was the problem.

    Cheers

    How do i do both of those.. i am new to creating servers and cannot find these features on my iis manager.. 
    Friday, May 25, 2012 12:18 PM
  • Hello,

    1 - 90% that this is FIREWALL issue.   you will access it same as on Your local computer.    go to Start/Remote Desktop COnnection/   and enter address/user/password for your server.   have you done this earlier?

    when on server, go to Control Panel - System & Security - Windows Firewall - Turn on or off - Turn it off and press OK

    than go to Your LightSwitch and try publishing 

    Friday, May 25, 2012 12:25 PM
  • Hello,

    1 - 90% that this is FIREWALL issue.   you will access it same as on Your local computer.    go to Start/Remote Desktop COnnection/   and enter address/user/password for your server.   have you done this earlier?

    when on server, go to Control Panel - System & Security - Windows Firewall - Turn on or off - Turn it off and press OK

    than go to Your LightSwitch and try publishing 

    No i haven't done this already, havent set a username and password for my server either. 

    ok ill give this a try :)

    Friday, May 25, 2012 12:29 PM
  • Hello,

    1 - 90% that this is FIREWALL issue.   you will access it same as on Your local computer.    go to Start/Remote Desktop COnnection/   and enter address/user/password for your server.   have you done this earlier?

    when on server, go to Control Panel - System & Security - Windows Firewall - Turn on or off - Turn it off and press OK

    than go to Your LightSwitch and try publishing 

    why would i go to remote desktop connection instead of my IIS manager?? and where can i find my username.. i never typed that in anywhere :S

    Friday, May 25, 2012 12:33 PM
  • Oli,

    that would be right under my 2nd place :)  (not typing in password for server at the time of publishing).

    when YOu press PUBLISH in LightSwitch, please note that it is not only one "screen", it has 8 selections on the left hand side.

    when you choose 3rd option - PUBLISH OUTPUT - have You entered there user name / password, as well as server address?

    Friday, May 25, 2012 12:36 PM
  • Oli,

    that would be right under my 2nd place :)  (not typing in password for server at the time of publishing).

    when YOu press PUBLISH in LightSwitch, please note that it is not only one "screen", it has 8 selections on the left hand side.

    when you choose 3rd option - PUBLISH OUTPUT - have You entered there user name / password, as well as server address?

    yep, but that is when i get the error.. as you said i think it might be a firewall thing.. yet there is no way to turn the firewall off in the IIS manager
    Friday, May 25, 2012 12:41 PM
  • Oli,

    dont worry, it is actually quite easy. I guess You just havent used REMOTE DESKTOP CONN. to Your server earlier?

    once You are connected - Your screen will show server's screen, and than you will simply work like on your computer.

    - you are using windows 7?

    - you know credentials for connecting to the server?  it is the same password you have used for publishing in LightSwitch wizard.

    if you know this, just click on START / and in box above START enter     mstsc       (or choose Remote Desktop Connection, if you have it on your start menu)

    than you will enter server address

    if all goes OK, you will be prompted for user name / password  (Administrator credentials)

    than you will have on screen your server windows instace...

    than just go to control panel and to firewall settings, as described in previous posts.

    let me know how it goes

    Friday, May 25, 2012 12:50 PM
  • Oli,

    dont worry, it is actually quite easy. I guess You just havent used REMOTE DESKTOP CONN. to Your server earlier?

    once You are connected - Your screen will show server's screen, and than you will simply work like on your computer.

    - you are using windows 7?

    - you know credentials for connecting to the server?  it is the same password you have used for publishing in LightSwitch wizard.

    if you know this, just click on START / and in box above START enter     mstsc       (or choose Remote Desktop Connection, if you have it on your start menu)

    than you will enter server address

    if all goes OK, you will be prompted for user name / password  (Administrator credentials)

    than you will have on screen your server windows instace...

    than just go to control panel and to firewall settings, as described in previous posts.

    let me know how it goes

    .. but i do not know what the username is.. 

    also it wont let me connect because i get this error:

    yes im using windows 7

    Friday, May 25, 2012 12:55 PM
  • Oli,

    this SAME USER/PASSWORD is also needed at time of publishing, so it is safe to presume you havent entered this password into LightSwitch Publish wizard as well?

    that would be #1 problem (trying to publish without Administrator credentials for server entered into LS Pub. wizard).

    has someone else entered password earlier into the LS, or application has never been published?

    i would suggest you try getting Administrator password for Your Web Server, otherwise there is no chance to publish application.

    Friday, May 25, 2012 1:00 PM
  • Oli,

    this SAME USER/PASSWORD is also needed at time of publishing, so it is safe to presume you havent entered this password into LightSwitch Publish wizard as well?

    that would be #1 problem (trying to publish without Administrator credentials for server entered into LS Pub. wizard).

    has someone else entered password earlier into the LS, or application has never been published?

    i would suggest you try getting Administrator password for Your Web Server, otherwise there is no chance to publish application.

    is is a server i have i have made about an hour ago on my pc..  and when i made it.. it didnt ask for a username or password.. so i really dont understand where im supposed to get one from

    the only time i published my program was as a desktop.. so i could see if it worked.

    Friday, May 25, 2012 1:02 PM
  • i just restarted using a good guide i found online. and realised that it pointed out missing parts in the other guide i used. 

    Anyways all working now and published. cheers for the input anyway :) 

    • Marked as answer by EvoVix Friday, May 25, 2012 2:44 PM
    Friday, May 25, 2012 2:44 PM