none
Unable to install KB2581206

    Question

  • Hi,

    I recently signed up for TFS Preview and I am trying to get it working on my development machine.  When I try to install VS10SP1-KB2581206.exe I get an error stating that the KB is already installed or something is blocking the installation.  I checked for the KB inside the Visual Studio about dialog but it doesn't appear there, nor does it appear inside the installed updates inside Programs and Feature.  I am using Windows 7 64 bit.

    I took a look at the logs and found the following near the bottom.  Does anyone have any ideas?

    Thanks,

    Stephen

    ------------------

    OpenFileMapping fails with last error: 6
     The handle to the section is Null
     OpenFileMapping fails with last error: 6
     The handle to the section is Null
     
    Applicability for Installing: evaluating each item


     
    Determining state: of c:\94eb28d4e3f3957f2a919e7e93\VS10SP1-KB2581206.msp


     evaluating ApplicableIf:
     
    Exists: evaluating


     MsiXmlBlob: this patch is not applicable


    Exists evaluated to false

     
    Determining state of c:\94eb28d4e3f3957f2a919e7e93\VS10SP1-KB2581206.msp - not applicable


    Applicability for Installing determination is complete


    Applicability Result Count:


    Number of applicable items: 0


    Applicability Result Count

    KB2581206 does not apply, or is blocked by another condition on your computer. Please see http://go.microsoft.com/fwlink/?LinkId=225649 for more details.

    Sunday, October 02, 2011 11:02 PM

Answers

  • I ended up needing to do a complete reinstall of Windows.  I couldn't uninstall SP1 or Visual Studio, even by using the seperate tool you can download.  The upside is it is now all working correctly and I can connect to TFS from Visual Studio.  Not sure how my installation got so corrupted, but at least it is all go now.
    Monday, October 10, 2011 2:14 AM

All replies

  • Hi Stephen - welcome to the preview!

     

    VS 2010 SP1 is required before you install KB2581206. Do you have VS 2010 SP1 installed?


    --Trevor H.
    Monday, October 03, 2011 1:43 PM
  • Sorry, I should have noted that.  Yes I have SP1 installed.  My current version of Visual Studio is 10.0.40219.1 SP1Rel.
    Monday, October 03, 2011 8:33 PM
    • If you try to connect to your TFSPreview.com collection, can you? I know you said KB2581206 is not showing up on your Help>About screen, but perhaps the message is accurate and it *is* actually installed?
    • May we see a screen shot of your whole VS 2010 Help>About dialog, please?
    • Can you see VS 2010 SP1 and\or KB2581206 in Control Panel\Programs and Features (you'll have to click "View installed updates")? Usually it's there if it is installed correctly. If SP1 or KB2581206 is missing from the list, you may need to try installing them again (in that order).

    --Trevor H.
    Monday, October 03, 2011 8:45 PM
    • If I try to connect to my TFS preview collection in Visual Studio I get a 203 (Non-authoritive) error.  Team Foundation services are not available from server https://myaccount.tfspreview.com/.
    • My about dialog information won't fit in a single screenshot so I've taken the text dump that clicking on Copy Info gives you.
    • Looking at my installed updates I don't see Visual Studio Service Pack 1 there.  I see several references to KB983509, but no actual reference to SP1.  Microsoft Visual Studio SP1 does appear in the Programs and Features list (just not in installed updates), does this mean I potentially have a corrupt installation of SP1?

    ------------------------

    Microsoft Visual Studio 2010
    Version 10.0.40219.1 SP1Rel
    Microsoft .NET Framework
    Version 4.0.30319 SP1Rel

    Installed Version: Ultimate

    Microsoft Visual Basic 2010   01019-532-2002102-70894
    Microsoft Visual Basic 2010

    Microsoft Visual C# 2010   01019-532-2002102-70894
    Microsoft Visual C# 2010

    Microsoft Visual C++ 2010   01019-532-2002102-70894
    Microsoft Visual C++ 2010

    Microsoft Visual F# 2010   01019-532-2002102-70894
    Microsoft Visual F# 2010

    Microsoft Visual Studio 2010 Architecture and Modeling Tools   01019-532-2002102-70894
    Microsoft Visual Studio 2010 Architecture and Modeling Tools
       
    UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

    Microsoft Visual Studio 2010 Code Analysis Spell Checker   01019-532-2002102-70894
    Microsoft Visual Studio 2010 Code Analysis Spell Checker

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

    Microsoft Visual Studio 2010 Team Explorer   01019-532-2002102-70894
    Microsoft Visual Studio 2010 Team Explorer

    Microsoft Visual Web Developer 2010   01019-532-2002102-70894
    Microsoft Visual Web Developer 2010

    Crystal Reports Templates for Microsoft Visual Studio 2010  
    Crystal Reports Templates for Microsoft Visual Studio 2010

    Hotfix for Microsoft Visual Studio 2010 Ultimate - ENU (KB2522890)   KB2522890
    This hotfix is for Microsoft Visual Studio 2010 Ultimate - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/2522890.

    Hotfix

    Hotfix

    Hotfix

    Hotfix

    Hotfix

    JetBrains

    Microsoft Visual Studio 2010 Ultimate - ENU Service Pack 1 (KB983509)   KB983509
    This service pack is for Microsoft Visual Studio 2010 Ultimate - ENU.
    If you later install a more recent service pack, this service pack will be uninstalled automatically.
    For more information, visit
    http://support.microsoft.com/kb/983509.

    NuGet

    PostSharp

    Telerik Silverlight VSExtensions   2011.02.915.0
    Telerik RadControls for Silverlight VSExtensions Package

    VisualStudioIntegration2010   1.0
    Information about my package

    Windows Azure Tools   Version 1.5
    Windows Azure Tools for Microsoft Visual Studio 2010 v1.5.40909.1602

    Monday, October 03, 2011 9:04 PM
  • Hi Stephen,

    That's what I see as well on my machine (Microsoft Visual Studio SP1 appears in the Programs and Features list, just not in installed updates).  A couple more things:

    • How much disk space is on the drive hosting %temp%?
    • Was there anything else descriptive in the setup log (other errors)?
    • It often takes a long time so I am hesitant to suggest it, but would it be possible to reinstall VS 2010 SP1? If you select the Microsoft Visual Studio 2010 Service Pack 1 item in Programs and Features and then click Uninstall\Change, you should be given the opportunity to reapply it in a maintenance dialog.

     


    --Trevor H.
    Monday, October 03, 2011 10:13 PM
  • There is 20 gigabytes of space free on the drive hosting %temp% and no other error related content in the setup log (or Windows Event Log that I could find).  I'll do a reinstall overnight and see how I get on.

    Thanks for your assistance Trevor.

    Stephen

    Monday, October 03, 2011 10:16 PM
  • Hi Stephen, any luck post SP1 reinstall? If not, let's try this...

    1. Run this tool: http://support.microsoft.com/mats/Program_Install_and_Uninstall/en-us.

    2. Let it download the Fix It engine, then when the "Program Install and Uninstall troubleshooter" opens, select the recommended option.

    3. Select the "Installing" option.

    4. Select "Not Listed" at the "Select the program you are trying to install" prompt.

    If there are patch issues this tool will let you know.  If it found issues and fixed, please re-attempt the patch install after the run. If it fails again, please e-mail me the complete setup log; I am "MS_TrevorH" (Hotmail).

     


    --Trevor H.
    Tuesday, October 04, 2011 4:50 PM
  • Hi,

    I was unable to get SP1 to re-install.  On closer expection my %temp% looks to have most of its data deleted somehow.  I think I'm going to need to do a complete Visual Studio install and that is probably the source of the problem.  A job for the weekend unfortunately.  I'll let you know if I get it working on Monday.

    Thanks,

    Stephen

    Tuesday, October 04, 2011 5:11 PM
  • I ended up needing to do a complete reinstall of Windows.  I couldn't uninstall SP1 or Visual Studio, even by using the seperate tool you can download.  The upside is it is now all working correctly and I can connect to TFS from Visual Studio.  Not sure how my installation got so corrupted, but at least it is all go now.
    Monday, October 10, 2011 2:14 AM
  • Stephen,

    Wow, sorry to hear all that, but I am glad you got it up and running. Thanks for looping back; enjoy the service! :-)


    --Trevor H.


    Monday, October 10, 2011 1:33 PM
  • Hi all, 

     

    I've had the same issue as ButcherOfCode had.


    I installed Visual Studio 2010 and then SP1. The SP1 installation was the full one (not the web download one). 

    This patch refused to install, so I reinstalled SP1 through the Web Platform installer.

    After that the patch install went perfectly. I don't know why, but may be this helps for other affected people.

     

     

    Sunday, November 20, 2011 3:46 PM
  • Hi,

    I had a similar problem, and I had also installed SP1 from an ISO image rathar than using WPI.

    I was able to install the KB2581206 when I mounted the VS2010 SP1 ISO and then installed the KB2581206.

    Eventually this could help others with a similar problem.

    Regards,

    Nelson Morais


    Nelson Morais nelsonmorais@yahoo.com

    • Proposed as answer by Nelson Morais Thursday, March 08, 2012 12:03 PM
    Thursday, March 08, 2012 12:03 PM