none
Visual Studio 2008 PAINFULLY SLOW!!

    Question

  •  

    I have read the posts for Visual Studio 2008 being slow in HTML Designer. I even downloaded and installed the patch, to no avail.

     

    I am developing windows forms and my IDE has become so sluggish switching between design and source mode it is seriously impossible to be productive. Visual Studio hangs for a good 10 seconds while redrawing the screen then sits there frozen for another 5 seconds before letting me take control again. It also does this when coming out of debugging.

     

    I am on a fast dual core machine...

     

    Anyone else experiencing this?

    Saturday, February 16, 2008 6:17 AM

Answers

  • As an update, I found an even better fix so you dont' have to lose any functionality in VS 2008.  This also drastically improved performance (response time) for me in SQL server management Studio.

     

    In Internet Explorer 7...

    Tools->Internet Options->Advanced->Security Node->Uncheck 'Check for publisher's certificate revocation*'

     

    Once I did this, like magic, VS 2008 works great even with 'Enable the Visual Studio hosting process'  checked and SQL Server Management Studio's response time was almost immediate.

     

    It is a good day!

     

    My theory is the corporate network I am in is blocking certain ports (out of my control), and thus certain 'behind the scenes' requests are timing out, causing the delays. 

     

    - Robbie

     

     

     

    Monday, March 03, 2008 3:49 PM
  •  

    Yes, this is exactly what I am experiencing... a 16 second delay every time the IDE refreshes and coming out of debug mode (or release mode for that matter)

     

    I too have a dual core 3.0 Ghz machine with 3GB of Ram.

     

    I have applied the hotfix, but it did not fix this problem.

    Wednesday, February 20, 2008 5:38 PM
  • Dave -

     

    I don't know if this will help, but do you happen to be using any 3rd party controls? After initially fixing the problem, it started happening to me again, but his time it was taking even longer to build (if that's even possible). I happen to be using ComponentOne's controls in my projects, and I upgraded to the new 2008 versions. However what happened was that all of my License.licx files didn't update to reflect the new version that I was using. I had to delete out all of the .licx files, and then let VS auto-regenerate them for me by opening up a form that had the controls on them. After doing this, the build works perfectly. 

     

    It may be a long shot, but I hope it helps.

    Wednesday, April 30, 2008 4:57 PM

All replies

  •  

    Yes, this is exactly what I am experiencing... a 16 second delay every time the IDE refreshes and coming out of debug mode (or release mode for that matter)

     

    I too have a dual core 3.0 Ghz machine with 3GB of Ram.

     

    I have applied the hotfix, but it did not fix this problem.

    Wednesday, February 20, 2008 5:38 PM
  • Thank you for the links,

     

    Unfortunately this problem is not stemming from the Web Developer in VS 2008. 

     

    I am simply creating a C# Console App "Hello World" program, and I stripped it of every reference except for System.

     

    Whenever I hit Debug, the console shows "Hello World" and then returns to the IDE, the IDE freezes for 11 to 17 seconds during which time I cannot type or click anything - incredibly disruptive to productivity.

     

    - This behavior occurs even when I boot the computer in safe mode, start VS in safe mode, log in under a different user,

    and reinstalling Visual Studio.

     

    *** I did find 2 workarounds to solve the problem, but I dont think it is a fix as I am losing debug functionality in the process.

     

    1 You can either run the project using Ctrl+F5 'Start without Debugging'

    -or-

    2 You can go to project settings, Debug Tab, and uncheck 'Enable the Visual Studio hosting process'

     

    Using option 2, the IDE immediately works great - so I think there is a bug in the VS hosting process, or the way the IDE interacts with the VS hosting process.

     

    - I sure hope they find a fix to this problem, in the meantime I will probably just continue using VS 2005 to avoid the hassles.

     

    My machine specs:

    Windows XP Professional, Service Pack 2

    Intel Core 2 Duo E6850 @ 3 Ghz

    3 GB RAM

    - VS 2008 & VS 2005 installed concurrently

     

    • Proposed as answer by SolidSnakeGr Wednesday, April 18, 2012 12:58 PM
    Friday, February 22, 2008 8:35 PM
  • I don't seem to have this option. Debugging tab. I feel stupid but can you be more specific? I have looked under project->properties and also tools->options, and I don't see it...I have checked both 2005 and 2008. ???
    Friday, February 22, 2008 10:56 PM
  •  

    Ok, no problem, it is the same in both 2005 & 2008. (although i dont have this prob in 2005)

     

    - I am just using a standard C# app, I have not tested this with the other languages.

     

    Load a solution (with at least 1 project in it)

     

    Make sure Solution Explorer is showing (View -> Solution Explorer)

     

    Right click on the Project (not the Solution) and select properties.

     

    You should see the Debug tab now with the 'Enable the Visual Studio hosting process' option.

     

     

    Friday, February 22, 2008 11:07 PM
  • Of course...I am C++ not C#!
    Saturday, February 23, 2008 12:23 AM
  • As an update, I found an even better fix so you dont' have to lose any functionality in VS 2008.  This also drastically improved performance (response time) for me in SQL server management Studio.

     

    In Internet Explorer 7...

    Tools->Internet Options->Advanced->Security Node->Uncheck 'Check for publisher's certificate revocation*'

     

    Once I did this, like magic, VS 2008 works great even with 'Enable the Visual Studio hosting process'  checked and SQL Server Management Studio's response time was almost immediate.

     

    It is a good day!

     

    My theory is the corporate network I am in is blocking certain ports (out of my control), and thus certain 'behind the scenes' requests are timing out, causing the delays. 

     

    - Robbie

     

     

     

    Monday, March 03, 2008 3:49 PM
  • I wish switching between design and source only took 10 - 15 seconds on my machine, the IDE freezes sometimes over a minute.  Try making an adjustment, then another freeze for 30+ seconds.  Try using the split display and the IDE crashes - this new bug courtesy of the "hot fix". 

     

    I'm using a dual core, 2 GB 2.4 GHz system.

     

    I only wish MS project planners + developers found fixing bugs as glamorous as adding new worthless features.  You'd think that in the five years since the VS2003 release thses kinds of bugs would be fixed.  This tool is not usable for any serious development.  Project planners beware, if you are planning any new web development projects stay clear away from .NET.

    Saturday, March 15, 2008 8:27 PM
  •  Robbie Couret wrote:

    As an update, I found an even better fix so you dont' have to lose any functionality in VS 2008.  This also drastically improved performance (response time) for me in SQL server management Studio.

     

    In Internet Explorer 7...

    Tools->Internet Options->Advanced->Security Node->Uncheck 'Check for publisher's certificate revocation*'

     

    Once I did this, like magic, VS 2008 works great even with 'Enable the Visual Studio hosting process'  checked and SQL Server Management Studio's response time was almost immediate.

     

    It is a good day!

     

    My theory is the corporate network I am in is blocking certain ports (out of my control), and thus certain 'behind the scenes' requests are timing out, causing the delays. 

     

    - Robbie

     

     

     

     

    Robbie -

     

    This has been driving me nuts for months! We were testing on a machine that had no internet access and it was taking us 5-10 mins to build our solution (19 projects) and none of the other hot fixes or workarounds helped. Once we turned on internet access it started working, but we weren't sure why. It turns out that we have some 3rd party controls that are digitially signed which was causing the build to hang for so long (couldn't verify). You saved us couple hours of checking for the 'why', but too bad I didn't find this post a month ago. Thanks much!

     

     

    Wednesday, April 23, 2008 9:05 PM
  • <sigh />

     

    unfortunately, this did not work for me - nor did the KB946581 Hotfix.

    Thursday, April 24, 2008 2:13 AM
  • Dave -

     

    I don't know if this will help, but do you happen to be using any 3rd party controls? After initially fixing the problem, it started happening to me again, but his time it was taking even longer to build (if that's even possible). I happen to be using ComponentOne's controls in my projects, and I upgraded to the new 2008 versions. However what happened was that all of my License.licx files didn't update to reflect the new version that I was using. I had to delete out all of the .licx files, and then let VS auto-regenerate them for me by opening up a form that had the controls on them. After doing this, the build works perfectly. 

     

    It may be a long shot, but I hope it helps.

    Wednesday, April 30, 2008 4:57 PM
  • Hi Micah,

     

    Thanks for the suggestion.  I'm not using any 3rd party controls and checked for any .licx files just in case.  The only one I could find was related to the SQL Server 2005 Samples.

     

    <sigh />

    Thursday, May 01, 2008 7:02 AM
  • Robbie Couret said:

     In Internet Explorer 7...

    Tools->Internet Options->Advanced->Security Node->Uncheck 'Check for publisher's certificate revocation*'

     


    You champion. This problem was driving me up the wall. Thanks for posting the solution.
    Wednesday, August 20, 2008 12:58 AM
  • I had similar problems. I had several different solutions that had dlls that were shared. I went through each solution and deleted all my breakpoints. Output window when debugging went from 2+ minutes to 2 milliseconds.

    Monday, November 17, 2008 8:57 PM
  • Same exact problem here. VS2008 used to hang for 10 seconds (or more) in lots of situations, making it unusable. I did experience the hangs when coming out of debugging and decided I was not going to use VS2008 until the problem was solved.

    Diagnosis:
    What placed me on the good track was Robbie's suggestion to uncheck 'Check for publisher's certificate revocation*', this did not solve the problem for me, though.
    Disabling all network connection did solve the problem, but it's obviously a very bad workaround, so I've used Netmon3.0 to look behind the scenes.
    Turns out that my very simple Windows Forms Application was communicating to some infonotary.com server (a legitimate certification authority). A little more digging in the DNS requests and a few trials with the hosts file and I could find a decent solution.

    Workaround (for me!):
    I've just added the entry "127.0.0.1 ldap.infonotary.com" to my hosts file (C:\Windows\System32\drivers\etc\hosts).

    Workaround (for other people as well?):
    1) use NetMon3 to identify what communication is causing the delay. In my case, the strange communication appears in the "Network Conversations" pane, both under the "My Traffic\devenv.exe" and the "My Traffic\myapp.vshost.exe" (the debugged app) nodes.
    2) use  NetMon3 again to discover the dns name of the certification authority that VS is interrogating.

    [to do so: start debugging your app, open a command prompt and type "ipconfig /flushdns" (needs elevation in Vista), start a capture with netmon, stop debugging, wait few seconds, stop capturing. In netmon, under the "My Traffic\<Uknown>" node, you should see a conversation with one of your DNS servers, whatever matches the ip address identified in 1) is the DNS name you are looking for.]

    3) edit your C:\Windows\System32\drivers\etc\hosts file and add the line 127.0.0.1 %the DNS name from 2%

    Explanation:
    for some reason, the communication with this particular certification authority from within my corporate network is blocked. The NetMon capture shows three outgoing frames at three seconds interval, but no reply. This explains a 9+ seconds lag in VS.

    Disclaimer:
    Applying this is at your own risk, effectively you will prevent your PC to communicate with a given certification authority. This is somewhat risky and might prevent other programs and/or websites and/or webservices from working correctly.

    Notes:
    a) I have absolutely no idea of why VS is trying to contact a certification authority when starting and when running a "Hello world" winform. I've tried to figure out what component is signed with a certificate that validates through infonotary.com but I've failed, if anybody knows how to figure that out please do let us know here, I might be able to figure out a better workaround! I did not install any third prarty components, just VS2005, VS2008 and MS-SourceSafe.
    b) For the VS team (hoping they do read these forums): would it be possible to change the way VS checks certificates? To say this politley: it is rather peculiar that VS stops responding when waiting for some network communication to end!

    I hope this helps,

    Sergio

    Wednesday, January 28, 2009 4:26 PM
  • Wow.  I thought you were completely out of your tree when you posted "Uncheck 'Check for publisher's certificate revocation'" but, sure enough:  it instantly fixed my problem with VS being all but unusable.

    It’s incomprehensible that A. This is a problem at all and B. MS hasn’t fixed it.

    Friday, January 30, 2009 4:48 PM
  • I am running into a similar problem with VS 2008 and Windows 7 RTM. All other apps work fine, when I go into VS 2008 and try to click on a file in an existing solution or trying to create a new solution it hangs. I have to create winforms, wpf and a database solution. Says creating xxx... hard drive is going nuts, cpu % is high. But is non responsive, have let it sit for an hour with no difference (to create a new solution - crazy!!).  All I can do is to kill via task manager.

    Installed VS 2008 SP1, and SQL Express SP1. Running VS with the run as administrator option. Have tried the compatibility options of Vista, Vista SP1 & Vistar SP2 all with same results. Have tried to repair install, uninstall and re-install. Have tried both VS 2008 Pro and Team editions. Worked fine previously with Windows 7 build 7168.

    Quad core 2.0 ghz with 4 gb mem.

    Will try above suggestions and post results...

     

    • Edited by craig20120 Tuesday, September 01, 2009 1:24 PM
    Monday, August 31, 2009 7:19 PM
  • Hmmmm, tried the disable services reg edit tweak, the msconfig disable non-microsoft services and startup tasks, the publisher's certificate revocation in IE, with the internet connection off, uninstalling all third party controls and lastly tried installing VS 2010 Beta 1.

    All with the same results...  About to wipe Windows and reinstall.


    Tuesday, September 01, 2009 1:21 PM
  • As an update, I found an even better fix so you dont' have to lose any functionality in VS 2008.  This also drastically improved performance (response time) for me in SQL server management Studio.

     

    In Internet Explorer 7...

    Tools->Internet Options->Advanced->Security Node->Uncheck 'Check for publisher's certificate revocation*'

     

    Once I did this, like magic, VS 2008 works great even with 'Enable the Visual Studio hosting process'  checked and SQL Server Management Studio's response time was almost immediate.

     

    It is a good day!

     

    My theory is the corporate network I am in is blocking certain ports (out of my control), and thus certain 'behind the scenes' requests are timing out, causing the delays. 

     

    - Robbie

     

     

     

    Robbie, absolute genius. Been driving me nuts and this solution worked perfectly. Thanks!
    Thursday, February 25, 2010 4:38 PM
  • Same exact problem here. VS2008 used to hang for 10 seconds (or more) in lots of situations, making it unusable. I did experience the hangs when coming out of debugging and decided I was not going to use VS2008 until the problem was solved.

    Diagnosis:
    What placed me on the good track was Robbie's suggestion to uncheck 'Check for publisher's certificate revocation*', this did not solve the problem for me, though.
    Disabling all network connection did solve the problem, but it's obviously a very bad workaround, so I've used Netmon3.0 to look behind the scenes.
    Turns out that my very simple Windows Forms Application was communicating to some infonotary.com server (a legitimate certification authority). A little more digging in the DNS requests and a few trials with the hosts file and I could find a decent solution.

    Workaround (for me!):
    I've just added the entry "127.0.0.1 ldap.infonotary.com" to my hosts file (C:\Windows\System32\drivers\etc\hosts).

    Workaround (for other people as well?):
    1) use NetMon3 to identify what communication is causing the delay. In my case, the strange communication appears in the "Network Conversations" pane, both under the "My Traffic\devenv.exe" and the "My Traffic\myapp.vshost.exe" (the debugged app) nodes.
    2) use  NetMon3 again to discover the dns name of the certification authority that VS is interrogating.

    [to do so: start debugging your app, open a command prompt and type "ipconfig /flushdns" (needs elevation in Vista), start a capture with netmon, stop debugging, wait few seconds, stop capturing. In netmon, under the "My Traffic\<Uknown>" node, you should see a conversation with one of your DNS servers, whatever matches the ip address identified in 1) is the DNS name you are looking for.]

    3) edit your C:\Windows\System32\drivers\etc\hosts file and add the line 127.0.0.1 %the DNS name from 2%

    Explanation:
    for some reason, the communication with this particular certification authority from within my corporate network is blocked. The NetMon capture shows three outgoing frames at three seconds interval, but no reply. This explains a 9+ seconds lag in VS.

    Disclaimer:
    Applying this is at your own risk, effectively you will prevent your PC to communicate with a given certification authority. This is somewhat risky and might prevent other programs and/or websites and/or webservices from working correctly.

    Notes:
    a) I have absolutely no idea of why VS is trying to contact a certification authority when starting and when running a "Hello world" winform. I've tried to figure out what component is signed with a certificate that validates through infonotary.com but I've failed, if anybody knows how to figure that out please do let us know here, I might be able to figure out a better workaround! I did not install any third prarty components, just VS2005, VS2008 and MS-SourceSafe.
    b) For the VS team (hoping they do read these forums): would it be possible to change the way VS checks certificates? To say this politley: it is rather peculiar that VS stops responding when waiting for some network communication to end!

    I hope this helps,

    Sergio


    I realize I'm replying to a year old post, but this is flat out enlightening.  I turned on Netmon, and boy was I shocked.  Long story short, I used Robbie's original fix to great effect. 

    <soapbox>As MS moved the Visual Studio stack from 2003 ->2005 -> 2008, they added a ton of "features" (all turned on by default) that have nothing to do with the actual people using the tool.  They've actually done this across all their product lines (Vista, Office, etc.)  MS is a grown up company, so I won't go to far with this, but when you look at the tools and frameworks that are eating into their market share (cough cough PHP, cough FireFox) they are basic tools that just work.  Way less embedded gunk running behind the scenes.</soapbox>


    Sunday, February 28, 2010 4:14 PM
  • Hi all, this is for your information.

    I had a problem with VS2008 and WPF Browser projects. When I close IE to end debug session, VS hang for a few seconds and a message was shown
    "The debugger was unable to terminate one or more processes
    [PID] PresentationHost.exe: Access is denied ... "

    Checking for a solution, I monitor PresentationHost process with process monitor and found a suspect TCP Reconnect to infonotary.com.

    So, I found this post and Sergio Graziosi solution solve the problem. I also think that communication with infonotary is blocked in my corporate network.

    I opened a post into Visual Studio Debug forum (http://social.msdn.microsoft.com/Forums/en-US/vsdebug/thread/ab371af0-4772-488c-b8c3-a964d3089ddf/#2e35222f-de79-4c69-9851-f5aff09e37c5 ), but I post here for your information.

    Thanks Sergio!

    Monday, March 01, 2010 4:55 PM
  • VS2008SP1 ide (VC++ native) hang (always, repeatably) also with me when I do this:
    1) put a breakpoint
    2) run (--> stops at the breakpoint)
    3) stop debugging (shift-F5)
    4) edit a line before the breakpoint
    5) press F5
    6) RESULT: hangs: hard drive spinning forever, 100% cpu utilisation, even task manager too unresponsive to kill directly, needs to reboot mannually the computer

    If 5) is replaced with: ctrl-F5 (start without debugging): things run smoothly, no problems

    Chaning internet explorer setting as above is irrelevant in this case (and done just in case:--> no effect) and donwloading patches (including the monstrous 300MB one and including KB960075 and KB963035) has no effect at all.

    Again, I can fully repeat the problem as often as I wish and my patience will allow.
    Therefore I can easily verify if a patch is working or not.
    Up to this data NO PATCH is working for this, so don't lose your time with bogus Micorosft "solved issue" claims




    Thursday, March 11, 2010 5:47 PM
  • wait til you try WPF...it is really slow.

    I believe that Microsoft has made simple things so complex that miles

    of unnecessary computation must be made

    Complexity is an ego trip. There was once COM.

    Under Qt 4,  I can  (in a few statements) display a table so that value changes are instantly

    reflected in the actual data base (MySQL)

    Friday, September 03, 2010 5:37 PM
  • right click on the toolbar and select "Debug". You will see some debug icon appears. One looks like  "Plus and two waves on it". It's name is "Show Threads in Source".  If it's been selected unselect it. For me that made the debugging much faster.
    Marquette uni
    Wednesday, September 29, 2010 11:33 PM
  • I had an issue similar to this and when I disabled the Google toolbar it was a lot faster.  I hope this helps. 


    John Chaffee
    Tuesday, April 12, 2011 1:09 PM
  • Try killing off all of your extraneous processes.

    Tuesday, February 21, 2012 6:04 PM
  • -or-

    2 You can go to project settings, Debug Tab, and uncheck 'Enable the Visual Studio hosting process'

     

    Using option 2, the IDE immediately works great - so I think there is a bug in the VS hosting process, or the way the IDE interacts with the VS hosting process.

    This option worked fine for me! Using Visual C# 2008 Express Edition..

    Wednesday, April 18, 2012 1:01 PM