none
Attaching the Script debugger to process 'iexplore.exe' on machine '' failed. A debugger is already attached.

    Question

  •  When i try to debug my aplication i receive this error message

    Attaching the Script debugger to process 'iexplore.exe' on machine '' failed. A debugger is already attached.

    I saw some posts about this error but i could not resolve my problem

    Someone can help with this?

    I have unistalling and re-installing my vs2010 and the vs2010 sp1 but the error continue.

    Wednesday, January 23, 2013 5:09 PM

Answers

All replies

  • Hi Fábio,

    Which kind of IE version are you using? Whether all similar apps have the same issue? To make sure that whether it is related to the IE settings, please reset your IE settins, and then uncheck “Disable Script Debugger (internet Explorer)” under Tools->Internet options->Advanced.

    Reference:

    http://msdn.microsoft.com/en-us/library/bb385613.aspx.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, January 24, 2013 9:56 AM
  • I just installed IE10 and am using VS 2010.  The solution that you mention, Jack, doesn't work.

    Friday, March 15, 2013 2:17 PM
  • Hi All,

         I do have the same issue , I am using VS 2010 and IE10 Browser. Tried debugging the web application project , got the below error .

    Already tried disabling debugging internet explorer option but no luck .:(

    Error :

    Attaching the Script debugger to process '[6768] iexplore.exe' on machine XXXXXXXXXX failed. A debugger is already attached.


    Ravishankar Maduri MCTS,MCPD,MCP

    Tuesday, March 19, 2013 9:58 PM
  • Start  commandprompt (run as admin) and run the following command:


    regsvr32.exe "%ProgramFiles(x86)%\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll

    Problem solved!
    Wednesday, March 20, 2013 3:05 PM
  • Great!!! this worked for me on 64 bit, VS2010 + IE10
    Monday, March 25, 2013 9:49 AM
  • Worked for me TX
    Wednesday, March 27, 2013 10:13 AM
  • Thanks Mojo Risin!  That worked for me also!  Hopefully they fix the root cause.
    Friday, April 05, 2013 1:59 AM
  • Worked! Thanks!

    Win7 32-bit, VS2010, IE10

    Friday, April 05, 2013 8:40 PM
  • Thanks! Totally Works!  Windows 7 x64 VS 2010

    Wednesday, April 10, 2013 10:23 PM
  • No lack with me. Anyone?  I've tried all of the above and still getting the same issue.
    Friday, April 12, 2013 7:09 PM
  • Sorry, but it did not work for me, either! Ed
    Friday, May 17, 2013 8:04 PM
  • The only thing that worked for me was to edit the Project's Properties that was running and enable the Silverlight Debugger on the Web Tab

    Wednesday, June 12, 2013 3:33 PM
  • Registering the msdbg2.dll from above worked for me on a 64 bit machine running VS2010.

    fieldb19

    Saturday, June 15, 2013 9:32 PM
  • regsvr32.exe "%ProgramFiles(x86)%\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll

    Worked...

    VS2010 IE10 Win64

    any behind the scene explanation?

    Tuesday, June 18, 2013 9:09 PM
  • Mine is win7, VS10, IE10

    I changed it like below and it worked for me.

    regsvr32.exe "%ProgramFiles%\Common Files\microsoft shared\VS7Debug\msdbg2.dll"

    Wednesday, June 19, 2013 3:10 PM
  • Editing the properties to enable the Silverlight Debugger worked for me, too (although my project was not a Silverlight project).  None of the other solutions did.  VS10, IE10.
    Tuesday, July 09, 2013 1:05 PM
  • I tried the Command Prompt thing and the IE-Tool-Options Advanced thing but either didnt work.

    Mine was a ASP.Net website in VS2010 and IE10.

    The only option that worked for me is in the ->Project Property Pages -> Click "Start Options" (In the Left side) > Check the option "Silverlight".

    This fixed the issue.

    Thank you Giovanni for the helpful response!


    Friday, July 12, 2013 3:04 PM
  • Excelente!!! Muchas gracias!

    My inglish is not very good looking

    Monday, July 15, 2013 6:00 PM
  • Solved for me too with the same configuration  64 bit, VS2010 + IE10.
    Thanx
    Friday, July 26, 2013 2:00 PM
  • regsvr32.exe "%ProgramFiles%\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll"

    worked for me

    thanks!!


    • Edited by NamithaKT Thursday, August 08, 2013 7:58 AM
    Thursday, August 08, 2013 7:58 AM
  • Thank you very much
    Thursday, August 08, 2013 9:11 AM
  • It worked for me on Win 7 Ultimate SP1 64 bit, VS2010 SP1 + IE10
    Saturday, August 10, 2013 5:31 PM