none
visual studio 2013 installation

    Question

  • I downloaded and installed Visual Studio 2013 Express. The install went perfectly.

    Unfortunately, there is no start  program in the Start Menu, no desktop icon and, no DEVENV.EXE icon pointing at this program as there is with VB2008 and 2010. While the program installed perfectly I can't use it

    Milt


    sirmilt

    Saturday, October 26, 2013 6:51 PM

Answers

  • Hi Milt,

    You should have a folder similar to c:\ProgramData\Microsoft\Windows\Start Menu\Programs\Visual Studio 2013. This is where the installer will lay down the shortcuts you see in the start menu.

    This folder and it's contents is either not getting installed, or something on your system may be removing it after the fact. While I haven't seen this exact problem, it's been my experience that odd behaviors like these most often occur when users attempt to customize their installations (both the OS and or the program being installed). For example, redirecting the user profile data to a different drive.

    Any of these things could potentially impact the installer. Given that this may be somewhat difficult to diagnose, and based on the behavior observed, I would encourage you to open a support request directly with Microsoft Tech Support. We have a team of support engineers that specialize in troubleshooting setup and installation issues. They can help verify if the installation was successful (or not) by evaluating your installation logs, and may be able to identify what's actually going on here.

    Sincerely, 


    Ed Dore

    Thursday, October 31, 2013 4:55 PM
  • Hi Milt,

    Setup and Install issues are always refunded. That being said, you've got to have a ProgramData folder somewhere on that system, otherwise you'd have a lot more than just Visual Studio missing from that start menu.

    You could try a reinstall of Windows, but I'd have though a simple repair/reinstall of VS would return the missing menu items.

    Again, have you may any sort of customizations to the original installation of Windows or VS? Can you search the hard drive and look for the actual .EXE (WDExpress.exe or VWDExpress.exe) I'm guessing you have WDExpress.exe which is the Express for Desktop SKU.

    Also, that ProgramData folder is likely hidden, so you may have to tweak your file explorer settings to actually see it.

    Sincerely,


    Ed Dore

    Thursday, October 31, 2013 9:14 PM
  • Thanks to all of you who tried to help. Every suggestion that was posted was tried and nothing worked. My PC is only six months old and I have been having a lot of problems with it and have finally come to the conclusion that Windows somehow got corrupted.

    As to the Visual Studio 2013 I found and deleted all files, ran the registry cleaner and will not attempt to try again until the Windows problem is resolved.

    Milt


    sirmilt

    • Marked as answer by sirMilt Wednesday, December 25, 2013 4:00 PM
    Wednesday, December 25, 2013 4:00 PM

All replies

  • Hi,

    which operating system are you running? If you're using Windows 8 or Windows 8.1 you can search for Visual Studio in the search (Windows key + Q).


    Best Regards. When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer. This helps us build a healthy and positive community.

    @Horizon_Net | Blog

    Sunday, October 27, 2013 1:32 PM
  • Thanks for the response.

    I am using Windows 7 Home Premium  64 bit.

    My PC is about  2 months old.  I have a copy of Windows 7 Professional that I purchased for my previous (now discarded) PC, would I be better off loading it into my PC?

    Milt


    sirmilt

    Sunday, October 27, 2013 3:17 PM
  • The Express editions do not use devenv.exe as the startup program.

    Look in a folder like this one:

    C:\Program Files(x86)\Microsoft Visual Studio 12.0\Common7\IDE

    You should find the startup executable there. Depending on the Express edition, the name will be something like WDExpress.exe or VWDExpress.exe

    Monday, October 28, 2013 2:12 PM
  • Thank you for the response.

    Unfortunately the folder you described does not exist.

    Could this be a Windows problem?

    Milt


    sirmilt

    Monday, October 28, 2013 2:32 PM
  • Hi ,

    To troubleshoot this issue , I need to confirm some information in the following:

    1. Could you let me know if  you have changed default  path when installing visual studio 2013? If you changed default  path when installing visual studio 2013,you should you find the file in  the relevant path.
    2. What’s the edition ( Visual Studio  2013 for web/Windows/Windows Desktop/Windows Phone or Microsoft Visual Studio Team Foundation Server Express 2013 ) ?
    3. Please let me know whether you download  visual  studio 2013 from our official website or not .

    If you  don’t download  visual  studio 2013 from our official website ,I would like to suggest you to download Visual  studio 2013 from our official website and reinstall again.

     4. Please check out if your OS meet System Requirements. For information about system requirements for Visual Studio 2013, platform targeting, and supported upgrade paths, see System requirements and platform compatibility 

    Hope these help.


    Lilia Gong <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, October 30, 2013 5:31 AM
  • Thank you for the response.

    Regarding your questions:

    1. No defaults were changed.

    2. Windows Desktop

    3. Downloaded from Microsoft website

    4. I believe it does, just purchased new from HP, 64 bit Windows 7

    I  had a similar problem with VS 2010 which loaded perfectly except for the start menu and I found the DEVENV.exe file, copied  the icon on the desktop and it works fine, but that doen't explain or permanently resolve the underlying problem.

    Is my next step doing a system of Windows?

    Milt


    sirmilt

    Wednesday, October 30, 2013 3:42 PM
  • Hi SirMilt,

    I still need to confirm  whether other installed softwares have similar  issue  or not ,if yes, I think that maybe it’s related to Windows  OS , I would like to suggest you to reinstall OS . If  only visual studio has these issue,  do you get any error messages during the installation process? If yes, post the detailed error logs here. Also you can consider  submitting a feedback on Connect site :

    https://connect.microsoft.com/

    Hope these help.


    Lilia Gong <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, October 31, 2013 6:43 AM
  • Hi Milt,

    You should have a folder similar to c:\ProgramData\Microsoft\Windows\Start Menu\Programs\Visual Studio 2013. This is where the installer will lay down the shortcuts you see in the start menu.

    This folder and it's contents is either not getting installed, or something on your system may be removing it after the fact. While I haven't seen this exact problem, it's been my experience that odd behaviors like these most often occur when users attempt to customize their installations (both the OS and or the program being installed). For example, redirecting the user profile data to a different drive.

    Any of these things could potentially impact the installer. Given that this may be somewhat difficult to diagnose, and based on the behavior observed, I would encourage you to open a support request directly with Microsoft Tech Support. We have a team of support engineers that specialize in troubleshooting setup and installation issues. They can help verify if the installation was successful (or not) by evaluating your installation logs, and may be able to identify what's actually going on here.

    Sincerely, 


    Ed Dore

    Thursday, October 31, 2013 4:55 PM
  • Ed

    I tried the support route with no success, and was referred to a Support desk that charged and I certainly was not about to pay for help installing a free program.

    Regarding the "ProgramData" folder, there is none, which surprises me and my guess is that I need to repair/reinstall Windows.

    Do you agree?

    Milt


    sirmilt

    Thursday, October 31, 2013 8:46 PM
  • Hi Milt,

    Setup and Install issues are always refunded. That being said, you've got to have a ProgramData folder somewhere on that system, otherwise you'd have a lot more than just Visual Studio missing from that start menu.

    You could try a reinstall of Windows, but I'd have though a simple repair/reinstall of VS would return the missing menu items.

    Again, have you may any sort of customizations to the original installation of Windows or VS? Can you search the hard drive and look for the actual .EXE (WDExpress.exe or VWDExpress.exe) I'm guessing you have WDExpress.exe which is the Express for Desktop SKU.

    Also, that ProgramData folder is likely hidden, so you may have to tweak your file explorer settings to actually see it.

    Sincerely,


    Ed Dore

    Thursday, October 31, 2013 9:14 PM
  • Hi Milt

    Maybe a dumb question - but did you look for "Visual Studio 2013" in the Programs menu - or search for "VS Express" in the search box?

    Because the 2013 Express version does not install as "Microsoft Visual Studio 2013" but as "Visual Studio 2013" instead.

    And if you installed the Web version, the IDE is started by "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\VWDExpress.exe" instead of "devenv.exe"

    Monday, December 23, 2013 11:29 AM
  • Thanks to all of you who tried to help. Every suggestion that was posted was tried and nothing worked. My PC is only six months old and I have been having a lot of problems with it and have finally come to the conclusion that Windows somehow got corrupted.

    As to the Visual Studio 2013 I found and deleted all files, ran the registry cleaner and will not attempt to try again until the Windows problem is resolved.

    Milt


    sirmilt

    • Marked as answer by sirMilt Wednesday, December 25, 2013 4:00 PM
    Wednesday, December 25, 2013 4:00 PM
  • I just had the same thing happen, installing from the Microsoft web site onto Windows 7 64-bit.  It sure spent a lot of time downloading and did not complain, but I cannot find what it installed.  I am baffled by the suggestion to reinstall the operating system.  What the heck is going on at Microsoft?  Do they care if their stuff works?
    Saturday, April 26, 2014 3:36 PM
  • Ok... searching by date let me to the install directory it created in "My Documents".  Apparently I need to run that.
    • Proposed as answer by ffg1992 Sunday, June 01, 2014 1:08 PM
    • Unproposed as answer by ffg1992 Sunday, June 01, 2014 1:14 PM
    Saturday, April 26, 2014 3:49 PM
  • If you are running windows 8, the problem is much simpler than anyone has proposed. It's a maddening feature of windows 8, nothing more.

    There are no icons created or any start menu items or even tiles created when you install visual studio express. Therefore, it is there, but you have no way to find it. Amazing!

    Also, on the tiled desktop, you can search for programs, but the free version is called VS Express, not Visual Studio or something else similar.

    My guess is when you could not find the icons or any way to launch the program, you believed that it did no install correctly. Then you started deleting things and the like and then by the time someone proposed that you use the search feature, Visual Studio was gone by that time.

    Reinstall, then use the tiled desktop search feature to search for VS Express. You will find it. Then when you figure out how to add the icon / shortcut to the desktop, let me know!

    Regards,

    Evan


    ffg1992

    Sunday, June 01, 2014 1:12 PM
  • Hello, 

    I have the same problem.  I installed/uninstalled too many times and looked everywhere but not able to launch vs 2013.   This is frustrated but at least i know somebody else is having the same issues. 

    I'll be watching this thread to see if other people have a better suggestions. 

    Thanks, 

    Sunday, June 08, 2014 5:55 PM